none
Bug 01 / 2015 Kinect 2 Gesture no longer works ? RRS feed

  • Question

  • Hi,

    Since 01/2015 my software using Kinect Gesture no longer works !!!

    - Windows 8.1
    - SDK KinectSDK-v2.0-PublicPreview1409
    - Demo using gesture crash

    I thought it was a change in my computer but it also crash other users of my software ...

    The code crash here  : 

    source = new VisualGestureBuilderFrameSource(Sensor, 0);

    Saturday, January 3, 2015 10:08 AM

Answers

All replies

  • Hi,

    Could you show me the error code or stack trace that you are getting ?

    Saturday, January 3, 2015 1:07 PM
  • Just a thought, does it help to re-copy the needed files from the redist folder to your application's folder?

    Maybe an auto update changed some internal dependencies. (certainly hope not!!)


    Brekel

    Saturday, January 3, 2015 3:28 PM
    Moderator
  • It also bread with SDK demo now. The Exception :

    A first chance exception 'System.InvalidOperationException' append in Microsoft.Kinect.VisualGestureBuilder.dll

    Informations supplémentaires : This API has returned an exception from an HRESULT: 0x80004005


    Saturday, January 3, 2015 6:44 PM
  • Can you confirm running the sample from the SDK Browser has the same issue?

    Carmine Sirignano - MSFT

    Monday, January 5, 2015 7:43 PM
  • Yes Carmine

    - Kinect\v2.0-PublicPreview1409\bin\DiscreteGestureBasics-WPF.exe crash with:

    Nom d’événement de problème:	CLR20r3
      Signature du problème 01:	DiscreteGestureBasics-WPF.exe
      Signature du problème 02:	2.0.1409.10000
      Signature du problème 03:	5410b5e8
      Signature du problème 04:	PresentationFramework
      Signature du problème 05:	4.0.30319.34004
      Signature du problème 06:	52467ee1
      Signature du problème 07:	7fe8
      Signature du problème 08:	fb
      Signature du problème 09:	System.Windows.Markup.XamlParse
      Version du système:	6.3.9600.2.0.0.256.48
      Identificateur de paramètres régionaux:	1036
      Information supplémentaire n° 1:	f8c3
      Information supplémentaire n° 2:	f8c3ffa6300645007e61ba9bb5a5ce18
      Information supplémentaire n° 3:	cae9
      Information supplémentaire n° 4:	cae937db740fec7d75c1a9048885d929
    
    But for others:

    - OK: BodyBasics-WPF.exe 
    - OK: ColorBasics-WPF.exe
    - KO: FaceBasics-WPF.exe
    - OK: CoordinateMappingBasics-WPF.exe
    - KO: HDFaceBasics-WPF.exe
    - OK: InfraredBasics-WPF.exe
    - KO: KinectFusionExplorer-WPF.exe

    That's really weird it's like if the new features of the SDK didn't work. Oh I did something I update ManyCam to latest version ?

    I think I have not install weird software. I have an other user with the same issue. It's a French Windows 8.1 64bit

    Does these .exe relies on a .dll or windows update or ? 

    Tuesday, January 6, 2015 6:36 PM
  • v2.0-PublicPreview1409 is not supported, the final version folder is "v2.0_1409" You need to uninstall all previews/drivers and install the released version of SDK:

    https://social.msdn.microsoft.com/Forums/en-US/5c3b67b6-3fe2-4789-b2df-eb63419e7ab6/kinect-for-windows-v2-sdk-now-available?forum=kinectv2sdk


    Carmine Sirignano - MSFT

    Tuesday, January 6, 2015 7:59 PM
  • I have the same problem / symptoms.

    Code :

    // create databases
    hr = CreateVisualGestureBuilderDatabaseInstanceFromFile(VGB_DATABASE_FILENAME, &pGestureDatabases[bodyId]);
    if (FAILED(hr))	{ printf("ERROR loading gesture database\n");	return; } // THIS IS SUCCESSFUL
    
    
    // create source
    hr = CreateVisualGestureBuilderFrameSource(pKinectSensor, 0, &pGestureSources[bodyId]);
    if (FAILED(hr))	{ printf("ERROR creating gesture source\n");	return; } // THIS FAILS
    
    		

    I have uninstalled "v2.0-PublicPreview1409" and installed  "v2.0_1409". All other Kinect projects run, but creating VGB source fails.

    Any more suggestions?

    Wednesday, January 7, 2015 1:00 AM
  • Yes ! it solve the problem I didn't thought the preview SDK was not the same than final SDK (because of release date) and there was a time bomb

    Thanks !

    Wednesday, January 7, 2015 8:08 AM
  • Problem is still not solved for me. As stated previously I have uninstalled "v2.0-PublicPreview1409" and installed  "v2.0_1409". All other Kinect projects and samples run, but creating VGB source fails as does the DiscreteGestureBasic-WPF sample.

    Error:

    The command "xcopy "C:\Program Files\Microsoft SDKs\Kinect\v2.0_1409\Redist\VGB\x86\vgbtechs" "C:\Program Files\Microsoft SDKs\Kinect\v2.0_1409\Samples\Managed\DiscreteGestureBasics-WPF\bin\x86\Debug\\vgbtechs" /S /R /Y /I" exited with code 9009. DiscreteGestureBasics-WPF

    It would be nice to get a solution suggestion or acknowledgement of bug, so I don't waste days trying to work around it.

    Friday, January 9, 2015 12:35 AM
  • This thread has been marked answered, by the person that created the question. If you are having similar issues, you should have posted a new questions and provided a link to this thread if it was related to your issue.

    Please post a new questions and we will discuss your issue further as there are steps you need to follow to ensure you have installed your SDK correct from preview, like did you completely uninstall all SDK and runtime components before installing the final release?


    Carmine Sirignano - MSFT

    Friday, January 9, 2015 6:49 PM