none
Cannot connect to Azure from VS2013

    Question

  • Hello,

    I'm trying to connect to Azure from Visual Studio 2013 (update 2) .

    For doing that, I go to the Server Explorer where I click to "Connect to Windows Azure"

    Then, a "login" window appears where I connect using a "Personal account".

    I have then the following message:

    ---------------------------
    Server Explorer
    ---------------------------
    An error occured during the sign in process: There was an error deserializing the object of type Microsoft.IdentityModel.Clients.ActiveDirectory.TokenResponse. Encountered unexpected character '<'.
    ---------------------------

    Can someone help me?

    Thank you

    Thursday, March 31, 2016 12:44 PM

All replies

  • Hi jcliebaert,

    Please try sign in your Azure account from website directly to confirm your Azure account is correct.

    Then please check whether there has any Azure SDK update for your current Visual Studio version. Please open menu Tools -> Extensions and Updates -> Updates. If there has any update for Azure SDK, please install it.

    If the SDK has been the latest, please install the latest update for your Visual Studio 2013 to check whether this issue can be fixed.

    After installing latest update, but the problem still exist, please try with following steps to troubleshoot this issue.

    1. Run your Visual Studio in safe mode to prevents all third-party VSPackages from loading when Visual Studio starts, thus ensuring stable execution.
    2. Close all third part software when running Visual Studio, such as antivirus.
    3. Repair your Visual Studio through Control Panel -> Programs and Features -> Visual Studio 2013 -> Change -> Repair.

    Best Regards,
    Weiwei

    • Marked as answer by jcliebaert Monday, April 4, 2016 10:09 AM
    • Unmarked as answer by jcliebaert Thursday, April 7, 2016 1:35 PM
    Friday, April 1, 2016 2:45 AM
    Moderator
  • Hello,

    The update of VS solved my issue.

    Thank you.

    Monday, April 4, 2016 10:10 AM
  • Hello,

    I come back with my issue (I had a problem with my PC so I have now a full fresh installation of VS). In reality, it doesn't really work better, excepted that I don't have error message anymore.

    What I'm trying to do is to add an account in the cloud explorer. After giving the username and the password, the window closes, but no account appears in the cloud explorer.

    Looking with fiddler, I see that the response of the last HTTP request (a POST to "https://login.microsoftonline.com/login.srf") is a 302-redirect (to location: "urn:ietf:wg:oauth:2.0:oob?code=xxx&session_state=xxx"), but there is no request for the redirection itself.

    I don't know whether it can have something to do with that, but I'm working behind a websense HTTP proxy and I needed to change the devenv.exe.config file to force VS to pass through the proxy.

    Any other idea?

    Thank you.


    • Edited by jcliebaert Thursday, April 7, 2016 2:29 PM
    Thursday, April 7, 2016 2:07 PM
  • Hi jcliebaert,

    >>What I'm trying to do is to add an account in the cloud explorer

    Does the cloud explorer that you mentioned means the Server Explorer in Visual Studio?

    Please sign in your Azure account from browser directly, if it can sign in successful, the problem is not related to your websense HTTP proxy. Please check your browser version, since Visual Studio 2013 is compatible with IE 11.

    If the problem is caused by the websense HTTP proxy, please refer to following link to configure your devenv.exe.config file. Hope it can help you.

    https://msdn.microsoft.com/en-us/library/dn771556.aspx

    Best Regards,
    Weiwei

    Friday, April 8, 2016 2:31 AM
    Moderator
  • Hi Weiwei,

    The "cloud explorer" I mentioned is the "cloud explorer" tool window. I just tried with the server explorer and it doesn't give better result.

    I'm well able to login to my Azure account from browser. 

    I have IE11.

    I already configured devenv.exe.config and it doesn't change anything.

    Monday, April 11, 2016 5:58 AM
  • Hi jcliebaert,

    After adding the <defaultProxy> node in the devenv.exe.config, do you have check the <settings> node under the <System.net> node? Please make sure the enabled property of ipv6 has been set to True.

    And after modify, please restart your Visual Studio to make sure the modified content will be used.

    Best Regards,
    Weiwei

    Tuesday, April 12, 2016 2:18 AM
    Moderator