none
Excel Add-in must support 2007 and beyond using VS 2012 & VS 2010 RRS feed

  • Question

  • I have an Excel add-in that I created in VS 2010.  The add-in is compatible with Excel 2007 and 2010 currently.

    I have just installed VS Premium 2012, including the optional Office Development Tools feature.

    I would like to work on my add-in in 2012, but I require my add-in to be compatible all versions of Excel 2007 - 2013.

    What are my options here?

    Edit: sorry about the text size, I don't know how it shrunk and I can't make it bigger.

    Friday, February 1, 2013 6:43 PM

Answers

  • i would stick with vs2010 since this is the last one that officially supports office 2007. Of course you can use vs2012 but you have to either manually bind against 2007 PIA or always make sure that functionality that you use is supported on 2007
    Friday, February 1, 2013 6:46 PM

All replies

  • i would stick with vs2010 since this is the last one that officially supports office 2007. Of course you can use vs2012 but you have to either manually bind against 2007 PIA or always make sure that functionality that you use is supported on 2007
    Friday, February 1, 2013 6:46 PM
  • That's disappointing.  Thank you the prompt response.
    Friday, February 1, 2013 7:15 PM
  • this is how it always has been - new VS version comes out and oldest technology is no longer supported, so from maintenance point of view stick with tool that supports lowest version and have faith that backward compatibility (which is very importnant for MS) will make that app work on new platform.
    Friday, February 1, 2013 9:27 PM