locked
The new HTML table control text alignment doesn't work RRS feed

  • Question

  • Hi,

    If I change the alignment to Right in the new table control, the output is Left aligned.

    It's there a way to fix the problem?

    Output

    Saturday, September 21, 2013 6:31 PM

Answers

  • Hi Daniel,

    Thanks for bringing this to our attention, I've forwarded it on to the appropriate team.  It appears that you can work around the issue by setting the label alignment to Hidden on the cells of your table.

    Regards,

    Burt

    Wednesday, October 2, 2013 7:20 PM

All replies

  • Hi Daniel

    I just noticed that there is a similar feedback about this issue before,  TextAlignment doesn't seem to work for Label & MoneyViewer controls in grids,  

    you could take a look at the following discussion: TextAlignment doesn't seem to work for Label & MoneyViewer controls in grids, if this is a simple project, it's recommended to re-do this project, and check whether it stall has same problem.

    If it still has same issue after re-do it, please don’t hesitate to let me know,

    Best regards,


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Friday, September 27, 2013 8:31 AM
  • Angie, that thread is in regard to Silverlight client whereas the OP is talking about the HTML client.


    Justin Anderson, LightSwitch Development Team

    Friday, September 27, 2013 8:37 AM
    Moderator
  • HI Justin

    Thanks for your reminder,

    I'm not sure what the root of this problem is, because I can hardly reproduce this problem, so I'd like to suggest to re-do this project(if this is not a big project).

    Best regards

    Angie xu


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, September 30, 2013 9:25 AM
  • Hi Angie

    This is what I did:

    Downloaded the "LightSwitch HTML Client Tutorial"

    Open it in 2013RC

    Create a HTML browse screen on customers

    Change the list to table, change Street property alignment to right. Same problem the output is always left align
    but if you use the Tile List option the alignments works.

    using internet explorer 10

    Tuesday, October 1, 2013 3:52 AM
  • Hi Daniel,

    Thanks for bringing this to our attention, I've forwarded it on to the appropriate team.  It appears that you can work around the issue by setting the label alignment to Hidden on the cells of your table.

    Regards,

    Burt

    Wednesday, October 2, 2013 7:20 PM
  • Burt, thanks for the help.

    Changing the label to hidden did the job.

    Daniel

    Thursday, October 3, 2013 12:07 AM
  • Except afterwards, your table column headers do NOT reflect that alignment and it looks awful. Had a very long back-and-forth about similar problem in SL Client grid some while back.

    Hopefully you guys can fix this too as it really does ruin the table's appearance; also its actually difficult to determine which value belongs to which column in many circumstances!


    Ian Mac

    Tuesday, October 15, 2013 11:42 AM
  • This issue is still the same.
    For the Right Text Alignment to work you can use all of the "Label Position" options except "None".

    Daniel

    Saturday, October 19, 2013 12:07 AM