Can't access my sites using ftp anymore!!!!!!


  • Hi everybody,

    I have 5 websites on windows azure and until last week I can access them throw ftp using filezilla and the credentials from the publish profile file.

    Today, I can't access those sites using ftp anymore!!!!! the sites are live but I'm getting the response: "530 User cannot log in."!!!!!!

    What is the problem? any thing changed on azure platform or azure is facing a problem in my region (sites are hosted in west europe and north europe)

    Anyone facing the same issue?

    Thank you for your help



    I also tried to use the deployment credentials but without success. Always the same error

    Wednesday, October 30, 2013 10:49 PM


All replies

  • Yup. Same here. No idea why. Trying to figure this out myself.
    • Proposed as answer by Benitah Thursday, October 31, 2013 8:01 AM
    • Unproposed as answer by Benitah Thursday, October 31, 2013 8:01 AM
    Thursday, October 31, 2013 12:40 AM
  • Ditto - I am having the same problem  One site is still active on the internet but I can't access it through Azure.  In the Dashboard, I have a red exclamation point by the website logo.  In addition, my websites are not listed with my databases.

    What's the problem?

    Thursday, October 31, 2013 1:19 AM
  • Same issue. 
    Thursday, October 31, 2013 5:38 AM
  • On the Service Health Dashboard, the recommendation is to post using Web Deploy or Git.  Looks like they are working on an issue with FTP.
    • Proposed as answer by Benitah Thursday, October 31, 2013 8:01 AM
    • Edited by Benitah Thursday, October 31, 2013 8:02 AM
    Thursday, October 31, 2013 7:59 AM
  • It doesn't matter if it is FileZilla or Web Deploy. Microsoft FTP service is down/broken and that's why it is not working. I'm having the same problem and so far everything I'm able to do is wait and try later again.

    Hopefully someone has made a ticket for Microsoft...

    Thursday, October 31, 2013 8:03 AM
  • Same for us.
    Thursday, October 31, 2013 9:55 AM
  • Thursday, October 31, 2013 10:04 AM
  • The team is actively working to resolve this FTP issue.

    In the meantime, you may want to look at the Kudu Diagnostic Console, which gives a convenient way of performing file operations, as well as running commands in your Windows Azure Web Sites.

    Here is a short screencast that shows it in action.

    We apologize for the inconvenience.


    Thursday, October 31, 2013 4:58 PM
  • This solution is not working. I'm getting error 404. I followed the screencast that you mentioned.

    when I access, I get

    404 - File or directory not found.The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    Thursday, October 31, 2013 5:44 PM
  • I can confirm that Kudu doesn't work either.

    I had some scripts that opened a KuduExec console, with saved parameters, and they also stopped working.

    Running kuduExec on
    { [Error: read ECONNRESET] code: 'ECONNRESET', errno: 'ECONNRESET', syscall: 'read' }

    Basically this means I cannot update sites, nor do the initial deployment in new ones.


    Thursday, October 31, 2013 6:03 PM
  • @Slim: that is strange. Is it even prompting you for credentials or do you get the 404 directly? To help isolate, can you try using Kudu Console on a new site? For the site that it doesn't work, is it a site that was created a very long time ago (e.g. 6+ months). If so, then enabling git publishing and then disabling it might fix the issue.

    @Joao: you are talking about KuduExec, which is a different tool you run locally, which which does have an issue that's being addressed. Please try the Kudu Console per my instructions above, and I suspect it will work fine.

    Thursday, October 31, 2013 6:12 PM
  • All my websites are 6+ months old.

    I'm getting 404 directly without prompting me for credentials

    I succeed to access Kudu console on a new site.

    your workaround worked :). enabling git publishing then disabling it fix this issue.

    just for other users, when you link a dummy repo with your website, be sure that this repo is empty, else, azure will get the bad ide to sync with that repo. Thanks god I didn't experienced that case because my dummy repo was empty, but azure displayed a message about this.

    Thank you david but I will keep this thread open until ftp comes back


    Thursday, October 31, 2013 6:53 PM
  • Hi,

    Kudu Console works, but
    - I have to add explicitly /DebugConsole; just adding the .scm and going to "/" gives me "access denied" instead of the page shown in the video;
    - if 1/3rd of the times gives timeout.

    How can I use it to deploy via Git?
    Do I do a git fetch/merge via the command line on the repository?
    Our deployment process is setup like this, and switching to WebDeploy is not an option.


    • Edited by JoaoCC Dev Thursday, October 31, 2013 6:57 PM additional feedback
    Thursday, October 31, 2013 6:54 PM
  • @Slim: if you just do "Set up from Source Control" and choose "Local git", then no actual deployment should happen until you git push something to it. But if you chose to do it from a Github repo, then it would indeed deploy from it. Sorry, I should have been more specific!

    @Joao: Kudu console is not related to deploying from git. Just use it to do basic file copying operations.

    Thursday, October 31, 2013 7:02 PM