locked
403 Forbidden error when trying to access Web Analytics reports RRS feed

  • Question

  • I have provisioned Web Analytics SA and started Web Analytics Data Processing Service and Web Analytics Web Service.

    When i go to
    CA > Monitoring > Reporting: View Web Analytics reports
    i get the error:

    Error
    An unexpected error has occurred.
    Troubleshoot issues with Microsoft SharePoint Foundation.
    Correlation ID: 358620b3-f318-4a47-ab67-2023693455a7

    When i look for the correlation ID in the trace log i find the following:

    08-13-2010 14:35:07.36 
    w3wp.exe (0x0508) 0x1038 
    Web Analytics Services Administration 
    c25h 
    Unexpected 
    Failed to get the server time zone id. Exception: System.ServiceModel.Security.MessageSecurityException: The HTTP request was forbidden with client authentication scheme 'Anonymous'. ---> System.Net.WebException: The remote server returned an error: (403) Forbidden.     at System.Net.HttpWebRequest.GetResponse()     at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)     --- End of inner exception stack trace ---    Server stack trace:      at System.ServiceModel.Channels.HttpChannelUtilities.ValidateAuthentication(HttpWebRequest request, HttpWebResponse response, WebException responseException, HttpChannelFactory factory)     at System.ServiceModel.Channels.HttpChannelUtilities.ValidateRequestReplyResponse(HttpWebRequest request, HttpWebResponse response, HttpChannelFactory factory, WebException responseException, ChannelBinding channelBinding)     at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)     at System.ServiceModel.Channels.RequestChannel.Request(Message message, TimeSpan timeout)     at System.ServiceModel.Channels.SecurityChannelFactory`1.SecurityRequestChannel.Request(Message message, TimeSpan timeout)     at System.ServiceModel.Dispatcher.RequestChannelBinder.Request(Message message, TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)     at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)     at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)    Exception rethrown at [0]:      at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)     at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)     at Microsoft.Office.Server.WebAnalytics.Administration.IWebAnalyticsWebServiceApplication.GetServerTimeZoneId()     at Microsoft.Office.Server.WebAnalytics.Administration.WebAnalyticsServiceApplicationProxy.<>c__DisplayClass5.<GetServerTimeZoneId>b__4(IWebAnalyticsWebServiceApplication channel)     at Microsoft.Office.Server.WebAnalytics.Administration.WebAnalyticsServiceApplicationProxy.ExecuteOnChannel(String operationName, CodeBlock codeBlock)     at Microsoft.Office.Server.WebAnalytics.Administration.WebAnalyticsServiceApplicationProxy.GetServerTimeZoneId() 7036ede3-4651-4909-8cfd-99550458411d

    And
    08-13-2010 14:35:07.36 
    w3wp.exe (0x0508) 
    0x1038 
    SharePoint Foundation Runtime 
    tkau 
    Unexpected 
    System.Net.WebException: The remote server returned an error: (403) Forbidden.    at System.Net.HttpWebRequest.GetResponse()     at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout) 7036ede3-4651-4909-8cfd-99550458411d

    If i look at Web Analytics from the WFE i get errors on both Site Web Analytics Reports and Site Collection Web Analytics reports:

    The remote server returned an error: (403) Forbidden.

    [WebException: The remote server returned an error: (403) Forbidden.]
       System.Net.HttpWebRequest.GetResponse() +1126
       System.ServiceModel.Channels.HttpChannelRequest.WaitForReply(TimeSpan timeout) +81

    [MessageSecurityException: The HTTP request was forbidden with client authentication scheme 'Anonymous'.]
       System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg) +10257978
       System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type) +539
       Microsoft.Office.Server.WebAnalytics.Administration.IWebAnalyticsWebServiceApplication.GetServerTimeZoneId() +0
       Microsoft.Office.Server.WebAnalytics.Administration.<>c__DisplayClass5.<GetServerTimeZoneId>b__4(IWebAnalyticsWebServiceApplication channel) +29
       Microsoft.Office.Server.WebAnalytics.Administration.WebAnalyticsServiceApplicationProxy.ExecuteOnChannel(String operationName, CodeBlock codeBlock) +352
       Microsoft.Office.Server.WebAnalytics.Administration.WebAnalyticsServiceApplicationProxy.GetServerTimeZoneId() +480
       Microsoft.Office.Server.WebAnalytics.Reporting.FrontEndDataRetriever.get_ServerTimeZone() +171
       Microsoft.Office.Server.WebAnalytics.Reporting.WebAnalyticsReport.OnInit(EventArgs e) +564
       System.Web.UI.Control.InitRecursive(Control namingContainer) +143
       System.Web.UI.Page.ProcessRequestMain(Boolean includeStagesBeforeAsyncPoint, Boolean includeStagesAfterAsyncPoint) +1477

    I run both CA and web apps using NTLM so i'm stomped as why im getting this error.

    Anders Rask


    Anders Rask
    Blog: http://andersrask.spoint.me
    Twitter: http://www.twitter.com/andersrask
    Friday, August 13, 2010 1:15 PM

Answers

All replies

  • Hi Anders Rask,

     

    Did you have SharePoint farm or just a stand-alone installation?

     

    If you had installed Microsoft SharePoint Server 2010 in a server farm environment with one or more application servers start the Web Analytics Data Processing Service and Web Analytics Web Service on the application server where the service will run.

     

    Try to start the Web Analytics Data Processing Service and Web Analytics Web Service on all supplication servers, then check the effect.

     

    Moreover, go to monitor-diagnostic logging, enable web analytics services category and its subsidiary items, then reproduce the error, post the error into the forum for further troubleshooting.

     

    For more information about Provisioning the Web Analytics Service Application on Microsoft SharePoint Server 2010, please refer to the following article:

     

    Step-by-Step: Provisioning the Web Analytics Service Application on Microsoft SharePoint Server 2010 Beta

    http://blogs.technet.com/b/wbaer/archive/2009/11/21/step-by-step-provisioning-the-web-analytics-service-application-on-microsoft-sharepoint-server-2010-beta.aspx

     

    Introducing Web Analytics in SharePoint 2010

    http://blogs.msdn.com/b/ecm/archive/2010/03/21/introducing-web-analytics-in-sharepoint-2010.aspx

     

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support
    Monday, August 16, 2010 6:57 AM
  • Hi Anders Rask,

     

    Did you have SharePoint farm or just a stand-alone installation?

     

    If you had installed Microsoft SharePoint Server 2010 in a server farm environment with one or more application servers start the Web Analytics Data Processing Service and Web Analytics Web Service on the application server where the service will run.

     

    Try to start the Web Analytics Data Processing Service and Web Analytics Web Service on all supplication servers, then check the effect.

     

    Moreover, go to monitor-diagnostic logging, enable web analytics services category and its subsidiary items, then reproduce the error, post the error into the forum for further troubleshooting.

     

    For more information about Provisioning the Web Analytics Service Application on Microsoft SharePoint Server 2010, please refer to the following article:

     

    Step-by-Step: Provisioning the Web Analytics Service Application on Microsoft SharePoint Server 2010 Beta

    http://blogs.technet.com/b/wbaer/archive/2009/11/21/step-by-step-provisioning-the-web-analytics-service-application-on-microsoft-sharepoint-server-2010-beta.aspx

     

    Introducing Web Analytics in SharePoint 2010

    http://blogs.msdn.com/b/ecm/archive/2010/03/21/introducing-web-analytics-in-sharepoint-2010.aspx

     

    Rock Wang


    Regards, Rock Wang Microsoft Online Community Support

    Hi,

    I am not getting Web Analytics Data Processing Service in Service Application List, and getting error when trying Site Action> Site settings >Site Web Analytics reports for any site collection.

    Any help regarding this one...
    Thanks n Regards, RB. Assigninfo EXPLORING NEW HORIZONS A-72, Sector 64 NOIDA (U.P) Off- +91-120-405-0000 Ext: 119 Mb. +91-9717266083 www.assigncorp.com
    Tuesday, January 11, 2011 8:31 AM
  • I've run into the same issue on my farm.  In my Test environment I had no problems with this, but the Production Farm gives me the error when trying to view the reports.  Though mine is slightly different:

    Failed to get the server time zone id. Exception: System.ServiceModel.ServerTooBusyException: The HTTP service located

    at http://localhost:32843/8e6691e12c3b4a6eab5ae0a9e7aaaa97/WebAnalyticsService.svc is too busy. ---> System.Net.WebException: The remote server returned an error: (503) Server Unavailable.

    at System.Net.HttpWebRequest.GetResponse()

    at System.ServiceModel.Channels.HttpChannelFactory.HttpRequestChannel.HttpChannelRequest.WaitForReply(TimeSpan timeout)

    Note: Servername is not really localhost...I just changed the entry in the log for the forum.

    Thursday, April 21, 2011 6:15 PM
  • I had the same issue. I was able to resolve it by stopping and then starting both the Web Analytics Data Processing Service and the Web Analytics Web Service.
    Thursday, May 31, 2012 1:57 PM