locked
Weird JS errors after upgrading to VS2019 (Program is fine.) RRS feed

  • Question

  • I upgraded from VS2017 to VS2019 the other day and ever since then, every time I attempt to test run my VB programs, I get these same six popup error messages:

    It doesn't matter what program I run, I get the same six error messages. The programs run just fine in VS2017. I tried disabling "Just My Code" in the Options, but it didn't help:

    Does anyone know the cause and how to fix this? It's very annoying. TIA


    Saturday, May 11, 2019 5:09 PM

Answers

All replies

  • Maybe you did not update Internet Explorer: https://developercommunity.visualstudio.com/content/problem/218740/vs2017-debug-javascript-files-not-working-1.html?

    In order to fix the issues 1, 3 and 5, you probably can try opening the mentioned plugin.vs.js file in any editor, go to line 1074 and remove the comma that appears in “portId: portId,”. Then start Visual Studio.

    Saturday, May 11, 2019 7:05 PM
  • Maybe you did not update Internet Explorer:

    .
    Ugh! I hope that's not the problem!

    I'm running Win7, and I have been unable to update IE beyond v9. MS did something ages ago that made updating IE impossible (I'm a PC tech and have yet to find a solution to this widely reported problem.)

    If VS2019 will only run if you have IE10/11 installed, then I guess I'm stuck using VS2017. :(

    I tried editing the .js file. Every time I fixed one line, the same error appeared further down the script. After fixing five such lines, the error changed to a "get" statement "missing a '.'" (ie: no prefix). I don't think rewriting the js script is the answer. :(

    Saturday, May 11, 2019 7:54 PM