locked
Help With Visual Studio 2012 error: Unable to access the IIS metabase. RRS feed

  • Question

  • Could someone please help:  I had Visual studio 2012 crash on my pc while running a asp.net web application project.  After I rebooted my computer and restarted Visual Studio 2012, I started getting this error when I try to open existing projects.   

    "error  : Creation of the virtual directory http://localhost:61471/ failed with the error: Unable to access the IIS metabase. You do not have sufficient privilege to access IIS web sites on your machine."

    I get this error when I try to create a new web application project.  "Web application projects are currently configured to use IIS Express.  To switch back to using the Visual Studio Development server, change the development server option under the Projects and Solutions/Web Projects category of the Tools/Options menu.  Configuring IIS Express failed with the following error:  Unable to access the IIS metabase.  You do not have sufficient privilage to access IIS web Sites on your machine."

    Note I have tried doing this "aspnet_regiis.exe -ga MyUserName" using the Visual Studio 2012 command Prompt as Admin.  Didn't help.  I have tried repairing the .Net Framework 4.5, it completed succesfully but didn't fix the issue. 

    Would anyone have any idea what is wrong, and how to fix this.

    Thanks

    Dave.

    Thursday, October 31, 2013 10:51 PM

Answers

  • Thanks to everyone that replied.  I tried all the above fix's including running Visual Studio 2012 as Administrator and nothing fixed the issue.  Then I found a post on a newsgroup that worked.  Here is the ansewer.  The problem appears to be a Windows 7 issue and not a Visual Studio issue, by turning off IIS and then turning it back on again it seems to reset the IISExpress setting and fixed the issue. 

    Thanks Again.

    Here is the Fix that worked.

    "I think we encountered a similar problem at work. For us, the solution was to go into Control Panel -> Programs and Features -> Turn Windows Features on or off... inside that, we had to select Internet Information Services -> Web Management Tools -> IIS 6 Management Compatibility -> IIS Metabse and IIS 6 configuration compatibility."

    • Marked as answer by Duckkiller53 Friday, November 1, 2013 3:13 PM
    Friday, November 1, 2013 3:13 PM

All replies

  • Thanks to everyone that replied.  I tried all the above fix's including running Visual Studio 2012 as Administrator and nothing fixed the issue.  Then I found a post on a newsgroup that worked.  Here is the ansewer.  The problem appears to be a Windows 7 issue and not a Visual Studio issue, by turning off IIS and then turning it back on again it seems to reset the IISExpress setting and fixed the issue. 

    Thanks Again.

    Here is the Fix that worked.

    "I think we encountered a similar problem at work. For us, the solution was to go into Control Panel -> Programs and Features -> Turn Windows Features on or off... inside that, we had to select Internet Information Services -> Web Management Tools -> IIS 6 Management Compatibility -> IIS Metabse and IIS 6 configuration compatibility."

    • Marked as answer by Duckkiller53 Friday, November 1, 2013 3:13 PM
    Friday, November 1, 2013 3:13 PM
  • Hi,

    Glad to see this issue has been resolved.

    Thanks,


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Monday, November 4, 2013 7:07 AM
  • I have windows 8.1 pro and using Visual 2013. This is the only solution that worked for me. I tried taking ownership of C:\Windows\System32\inetsrv and all sub folders then granting full control to no avail. And of course running Visual as admin didn't help either.
    Saturday, April 12, 2014 6:01 PM
  • I have the same setup as yours. I just installed VS 2013 Update 2 RC and immediately opened up a web project and got the meta base error. Nothing I tried fixed it until I found this post and did what you describe - simply enable the IIS Metabase option. All is well again.


    Friday, May 9, 2014 5:38 PM
  • I did enable the IIS Metabase option. Still getting the same error.
    Wednesday, August 20, 2014 6:02 AM
  • I ended up with removing all IIS features. I had to reboot after that, so I really don't know if the reboot fixed this, or if there is a conflict when both IIS and IIS Express are installed.
    Thursday, August 21, 2014 11:16 AM
  • Hi,

    I am little confused on your solution

    Are you saying that just by turning off IIS and then turning it back worked?

    or

    Go into Control Panel -> Programs and Features -> Turn Windows Features on or off... inside that, we had to select Internet Information Services -> Web Management Tools -> IIS 6 Management Compatibility -> IIS Metabse and IIS 6 configuration compatibility."

    Wednesday, August 27, 2014 8:03 PM