HDMI connection on dock is not working RRS feed

  • Question

  • I have a strange issue with the HDMI connector on the dock. It's not detected properly it seems. When I insert the tablet in the dock, power it on and have an external display connected, nothing is shown on the external display. After a while the external display goes to sleep.

    This is while having the display connected using a HDMI->DVI-D cable or a HDMI->VGA cable. 

    I can get it to work using the following funny workaround:

    1. Connect the monitor to the dock using one cable
    2. Connect the monitor to the tablet using the other cable
    3. Extend the display while the tablet is out of the dock (this has always worked)
    4. Insert the tablet into the dock (thus while doubly connected)

    This will make windows detect the external display and allows you to extend to it as you normally would. It will keep working until the device goes to sleep. After that undocking and redocking brings up the external display again.

    This is with the standard Windows 8 driver (1.2) from windows update. If I install the Windows 8 drivers from Intel, it behaves just the same.

    This seems like a driver/hardware issue with the dock. Any ideas? Updates?

    My blog: blog.jessehouwing.nl

    Wednesday, July 25, 2012 11:23 AM

All replies

  • I have a similar problem on my TV, though sometimes it's only the audio that doesn't work.

    What seems to work for me is this: connect the cable and extend the display; then switch the input of the external *away* from the right input, then switch it *back* to the correct input. That time it syncs.

    good luck!

    Tuesday, July 31, 2012 3:13 PM
  • Switch away where?

    My blog: blog.jessehouwing.nl

    Tuesday, July 31, 2012 3:37 PM
  • In my case, I'm connecting the tablet to a TV.

    The tablet is on the "HDMI2" input

    After connecting the cable and extending the desktop, I had to switch the TV away from HDMI2 to some other input, like HDMI1 using the Input button on the remote. Then switch the TV back to HDMI2 and this time it worked.

    Even if you're using a monitor and not a TV, you probably have an Input selector. Change that a couple times and see if that fixes it.

    Saturday, August 4, 2012 3:28 AM
  • I have the same problem. With Roger's solution the connection doesn't work. The tv remains in black screen. I tried different connections and none of them works but the microHDMI->TV and the tablet un-dock. I am really interested in a solution. Anybody can help with this?


    Sunday, August 12, 2012 3:25 AM
  • I was hoping this would be fixed with the RTM release. That is was software glitch. But it looks like it's still not working with Windows 8 RTM. The workaround is still working.

    My blog: blog.jessehouwing.nl

    Thursday, August 16, 2012 12:23 PM
  • I have the exact same issue on my S7S with Windows 8 Enterprise RTM installed.

    Connecting an external monitor using a HDMI-DVI Cable makes both displays go black.

    The Micro HDMI -> HDMI -> DVI (same Cable after Micro HDMI -> HDMI converter) works just fine, but only undocked. This is a problem since the WLAN (Option GTM67x PCIe) does not support WPA2-Enterprise properly with the "Windows Update Drivers" and I therefore need the dock to be able to use the Ethernet wired network instead. WPA2-Enterprise with user authentication works with very old Win7 drivers but those are buggy in different ways.

    I have the brand new Intel HD Graphics drivers for W8 installed http://downloadcenter.intel.com/SearchResult.aspx?lang=eng&ProductFamily=Graphics&ProductLine=Processor+graphics&ProductProduct=2nd+Generation+Intel%c2%ae+Core%e2%84%a2+Processors+with+Intel%c2%ae+HD+Graphics+3000%2f2000 ... but that did not help the dock's HDMI->DVI problems either.

    Did anyone get it to work yet?


    Thursday, August 23, 2012 12:00 PM
  • I'm working with Samsung Support to get it resolved, but since my device is a developer device I'm not entitled to the same support level as a retail user would get. Can you contact Samsung? I'm in contact with Sabrina from Samsung Support on Twitter. Please reference this twitter conversation should you want to contact through email or phone: https://twitter.com/jessehouwing/status/237664807413755904

    As for the Wifi driver, you can install the Windows 7 driver (download the latest version from the atheros website or from this mirror). From what I understand the real issue is that the Atheros Wifi driver understands Enterprise Wifi a little too well (it supports 802.11w under Windows 8) and that there is an issue with Cisco AP's that have this feature enabled. Last I heard Microsoft was working with Cisco to implement a fix to be deployed to the Access Points. For more information see: http://social.msdn.microsoft.com/Forums/en-US/samsungpcgeneral/thread/acb4b6f4-0808-4534-b31a-75fd5c075f76/

    And then you can use the "Hide Update" option to cancel out the driver Windows Update is trying to push.

    My blog: blog.jessehouwing.nl

    Thursday, August 23, 2012 12:23 PM
  • Samsung support came back with the results of their investigation: The slate and docks drivers are designed for win7 and don't yet support win8. No news on when or if a driver will become available...

    My blog: blog.jessehouwing.nl

    Saturday, August 25, 2012 2:36 PM
  • i think this is a Win8 RTM issue. I'm seeing the same thing on several laptops with different adapter manufacturers... all external displays fail the drivers.
    Tuesday, September 18, 2012 10:46 AM
  • I've had my slate7 for about 8 months- windows 7 - dock and monitor worked well until a week ago, then the monitor stopped working.  Suggests to me that this is not just a win8 problem. I've had the same experience with the work-arounds as noted previously.  Was there possibly a "bad" driver update that I automatically downloaded that caused this?  Thanks for your comments - I'm just an average user - not a pro like others who have replied.
    Thursday, September 27, 2012 3:48 AM
  • @larry. Can't really help you. I wish I could. What you can do is contact Samsung on twitter or through their support system. If you want to, quote this thread. I'm still waiting for the issue to be resolved.

    My blog: blog.jessehouwing.nl

    Monday, October 8, 2012 2:09 PM