none
Publishing in EW2 very slow after installing Joomla to subdomain RRS feed

  • Question

  • I'm managing a website that is currently in HTML/CSS. I'm using EW2 to maintain the current site until I can migrate it over to Joomla. In order to test and experiment with creating a new site (templates, etc.), I have created a subdomain called "test" and installed Joomla to it.

    Before I created this "test" subdomain, it was very fast to publish changed/new files from EW2 to the HTML primary site (it's a very small site). However, since installing Joomla publishing to the subdomain, publishing to the main site has been extremely slow (up to 5 minutes before it finally starts the file transfer), even though EW is not publishing anything to the subdomain at all. I've noticed a similar slow-down with another site I have too.

    My best theory is this: because the subdomain is actually installed in a folder called "test" that is off the root directory of the main site, EW is assuming it's part of the main site and is taking inventory of the "test" folder and all subfolder files, even though it's a separate domain (or at least not part of the main site). Since Joomla seems to install a LOT of files, I suspect this is what's slowing it down.

    Can anyone confirm that this is what's causing the slow-down? And is there any way to tell EW2 to ignore that folder, or to recognize that there's a subdomain installed there that it can/should ignore?

    I doubt any more info can be had by looking at the site, but here are the URLs: the main site is www.astrologytoronto.ca and the test site is www.test.astrologytoronto.ca.

    Thanks in advance for any help with this.


    Monday, November 15, 2010 2:00 AM

All replies

  • I don't know if this will resolve your issue, because I've not created a subfolder with that many files in it, but you can right-click the subfolder in the Folder List panel (or in Site View, IIRC) and select "Do not publish." Again, I have not monitored the pre=publish "inventory" timing with a subfolder of that size, but that may prevent EW from spending the time to look for conflicts in the subfolder. What the hey, it doesn't take long to try it, and it may just solve the problem. Worth a shot...  ;-)

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Monday, November 15, 2010 3:12 AM
  • Thanks for your reply, Scott. Yes, I've heard that suggestion before. Unfortunately, in EW2 the "don't publish" is greyed out for folders - it only works for files. Also, it doesn't seem to work at all in the remote host files or folders; only for the local computer's files.

    Starhugger

     

    Monday, November 15, 2010 4:31 AM
  • Hmmm, seems to me there was another solution suggested here back when EW2 was current. Right-click the folder in the Folder List and see if there isn't an option to "Convert to Web" (or maybe it was Convert to Subsite; going from memory here). I think that makes EW2 treat that folder as a separately administered subsite that publishes separately.

    Been a while, but check that, and if it exists, give it a shot. And please report back; I'd like to know if it works, and it would be helpful to have the information in the message archives. Thanks.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Monday, November 15, 2010 5:55 AM
  • If you are using meta data then make the Joomla folder a subweb - right click on the folder and choose "Convert to web"
    EW1 and EW2 will completely ignore subwebs - unfortunately EW3 and EW4 don't when publishing (but do for all other operations).


    Ron Symonds
    Microsoft MVP (Expression Web)

    www.rxs-enterprises.org/fp
    Monday, November 15, 2010 9:48 AM
  • EW1 and EW2 will completely ignore subwebs - unfortunately EW3 and EW4 don't when publishing (but do for all other operations).

    Hmm -- talk about a step backwards ---

    ClarkNK, A.K.A. HomePage Doctor
    HomePageDoctor.com -- Expression Web database tutorials
    Ownertrades.com -- Created with FP, Access, Bots and Wizards
    MyNumbersTracker.com -- Created with Expression, VWDExress, SQL Express, and ASP.NET.
    Monday, November 15, 2010 1:20 PM
  • Thanks, Scott and Ron, for the suggestion. I tried doing that and then did a test-publish (after making an insignificant change to a page) and it still took forever. It won't let me "convert to web" in the remote host window. In the local computer window, I tried both creating a folder by the same name (including the same spelling, capitalization, etc.) and converting to web, as well as having EW2 create a new subsite by that name. Neither method seemed to make any difference. :-/ Maybe if I have it create the subsite on the server and then reinstall Joomla to that folder...?? I dread such a complex and time consuming experiment but maybe that's my best next attempt. Any other suggestions before I do that?

     

    Edited: By the way, the option to use meta data (site options) is greyed out for me. ??? Maybe that's why I can't get EW to acknowledge the subsite? What might be preventing that option from being accessible?

    Thanks.

    Wendy

    • Edited by Starhuggrrr Tuesday, November 16, 2010 8:45 PM Afterthought
    Tuesday, November 16, 2010 8:21 PM
  • It should work to create a local folder with the identical name of the remote joomla folder, and make the local folder a subweb.

    For EW2, make sure the Publishing tab of the Remote Website Properties for your local copy of your site does not have "include subsites" checked.

    Tuesday, November 16, 2010 8:29 PM
  • Hi Kathy,

    Thanks for replying. Unfortunately, it doesn't work on mine. I checked and I don't have "include subsites" checked. So I'm baffled why it's not working; nor why my option to include metadata is greyed out.

     

    Wendy

    Tuesday, November 16, 2010 11:40 PM
  • Your option for metadata is greyed out because the folder your websites is in is considered a site.  (Silly default behavior for some folders, such as My Web Sites, in your version of EW.  I don't know if that has changed in later versions.)  Open that folder as a site, and remove the metadata from it.  The site or sites inside it should now have the metadata option enabled.
    Tuesday, November 16, 2010 11:44 PM
  • Thanks Kathy, but I'm not sure how to go about doing that. The folder that contains the root directory of the site on my hard drive has the EW website icon, which AFAIK means EW regards it as a true website. It does have the two hidden folders that (I think) are supposed to contain the metadata: _vti_cnf and _vti_pvt. I tried deleting the files in those folders (after backing them up) but it still hasn't made the metadata option available.
    Wednesday, November 17, 2010 5:58 AM
  • You delete metadata by unchecking the metadata option after opening that folder as a site in EW.

    Wednesday, November 17, 2010 6:07 AM
  • Kathy, won't the option be grayed out as long as the folder remains within the folder (My Web Sites?) that caused it to be grayed out to begin with? Or, by "Open that folder as a site...", were you meaning for him to open the containing folder, rather than the one he is working in, which is what I believe he may have taken your meaning to be?

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    Wednesday, November 17, 2010 6:41 AM
  • Scott, I was very clear:

    " the folder your websites is in is considered a site.  (Silly default behavior for some folders, such as My Web Sites, in your version of EW.  I don't know if that has changed in later versions.)  Open that folder as a site, and remove the metadata from it. "

    The following posts were clearly referring to that folder.

    Wednesday, November 17, 2010 7:35 AM
  • If you are using FTP to Publish, then you cannot convert a folder in the remote site to a subweb - this conversion requires meta data which is only available in the local web, or on servers running FrontPage extensions.
    Converting the folder to a subweb in the local web should work in EW1 and EW2 (if meta data used).  I use this technique for my site, where the subwebs contain over seven thousand media files. EW2 ignores the subwebs completely when publishing, and starts uploading a minute after clicking the Publish button, whereas EW3 and EW4 search the entire "remote" site for unmatched/changed/conflict files and (after an hour or so) find over 7000 of them in the subwebs - usually unmatched because they are not in the web being published.
    With FrontPage extensions on the server, all 4 versions of EW ignore the subwebs completely.


    Ron Symonds
    Microsoft MVP (Expression Web)

    www.rxs-enterprises.org/fp
    Wednesday, November 17, 2010 8:51 AM
  • I'm totally confused now. I was finally able to figure out how to delete the metadata by unchecking the parent directory's site option (MyWebSites), but this completely severed all identification EW had of my websites (I have more than one in that parent folder). How do I now get EW to treat each one as a website? And how will any of this enable me to get EW to ignore a subdomain on the hosting server?
    Thursday, November 18, 2010 12:10 AM
  • I'm definitely not going back to FP extensions. It was like trying to get off crack to unhook my website from them the first time. ;-) I'm not in a position to upgrade to a later version of EW either.

    It looks like my sites were already using metadata by default, but now all that is gone. I've made backups, but I don't know that simply copying them back to the same place will necessarily restore EW's recognition of them as websites now. And so far I haven't been able to re-establish that relationship through EW.

    If I can get that relationship back between EW and my local site folders/files, how would I create a subweb in a way that will enable EW to treat the corresponding folder on the server as something it should ignore? I had already tried simply creating a new file and/or subweb on my local drive, but EW didn't seem to make the connection between the folder of the same name on the server and the one on my local drive - at least, it didn't speed up the publishing time; it was still disproportionately slow. So I'm not sure what I should do that's different now.

    Thursday, November 18, 2010 12:18 AM
  • "I'm totally confused now. I was finally able to figure out how to delete the metadata by unchecking the parent directory's site option (MyWebSites), but this completely severed all identification EW had of my websites"

    It should not have done that unless they were not websites to begin with.  It did not have that effect when I did it.

    Regardless, just open each directory as a site, and turn metadata on.  Add the publishing information if that has been lost.

    "And how will any of this enable me to get EW to ignore a subdomain on the hosting server?"

    Removing metadata was in response to your post that yours was greyed out, not about using subsites.

    As to EW2 ignoring files inside directories identified as subsites, when publishing, EW2 should simply do that.  I have no idea why it isn't for you.

    Thursday, November 18, 2010 2:18 AM
  • When I try to open the website's folder (one of several subfolders of MyWebSites, each of which was a website) as a site, it keeps wanting to apply the metadata to MyWebSites. In trying to do this, I right-clicked on the website's root folder (the subfolder of MyWebSites) but it wouldn't apply metadata or website attributes to that folder.

    I tried to force the name of a website in MyWebSites (in the name of website input field of the Site Options window) and clicked the metadata option, it gave me an error message ("cannot rename...MyWebSites"). It then took some of the folders in MyWebsites and turned them into websites (they have the icon in the folder view) ...but not for the current websites I'm working on (two in particular). It was applied to old websites and development websites. When I tried to get EW to acknowledge one of my current sites' folder, it still just wants to default to MyWebSites.

    So I tried unclicking the metadata option for MyWebSites and the website icons disappeared (just plain folder icons now). Even when I tried to recheck metadata, the site icons aren't coming back again, even after I reload EW.

    Is there something else I should be doing to "open a folder as a site"?

    Thursday, November 18, 2010 3:42 AM