none
cannot open infopath form

    Question

  • When I try to open the form from Sharepoint, I get an error message that there is an error in calculation, upon further detail:InfoPath
    Your user name cannot be verified because the form's security settings do not permit it.

    Error occurred during a call to property or method 'get-UserName'.

    I have since changed security to allow full access and deleted the formula that calls for username & still cannot open. I can open via Sharepoint editor, but not when I try to create a new document from sharepoint.

    Any suggestions??

    Friday, June 17, 2011 4:38 PM

Answers

  • Hi Andrew,

     

    Thanks for your post.

    Please try to add the SharePoint site to the “Intranet site” in IE browser. Here is a similar issue about this issue:

    http://blog.michaellotter.com/category/0a09090909-InfoPath-Forms-Services0a-0a090909.aspx

     

    It’s not an InfoPath security problem. Share your views.

     

    Thanks,

    Wayne

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    Monday, June 20, 2011 6:17 AM
  • There is no security setting that allows full access.  If you mean you set the form to Full Trust, then definitely do not do that - change it back to domain.

    The form surely needs to use the userName() function to operate properly, right?  I wouldn't remove that.  If you can't simply use the userName() function, then something else is very wrong and needs to be fixed.

    What is SharePoint editor?  I've never heard of that, and it wouldn't help when opening an InfoPath form template - nothing else can open an InfoPath form template.

    You told us the error when trying to get userName(), but you didn't tell us the error after removing the formula that used it.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Friday, June 17, 2011 9:55 PM
  • Hi Andrew,

     

    Would you please let us know how is your problem going? Is the suggestion helpful for your issue?

    If you need further assistance, please feel free to let us know.

     

    Thanks,

    Wayne Fan

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.

    Friday, June 24, 2011 1:40 AM

All replies

  • There is no security setting that allows full access.  If you mean you set the form to Full Trust, then definitely do not do that - change it back to domain.

    The form surely needs to use the userName() function to operate properly, right?  I wouldn't remove that.  If you can't simply use the userName() function, then something else is very wrong and needs to be fixed.

    What is SharePoint editor?  I've never heard of that, and it wouldn't help when opening an InfoPath form template - nothing else can open an InfoPath form template.

    You told us the error when trying to get userName(), but you didn't tell us the error after removing the formula that used it.


    SharePoint Architect || Microsoft MVP || My Blog
    Planet Technologies || SharePoint Task Force
    Friday, June 17, 2011 9:55 PM
  • Hi Andrew,

     

    Thanks for your post.

    Please try to add the SharePoint site to the “Intranet site” in IE browser. Here is a similar issue about this issue:

    http://blog.michaellotter.com/category/0a09090909-InfoPath-Forms-Services0a-0a090909.aspx

     

    It’s not an InfoPath security problem. Share your views.

     

    Thanks,

    Wayne

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

    Monday, June 20, 2011 6:17 AM
  • Hi Andrew,

     

    Would you please let us know how is your problem going? Is the suggestion helpful for your issue?

    If you need further assistance, please feel free to let us know.

     

    Thanks,

    Wayne Fan

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact  tnmff@microsoft.com.

    Friday, June 24, 2011 1:40 AM


  • Please try the following: 

    In InfoPath 2013, Go to: File > Info > Form Options (Advanced Form Options) > Security and Trust. Change options to Full Trust. (The form has access to files and settings on the computer).
    Thursday, April 9, 2015 10:19 PM