locked
SSMS Minimum Rights RRS feed

  • Question

  • Hi,

    I can rdp (rdc connection) into a sql server having user rights. When I tried to open SSMS, I got "SQL Server Management Studio Package failed to load".

    What are the min rights required ? I've been granted read & write to c:\program files\sql server

    Please advise.

    TIA !
    Thursday, July 16, 2009 7:30 AM

All replies

  • Hi,

    It can be there due to many reasons.

    #1 IF you are using SQL Server 2005 make sure you have on latest version of SP. If SP is not upto date this error happens.
    #2 If you are clicking on short cut of the SSMS, go to physical folder and try it from there.

    Kind Regards,
    Pinal
    Pinal Dave
    Founder - http://blog.sqlauthority.com
    Search SQL Solutions
    Friday, July 17, 2009 8:25 AM
  • Hi,

    I'd tried on other systems and usually User privilege is sufficient.

    I guess there're some hidden restriction at the OS level on that machine that gave me the errors.

    Thanks !
    Friday, July 17, 2009 9:28 AM