How to ignore prefix/namespace RRS feed

  • Question

  • I have a schema which defines no namespace URI and no prefix for all elements/attributes. But our customers occasionally use prefixes in their xml documents.

    I want to map the incoming xml documents with/without prefixes against my schema. But it doesnt work. BTS2010 complains and throws an error.

    Output validation error: Could not find schema information for the element 'http://www.homepage.de:element'.

    So my question is: Is it possible to map incoming xml documents with prefixes when I have a schema which defines no prefixes/namespaces at all?

    Monday, October 4, 2010 9:37 AM


All replies

  • Hi albix,

    You can use the Add/Remove Namespace pipeline component for this purpose.

    Have a look into this.




    Abhijit Mahato - MCTS BizTalk Server blog: http://abhijitmahato.wordpress.com/ Please "Mark as Answer" if Post has Answered the Question
    Monday, October 4, 2010 9:53 AM
  • Thanks Abhijit,

    I have installed ESB Toolkit 2.1 and I have Microsoft.Practices.ESB.Namespace.PipelineComponents.dll in my BTS 2010 Pipeline Components folder. But when I look in my toolbox of my custom pipeline I have no add/remove namespace components to choose from. ?? I am stucked. What else do I have to install to use the namespace pipeline components. I am running Windows 7/BTS 2010/Windows SDK 7.1/etc. And I did reference the assembly (Microsoft.Practices.ESB.Namespace.PipelineComponents.dll) in my project.


    RESOLVED!! Choose items did it...

    Monday, October 4, 2010 4:20 PM
  • Just to complete the thread for people having the same issue.

    In Visual Studio you will need to enable this components. Use Tools / Choose Toolbox Items / BizTalk Pipeline Components, browse for the assemblies and enable them. Afterwards it will show up in the pipeline toolbox.

    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver


    Monday, October 4, 2010 6:24 PM