locked
Right click on script”run with PowerShell” RRS feed

  • Question

  • I have set the execution policy in GPO to remoteSigned, and it is working fine, when I run the script from cmd prompt powershell –f

    When I right click the script and choose “run with PowerShell” it starts with this text in red

    Set-ExecutionPolicy : Windows PowerShell updated your execution policy successfully, but the setting is overridden by a policy defined at a more specific scope.  Due to the override, your shell will retain its current effective executionpolicy of RemoteSigned

    The script is working, but it do not look right for a user of the script.

    Sometimes when I run the script “run with PowerShell” it prompts the user to overwrite policy, again no matter if I choose yes or no, the script will run.

    I am running on Windows 8.1 Update 1 x64, Powershell 4.0

    Do anyone know how to fix?

    Kind Regards

    Jens

     


    Jens Lund

    • Moved by Bill_Stewart Tuesday, April 7, 2015 3:15 PM Abandoned
    Thursday, February 26, 2015 1:32 PM

All replies

  • There is another Group Policy setting that is setting a different policy. Post in the GP forum to get help with fixing this.

    Possibility #2.  You are setting the policy in your profile or on the command line.


    ¯\_(ツ)_/¯

    Thursday, February 26, 2015 4:01 PM