locked
Issues processing with Oracle data source RRS feed

  • Question

  • I am getting processing failures for a ssas database pointign to an Oracle source.

    I am developing locally, and deploying to a dev server. The DSV points to an Oracle database and all tables are viewable & explorable (i.e. Explore Data)

    The TNS names entry exists in both my desktop & dev server.

    When I deploy to dev server, the ssas database deploys fine, but processing fails due to "ORA-12154 TNS could not resolve the connect identifier specified".

    If I remote desktop to the dev server, open the ssas database directly, open the data source & test connection: it succeeds. If I then process the cube, it fails with the same error above. When I look at the DSV from the dev server, I can explore the data in the tables.

    So why can I connect & explore the data, even locally, but not process the cube?

    Impersonation is set to inherit, and the password is saved in the connection.

    I have a second ssas database, pointing to a DIFFERENT Oracle database, and it processes fine.

    I am not sure what versions of oracle the Oracle databases are, but can find out - if this is a potential reason.

    Thursday, September 8, 2011 10:04 AM

Answers

  • FYI - Issue solved. Destination server had two installations of Oracle, one 32bit & one 64bit. Quite simply, the TNS entry was in 32bit rather than 64.

    Occam's Razer, case in point.

    • Marked as answer by Ben WattMVP Friday, September 9, 2011 11:34 AM
    Friday, September 9, 2011 11:34 AM