locked
Is it possible to configure device channels for team site? RRS feed

  • Question

  • I am trying to configure device channels for one of my existing sites and it is not working (no UI difference from device to device). It is working well if I create a new publishing site however I want to achieve the same for my existing team site. I have deactivated the mobile browser feature and activated the publishing site and site collection features but still not working. Is it at all possible to configure device channels for team sites? If yes, please share the steps. If not, is there any alternative solution for this?

    Thank You.

    Monday, November 2, 2015 9:04 PM

Answers

  • I suspect your issue is related to the master page that you are using.  By default the device channel changes the custom.master masterpage which is the one used in Publishing Page layouts.  IT doesn't change the default.master, which is the one used in publishing _Layout pages.  The problem is that by default team sites use the default.master for all pages so when you specify the new master page for the channel it doesn't change the master page being used.  Create a custom Team site page that uses the custom.master and see if the device channel doesn't then apply to that page also.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by Victoria Xia Monday, November 23, 2015 8:51 AM
    • Marked as answer by Victoria Xia Friday, November 27, 2015 11:10 AM
    Tuesday, November 3, 2015 12:03 AM

All replies

  • I am trying to configure device channels for one of my existing sites and it is not working (no UI difference from device to device). It is working well if I create a new publishing site however I want to achieve the same for my existing team site. I have deactivated the mobile browser feature and activated the publishing site and site collection features but still not working. Is it at all possible to configure device channels for team sites? If yes, please share the steps. If not, is there any alternative solution for this?

    Thank You.

    • Merged by Dennis Guo Tuesday, November 3, 2015 6:54 AM the same question
    Monday, November 2, 2015 7:32 PM
  • I suspect your issue is related to the master page that you are using.  By default the device channel changes the custom.master masterpage which is the one used in Publishing Page layouts.  IT doesn't change the default.master, which is the one used in publishing _Layout pages.  The problem is that by default team sites use the default.master for all pages so when you specify the new master page for the channel it doesn't change the master page being used.  Create a custom Team site page that uses the custom.master and see if the device channel doesn't then apply to that page also.

    Paul Stork SharePoint Server MVP
    Principal Architect: Blue Chip Consulting Group
    Blog: http://dontpapanic.com/blog
    Twitter: Follow @pstork
    Please remember to mark your question as "answered" if this solves your problem.

    • Proposed as answer by Victoria Xia Monday, November 23, 2015 8:51 AM
    • Marked as answer by Victoria Xia Friday, November 27, 2015 11:10 AM
    Tuesday, November 3, 2015 12:03 AM
  • Hi Pavan,

    Here is a link for your issue as reference:

    http://sp2013.blogspot.jp/2013/07/sharepoint-branding-team-sites-on.html

    Best regards,

    Aaren liu


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Wednesday, November 4, 2015 3:41 AM
  • Hi Pavan,

    We have not heard from you in a couple of days. Is there any updates?

    If Paul's reply is helpful, please remember to mark it as answer so that others with similar issue can benefit from it.

    Best regards,

    Aaren liu


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, November 13, 2015 7:30 AM