none
Event id 3040: 'VM' could not initialize. RRS feed

  • Question

  • I have a recently installed Windows Server 2008 R2 system (full install) and have added (and removed and re-added) Hyper-V. However, when I try to create a new VM, I always get event 3040 logged, 'VM' could not initialize'. Having searched the event logs, I can find no other errors, except perhaps even 14050, 'Failed to register principal name'. The only fix I found for this (permissions on the SELF and SYSTEM entries in the machine account in AD) does not apply (rights are allowed). Would this cause event 3040? I've checked all file permission on the virtual machine and disk folders (even trying setting them to Everyone-FullControl).

    The first question is how do I find out what's causing the initializations to fail, since there doesn't seem to be any information logged anywhere in the event viewer.

    After that, the second question will be to fix the problem. :-)

    Thank you in advance.

    Thursday, July 8, 2010 4:03 PM

All replies

  • Hello,

    Check please if you have in the Bios of the server virtualization technology enabled and DEP.

    Regards.

    Monday, August 30, 2010 9:40 PM
  • Re 1 & 2, I presume you can't be bothered to read the previous reply?
    Monday, September 20, 2010 8:42 AM
  • And, for info, hypervisorlaunchtype is already set to auto.

    Windows Boot Loader
    -------------------
    identifier              {current}
    device                  partition=C:
    path                    \Windows\system32\winload.exe
    description             Windows Server 2008 R2
    locale                  en-US
    inherit                 {bootloadersettings}
    recoverysequence        {2b208bb3-82f4-11df-b7e1-ee3bd200c5ff}
    recoveryenabled         Yes
    osdevice                partition=C:
    systemroot              \Windows
    resumeobject            {2b208bb1-82f4-11df-b7e1-ee3bd200c5ff}
    nx                      OptOut
    hypervisorlaunchtype    Auto

     

    Monday, September 20, 2010 8:45 AM
  • Found your solution. Go here, read the article, scroll down to the Microsoft link and download the hotfix. Worked for me!
    Wednesday, January 25, 2012 3:32 PM