none
Registry Permission Problem?

    Question

  • For some reason I'm unable to create a new file for Visual Studio 2015. I am able to open a Visual Basic file from 2010, but I just can't create a new form for some odd reason. It gives me this message:
    "Visual studio does not have permissions to read the template information from the registry. this is often caused by registry permission problem."

    Does anyone have any solutions? I have tried turning my anti-virus off, yet the problem still occurs.

    Thursday, December 10, 2015 4:24 AM

All replies

  • Hi Rafat,

    Thanks for your post.

    Are you a administrator on your OS? Do you have the permission to access this location:
    C:\Users\xxxxx\Documents\Visual Studio 2012\Templates\

    If  you have the administrator authority. I suppose if the cause is in your VS.

    I suggest you could repair your VS . Then try it again,

    If still give the same prompt message. I suggest you could  use the collect.exe  to collect the installation logs. After using it, you will find vslogs.cab from %temp% folder.

    Then upload the file to https://onedrive.live.com/   and share the link here.

    If still no help. I suppose if you have no full registry access.

    In this case, you could refer to the following link which could be helpful to you.

    http://superuser.com/questions/740142/visual-studio-2012-project-creation-failed

    Note: This response contains a reference to a third party World Wide Web site. Microsoft is providing this information as a convenience to you.

    Microsoft does not control these sites and has not tested any software or information found on these sites;

    Therefore, Microsoft cannot make any representations regarding the quality, safety, or suitability of any software or information found there.

    There are inherent dangers in the use of any software found on the Internet, and Microsoft cautions you to make sure that you completely understand the risk before retrieving any software from the Internet.

    Best Regards,

    Lake Xiao

    Friday, December 11, 2015 9:20 AM
    Moderator