locked
HTML help workshop images problem

    Question

  • Hi,

    I try to build a HTML help online files.

    I successfully builed new project with table of contents. the html files are word documents that i changed them to HTML files.

    the proublem is that some of the images are seen and some with red X (some error).

    I tried to change the pictures to .bmp or .png but it still dosent work.

    what can i do?

    thank you

    Tuesday, December 04, 2012 8:05 AM

All replies

  • Hi,

    did you check the HTML files? When some images are included correctly and some are not: Did you see any difference? Without details it is quite hard to help. Are all pictures inside the same directory as the html pages?

    Important is to just place the pictures into the same directory or inside another subdirectory. And then link to them relatively. So something like mypicture.bmp or pictures/mypicture.bmp but NOT something like C:/somepath/mypicture.bmp or a ../mypicture.bmp! (I think that caused trouble for me in the past, too!)

    With kind regards,

    Konrad

    Tuesday, December 04, 2012 11:26 AM
    Moderator
  • Hi,

    I checked my HTML files. they are fine (i saved them as "web page, filtered (*.htm,*.html)").

    i can see the images in the HTML files. they all saved in the same folder and still.. its not working :\..

    thank you

    Wednesday, December 05, 2012 2:30 PM
  • As I said: without exact details we can only guess around.

    What did you mean with "I checked my HTML files"? Did you open the File as Text File and look exactly at the code inside? Did you see any differences between Images that work and that does not work?

    With kind regards,

    Konrad

    Thursday, December 06, 2012 3:51 PM
    Moderator
  • I didnt look at the code inside because i dont know how to read it. all the word\ html files was ready before i insert them to the workshop.

    i openned the files as HTML files and as word files - the images looked good in both documents.

    I cant see any differences between the images who work and that who doesnt work.

    thank you


    • Edited by o.b ness Sunday, December 16, 2012 12:09 PM
    Sunday, December 16, 2012 12:08 PM
  • Word is nor very suitable forr HTML Help. You really need a HTML editor that creates clean HTML.

    You will find that the HTML code for the images is verbose DHTML.

    The HH compiler can't detect the images and wont include the image file at compile time (so you get an x). You need to include the relative path to the image in the .HHP [files] section.

    [FILES]
    myimage1.gif
    myimage2.gif
    etc

    If the images were clean HTML like <img src="myimage1.gif"> the images world be detected and work.

    See also http://kb.helpwaregroup.com/ms-html-help/hh-faq#TOC-Images-don-t-show-in-the-CHM

    Rob


    Rob Chandler Help MVP www.helpware.net | mshcmigrate.helpmvp.com | hv2.helpmvp.com

    Monday, December 17, 2012 1:55 AM
    Moderator