none
v1.5 has more depth noise and skeleton jitter than v1.0 RRS feed

  • Question

  • Hi,

    Since updating to the v1.5 SDK (or runtime), I have noticed that the depth image has more noise in it and the skeleton has more jitter.  I've tested this on a number of different computers and they all show the same symptoms.  The computers are in various locations around the office, with typical office lighting, have varying backgrounds/clutter in the field of view.  There doesn't seem to be any pattern where one environment triggers the noise and another does not.  When I uninstall v1.5, re-install v1.0 and run the same application, nearly all of the noise and jitter are gone.  The application I'm testing with is the C++ skeleton viewer.

    Has anyone else encountered this?


    Thanks!

    Darryl

    Tuesday, August 21, 2012 4:21 PM

All replies

  • Are you operating more than one Kinect sensor simultaneously, with overlapping fields of view? The interference between the IR emitters from multiple Kinect sensors is known to cause significant degradation/noise in the depth readings, which would also have an effect on skeleton tracking.


    John | K4W Dev

    Wednesday, August 22, 2012 6:38 PM
  • Hi John,

    I'm using a single sensor.

    Thursday, August 23, 2012 4:17 PM
  • We'd be curious to know whether you detect the same noise in the depth data with an application that is not simultaneously using the color camera. For example, the Kinect Explorer sample gives you the ability to disable the color stream.


    John | K4W Dev

    Monday, August 27, 2012 8:38 PM
  • I am also experiencing the same problem - a lot of jitter/noise with the depth camera.  Have tried moving the PC/kinect - but no difference.  

    Is it worth trying to adjust the tolerances?

    I am using the XBox 360 kinect  - not the Windows Kinect.  Is there any difference?

    Thanks
    Tim

    Tuesday, August 28, 2012 10:50 PM
  • Guess I didn't specify...I'm using the Windows Kinect sensors.

    John, I got diverted the last couple of days.  I'll try the Explorer later today and let you know.

    Wednesday, August 29, 2012 3:29 PM
  • John,

    I ran Kinect Explorer.  Disabling the color stream didn't make any difference.  There is still quite a bit of noise.  I see the most noise when running with near mode.  Near mode seems to introduce more noise.

    Thanks,

    Darryl

    Friday, August 31, 2012 2:52 PM
  • More noise in near mode might be expected, depending on environmental conditions. Near mode operates the IR laser at a lower intensity does than default mode. Since the intensity of the signal is lower, IR noise in your environment can more easily drown it out.

    What I haven't yet figured out is why the noise would vary between v1.0 and v1.5 of the runtime and drivers. I'm not aware of any changes between the two releases that would have caused this, and we haven't observed it in any of our own testing.


    John | K4W Dev

    Tuesday, September 4, 2012 9:20 PM