none
SQL Server Management Studio 18 doesn't start RRS feed

  • Question

  • My installed SQL Server Managenement Studio doesn't start. It only shows the splash screen for ~0.5 second and then nothing.

    I have both tried a restart and a repair, but that doesn't solve the problem

    Last week it did exactly the same thing, nothing worked and in the end I uninstalled and re-installed. That worked - but apparently only for week, so I don't see this as a usable solution.

    My PC is only 2 weeks old, Win10 Pro 1809 and all updates. Not much is installed besides Visual Studio 2019, newest MS Office and a couple of browsers.

    Any help on this would be much appreciated.

    Friday, May 10, 2019 7:41 PM

All replies

  • Hi Qbrix2000,

     

    I suggest you use ssms17.9.1 first, this is a very stable version, here is the download link for this version: https://docs.microsoft.com/en-us/sql/ssms/release-notes-ssms?view=sql-server-2017#download-ssms-1791

     

    I  recommend you to submit your issue to the Microsoft feedback at this link https://feedback.azure.com/forums/908035-sql-server . This site will serve as a connecting point between you and Microsoft, and ultimately the large community for you and Microsoft to interact with. Your feedback enables Microsoft to offer the best software and deliver superior services, meanwhile you can learn more about and contribute to the exciting projects on Microsoft feedback.

     

    Hope this could help you .

    Best regards,

    Dedmon Dai


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Monday, May 13, 2019 5:48 AM
  • Run

    "[SQL Server Managenement Studio Installation Path]\Common7\IDE\Ssms.exe" -log "%UserProfile%\Documents\ssms.xml"
    open "%UserProfile%\Documents\ssms.xml" with Internet Explorer or other xml viewer, check if there were any errors.

    Log sample:

    Log

    Monday, May 13, 2019 8:23 AM
  • rename file:
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies\Microsoft.VisualStudio.Shell.Interop.8.0.dll
    to 
    Microsoft.VisualStudio.Shell.Interop.8.0.dll.old

    then copy file:
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PrivateAssemblies\Interop\Microsoft.VisualStudio.Shell.Interop.8.0.dll
    to folder
    C:\Program Files (x86)\Microsoft SQL Server Management Studio 18\Common7\IDE\PublicAssemblies\

    Then launch SSMS 18

    • Proposed as answer by b_mcg Friday, May 17, 2019 8:16 PM
    Friday, May 17, 2019 4:36 PM
  • dude ! youre the best !

    i was struggling with this problem for so many days and now it is finally working ! :D :D :D thank you !!!!

    Saturday, May 25, 2019 9:56 PM
  • Thank @IR8 this worked for me too.


    Andre Coetzee

    Thursday, May 30, 2019 12:07 PM
  • perfect, thanks
    Friday, May 31, 2019 10:43 AM
  • Well, that works.  So does anyone know why?  After installing SSMS worked fine until closed and would not restart.  The first time I did a repair, that did not work.  I then uninstall and reinstalled, that worked until I closed it again.

    Wonder if I will have to keep making this change...


    John J. Hughes II

    Wednesday, June 5, 2019 1:33 PM
  • Wow, this worked.  Almost.... strange.  I guess, thanks.
    Monday, June 10, 2019 7:15 PM
  • Many thanks dude.
    You are a lifesaver <3
    Tuesday, June 11, 2019 1:59 AM
  • Great, this worked. Thank you.
    Tuesday, June 11, 2019 4:52 PM