locked
Unfortunately, *App Name* has stopped. RRS feed

  • Question

  • User76322 posted

    I need some help here, I can't deploy to an actual phone and have it load to save my life. I've built a simple Android App, as a matter of fact I dumbed it down to just a label with text, deploy to an .APK and tried to install on 3 different phones and versions of Android and it crashes every time. Build something similar in Android/eclipse works perfectly, had Xamarin for a couple of weeks now and haven't been able to deploy anything. All my hello world apps work perfectly in all the emulators just not a deployed .apk version, so not sure of I'm missing something or not but I'm frustrated now and need some help. I have VS 2012 11.61030 Update 4. Using Xamarin 3.6.253 with Xamarin Android 4.16.17, your response will be greatly appreciated. Thanks.

    Friday, October 10, 2014 7:08 PM

All replies

  • User60907 posted

    I am fairly new myself so prob not much help, but it could be the fast deployment option. Right-click on your project, not solution, and select properties. Select "Android Options" on the left and you should see the attached image. Try unchecking the "Use Fast Deployment (debug mode only)" option. It seems some phones don't like that at all. My test Nexus is ok, but the Samsung Galaxy S4 does not.

    Tuesday, October 14, 2014 8:23 PM
  • User76322 posted

    Thank you, however, that didn't work either.

    Wednesday, October 15, 2014 1:55 PM
  • User83124 posted

    Same here. After my android debugging went spastic. I decided to load up vs2015 ctp6 and can now see the VS Emulator Lollipop Phone in vs2013 but get the message "Unfortunately, ... .Droid has stopped. I seem to spend half my life at the moment coping with google nonsense like chrome never shutting down. I have unchecked Use Fast Deployment to no avail. Has anybody got the VS Emulator (from VS2015) working with VS2013 and can point me to an easy to follow instruction guide.

    Sunday, April 12, 2015 5:50 AM
  • User122557 posted

    Bump!

    Tuesday, April 21, 2015 12:20 PM
  • User110289 posted

    Android Player worked fine on my Win 7 Machine. Got a new Win 8.1 computer, re-installed everything as before and now can't deploy android apps. Get the same "Unfortunately, [app name] has stopped." message.

    VERY FRUSTRATING!

    Tuesday, April 21, 2015 3:11 PM
  • User122088 posted

    Same here - blank app project (Xamarin.Forms shared). Deploys to Xamarin Android Player but crashes immediately with message "Unfortunately, App Name has stopped.". Runs fine on both iOS and Win8 emulators.

    Wednesday, April 22, 2015 12:06 AM
  • User122088 posted

    Update: It works for Release builds but not for Debug. I have disabled Fast Deployment. Anybody solved this?

    Wednesday, April 22, 2015 8:27 PM
  • User122088 posted

    SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Wednesday, April 22, 2015 8:33 PM
  • User102114 posted

    Maybe this would help: http://www.geekswithblogs.net/dotNETvinz/archive/2015/02/17/xamarin.android-and-visual-studiondashbuild-failed-with-no-errors.aspx

    http://www.geekswithblogs.net/dotNETvinz/archive/2015/04/23/xamarin.android---testing-debugging-and-deploying-apps-to-wear-and.aspx

    Friday, April 24, 2015 1:36 PM
  • User2223 posted

    Hello Thanks to Ari Johannesson, the "Shared Runtime" uncheck did work for me.

    Thursday, April 30, 2015 9:29 AM
  • User102980 posted

    Ditto - And big thanks to Ari Johannesson. Disabling the shared runtime fixed me up too.

    Tuesday, May 5, 2015 1:23 PM
  • User8105 posted

    Yes, it works by unchecking the "Shared Runtime", but the file it created was 32MB whereas the other was around 4MB!

    So I had to get WinZip for my Android to get it emailed to me.

    Sure wish Xamarin would fix this!

    Friday, May 29, 2015 11:15 PM
  • User81746 posted

    Hi friends, I have developed an android application using xamarin form in xamarin studio and it was working fine in debugging mode with a physical device but when i tried to publish the app in ad-hoc it got published with out any error but the problem came when i tried to install the .apk file to the device which i was used test the application while debugging is not working it show the same error Unfortunately, App Name has stopped. i tried the solutions that you guys mentioned above like unchecking the Shared Shared Runtime but no change please help me to get out of this issue...

    Thanks in Advance..........

    Monday, July 6, 2015 5:52 AM
  • User139674 posted

    Same here -error Unfortunately, App Name has stopped.

    Monday, July 6, 2015 12:34 PM
  • User81746 posted

    Giving internet permission solved my problem.

    Wednesday, July 8, 2015 5:34 AM
  • User124167 posted

    VishnuPS suggestion about allowing internet permission finally worked! Very frustrating! Thanks!

    Friday, August 28, 2015 6:52 PM
  • User150023 posted

    same problem here , tried all written solutions but still not working

    Friday, September 4, 2015 2:41 AM
  • User109558 posted

    Yes, it works by unchecking the "Shared Runtime", but the file it created was 32MB whereas the other was around 4MB!

    So I had to get WinZip for my Android to get it emailed to me.

    Sure wish Xamarin would fix this!

    Same here

    Tuesday, October 6, 2015 12:58 PM
  • User162958 posted

    Hi , Thanks to Ari Johannesson i unchecked Shared Runtime and its running like charm.

    Tuesday, October 6, 2015 7:16 PM
  • User167439 posted

    Hi,

    I had the same problem when I used the "WebView App (Android)" solution in VS2015, but when using the "Blank App (Android)" and added a WebView to this, all my code from my first App worked!.

    Friday, October 16, 2015 3:33 PM
  • User169972 posted

    I have a same problem... but i have soleved problem after unchecked Shared Runtime.

    But Before this my app size approx 9 MB

    After Unchecked shared Runtime app size : 60 MB.

    How to compress my android apps size ?

    Saturday, November 21, 2015 6:31 AM
  • User168108 posted

    I installed my app from the emulator, redeployed and it worked. With "Shared Runtime" and without the Java Heap setting. https://www.androidpit.com/how-to-fix-unfortunately-app-has-stopped

    Tuesday, November 24, 2015 1:18 AM
  • User176177 posted

    I too have same problem... i'm running a default sample application in android, whenever i'm deploying it i am getting the error as "unfortunately app has stopped." I've tried by

    1) changing the VM heap value. 2) checking & unchecking the shared runtime, but still same error.

    Thursday, November 26, 2015 9:58 AM
  • User163884 posted

    I am using Visual studio android emulator and had the same problem. I tried all of the suggested solution, but none of them worked for me. Eventually, i've found one, go to Settings->Apps->(appName) and pressed Clear cache and clear data, after that App run happily ^^

    Sunday, December 13, 2015 12:41 PM
  • User136477 posted

    Hi guys go through this link:

    it might work

    https://forums.xamarin.com/discussion/22798/settings-clear-data-crashes-my-app

    Friday, December 18, 2015 9:43 AM
  • User188706 posted

    Hi Guys.. Finally i found the issue regarding Unfortunately "App Name" has stopped in android mobile.. When we run the application in our mobile, we should have to keep the xamarin supporting file on your mobile.. It should work..

    Wednesday, January 20, 2016 6:50 PM
  • User205072 posted

    Ari Johannesson, IT WORK FOR ME... Thanks

    Thursday, March 24, 2016 2:49 PM
  • User218392 posted

    @AriJohannesson said: SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Nice..it's work for me.

    Wednesday, May 25, 2016 1:24 PM
  • User231095 posted

    Hi Guys,

    I was having the same problem and the below solution worked for me:

    Go to the project name in solution explorer and right click -> Properties. In the properties, go to Android Options -> uncheck shared runtime.

    Then go to Application tab and select Compile using Android version: Use Latest Platform Minimum Android Target -> This must be the Android version of the device you are deploying on Target Android version -> This must be the Android version of the device you are deploying on

    I selected Android 4.2( API Level 17 - Jelly Bean) as this was my target device for development. You can change this according to the device you are developing for.

    Hope it works for you all!

    Thanks and regards!

    Saturday, June 4, 2016 8:19 AM
  • User234574 posted

    @AriJohannesson said: SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Worked !

    Monday, June 20, 2016 10:34 AM
  • User234574 posted

    @kutt said:

    @AriJohannesson said: SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Worked ! Thanks !!

    Monday, June 20, 2016 10:36 AM
  • User210701 posted

    I was having the same issue when I tried to build project in Release configuration in Visual Studio and run it on symulator. I found solution to fix it. Go to properties of Android project, then go to Android Options-> Advanced tab-> Supported architectures; and check all architectures' checkboxes.

    Wednesday, August 3, 2016 9:37 AM
  • User230160 posted

    @TymurTkachenko said: I was having the same issue when I tried to build project in Release configuration in Visual Studio and run it on symulator. I found solution to fix it. Go to properties of Android project, then go to Android Options-> Advanced tab-> Supported architectures; and check all architectures' checkboxes.

    Thank you so much it worked. I only checked ARM Processor. Now i checked all and it works on all real devices now!

    Friday, August 26, 2016 8:25 AM
  • User280252 posted

    For me, it was x86_64 emulator and that not being in Build Options -> Advanced -> supported architectures. Most of the answers in this thread have to do with build properties.

    Wednesday, November 30, 2016 5:14 PM
  • User169113 posted

    OK, Solved.. When I tried to used what @AriJohannesson said, i did not work for me. So, keep checked "Shared Runtime" (if Uncheked it, it gives a arquitecture error).
    My Solution: Go to Android build-->Advanced and Unchecked "armeabi" option

    Tuesday, December 6, 2016 3:28 PM
  • User266620 posted

    Thank-you just unchecking "armeabi" and leaving the "shared runtime" checked worked for me also.

    Wednesday, January 4, 2017 10:08 AM
  • User288888 posted

    @TymurTkachenko said: I was having the same issue when I tried to build project in Release configuration in Visual Studio and run it on symulator. I found solution to fix it. Go to properties of Android project, then go to Android Options-> Advanced tab-> Supported architectures; and check all architectures' checkboxes.

    Thankssssssssssssssss!!!!!!!!!!!!!!

    Thursday, January 5, 2017 8:04 AM
  • User285342 posted

    Hai how to get .apk file in xamarin cross plate from. Please help me

    Thursday, January 19, 2017 9:08 AM
  • User309142 posted

    @AriJohannesson said: SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Got this error in actual device. Worked for me! Thanks @AriJohannesson!

    Wednesday, March 22, 2017 2:33 AM
  • User326120 posted
    1. Uncheck the "Shared Run time"
    2. Please check the version compatibility of the android build and your deceive / emulator
    Friday, May 26, 2017 12:08 PM
  • User328636 posted

    How I do this but with continuous integration in my build definition with VSTS? To make a release to HockeyApp, my app close immediately to start in my device. any ideas?

    Tuesday, June 6, 2017 4:26 PM
  • User252595 posted

    try unchecking Enable Multi-dex

    Wednesday, June 21, 2017 5:13 AM
  • User332416 posted

    hey, Thanks to Ari Johannesson, the "Shared Runtime" uncheck now working...

    m using xamarin in visualstudio 2015.

    Friday, June 23, 2017 10:41 AM
  • User5642 posted

    Unchecking "Shared Runtime" in the Android project properties fixed this issue for me as well. It turns out though that it was checked in Debug mode, but not in Release mode, so rather than unchecking it in Debug mode I just switched my build system to build in Release mode. Thanks!

    Sunday, January 14, 2018 3:14 PM
  • User236907 posted

    @AriJohannesson said: SOLVED: Disabled "Shared Shared Runtime" in Android build options.

    Solved!!!

    Wednesday, June 3, 2020 6:34 PM