none
MSDAORA provider RRS feed

  • Question

  • Hi,

     

    I have an application that connect on Oracle 10g server through MS OleDb Data Provider. The connection string below was running fine:

     

    Provider=MSDAORA;Data Source=ORCL_192.168.1.1;Persist Security Info=True;User ID=UserName;Password=passwd

     

    but after I removed a some of Oracle clients entries on my registry the message below starts show:

     

    The 'MSDAORA' provider is not registered on the local machine.

     

    How I do to correct this problem? I have a Windows Vista Business version. I will need to reinstall the Vista to correct the problem?

     

    Thanks.

    Tuesday, December 9, 2008 9:42 PM

All replies

  • If the Msdaroa.dll file is on your system try re-registering it using the Regsvr32.exe (command line) utility. I'm assuming that you're not running the 64-bit version of Vista.

     

    If the above suggestion doesn't work then you will probably need to re-install Vista. I'm not aware of any way to fix the MDAC install on Vista.

     

    Wednesday, December 10, 2008 2:37 PM
  • Dear All,

    Am also having the same problem. Am using Windows Server 2008 R2 Server, its 64 bit. I already register the msdaora.dll in the same server. Now also am facing the same issue.

     

    Kindly suggest me a way around for this..

    Thanks and Regards,

    Anil

    Sunday, May 29, 2011 6:11 AM

  • how to connect visual studio ultimate2013 update4 with oracle12c(12.1.0.2.0) 64-bit on windows7prof 64-bit 
    Wednesday, December 10, 2014 8:21 AM