none
Visual Studio 2013 Ultimate : Error message when loading a project or solution

    Question

  • When I load some projects, this dialog prompts:

    ---------------------------
    Microsoft Visual Studio
    ---------------------------
    The 'Microsoft Visual Studio Tools for Applications 2013 - Update 1 Shell Integration Package' package did not load correctly.
    The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by examining the file 'C:\Users\<user>\AppData\Roaming\Microsoft\VisualStudio\12.0\ActivityLog.xml'.
    Restarting Visual Studio could help resolve this issue.
    Continue to show this error message?
    ---------------------------
    Yes   No  
    ---------------------------
    Thursday, October 20, 2016 2:08 PM

All replies

  •                   
    You cannot vote on your own post
    0

    Here is the useful portion of the log file:

    <?xml version="1.0" encoding="utf-16"?>
    < ?xml-stylesheet type="text/xsl" href="ActivityLog.xsl"?>
    < activity>

      ...

      <entry>
        <record>360</record>
        <time>2016/10/19 08:26:40.410</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>CreateInstance failed for package [Microsoft Visual Studio Tools for Applications 2013 - Update 1 Shell Integration Package]</description>
        <guid>{DD3EEB42-D065-4F65-A9F9-BD3D8C4A75EF}</guid>
        <hr>80070002</hr>
        <errorinfo>Could not load file or assembly 'Microsoft.VisualStudio.Tools.Applications.Package, Version=12.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.</errorinfo>
      </entry>
      <entry>
        <record>361</record>
        <time>2016/10/19 08:26:40.410</time>
        <type>Error</type>
        <source>VisualStudio</source>
        <description>End package load [Microsoft Visual Studio Tools for Applications 2013 - Update 1 Shell Integration Package]</description>
        <guid>{DD3EEB42-D065-4F65-A9F9-BD3D8C4A75EF}</guid>
        <hr>80004005 - E_FAIL</hr>
        <errorinfo>Could not load file or assembly 'Microsoft.VisualStudio.Tools.Applications.Package, Version=12.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a' or one of its dependencies. The system cannot find the file specified.</errorinfo>
      </entry>

    Downloading and installing the following didn't solve that last problem:

    - Microsoft Visual Studio 2013 Shell (Isolated) Redistributable Package
    - Microsoft Visual Studio 2013 Shell (Integrated) Redistributable Package
    - Microsoft Visual Studio Tools for Applications 2013

    Probably one of the numerous .NET Framework has a problem... but which one?
    Ideas are welcome.

    Best regards,

    Vincent

    Thursday, October 20, 2016 2:08 PM
  • Hi Vincent,

    Thank you for posting in MSDN forum.

    >>The problem may have been caused by a configuration change or by the installation of another extension. You can get more information by examining the file

    According to this error information, please take a look at following link:

    https://software.intel.com/en-us/forums/intel-inspector-xe/topic/509726

    This member solved this similar issue by uninstalling everything, then download and reinstall the software again.

    So please go to Control Panel to repair your VS first, start VS in safemode ,

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, October 21, 2016 10:04 AM
    Moderator
  • I realize I didn't explain the context when I posted this new question...

    First my first solved problem was that after uninstalling VS2015 "free" and installing VS2015 Entreprise, my VS2013 Ultimate crashes at launch. I first try the safemode and other "reset" options without success. To solve the problem I (again) uninstall VS2103, but remove completely the vs2013 folder (so no more extension stay and make it crashes), then reinstall.

    Still stay the current described problem. So I think that the suggestions mentioned in the link will not works...

    Wednesday, October 26, 2016 6:47 AM
  • Hi VincentGouv,

    To analyze the cause, please navigate to the following location:

    >>C:\Users\<user>\AppData\Roaming\Microsoft\VisualStudio\12.0\ActivityLog.xml

    Upload this log file to https://onedrive.live.com/ and share the link here.

    There is another possibility about Shell Integration Package' package did not load correctly, the VS Shell Integration package is broken.

    I suggest you insert a healthy VS ISO and repair it again.

    Best Regards,


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Wednesday, October 26, 2016 9:00 AM
    Moderator