locked
Environment Variable is not getting set RRS feed

  • Question

  • Hi,

    I am trying to set new build environment variable using InvokeMethod in TFS2012 process template.

    Here are my values for parameters .

    Direction = In;Type = String; Value="TF_BUILD_SOURCEGETVERSION"

    Direction = In;Type = String; Value=BuildDetail.SourceGetVersion

    TargetType = System.Environment

    But it seems to be not getting set. Below is the build log I can see after build.

    Set Buildnumber environment variable
    Inputs
    • TargetObject:
    Outputs
    • Result: 

    

    Please advise


    • Edited by DHegde Wednesday, March 18, 2015 1:47 PM
    Wednesday, March 18, 2015 1:35 PM

Answers

  • Hi DHegde, 

    Thanks for your post.

    You added the InvokeMethod activity in default TFS 2012 build process template? I followed your settings in my InvokeMethod activity, after build received below result:

    If there’s anything misunderstood, please describe your InvokeMethod activity in more detail and we will try to provide the better responses.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.



    Thursday, March 19, 2015 3:15 AM
    Moderator
  • Hi,

    Your understanding is correct. It doesn't appears to be shown the variable and its value in the log. But I can see that value is set now.

    Friday, March 20, 2015 9:50 AM

All replies

  • Hi DHegde, 

    Thanks for your post.

    You added the InvokeMethod activity in default TFS 2012 build process template? I followed your settings in my InvokeMethod activity, after build received below result:

    If there’s anything misunderstood, please describe your InvokeMethod activity in more detail and we will try to provide the better responses.


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.



    Thursday, March 19, 2015 3:15 AM
    Moderator
  • Hi DHegde, 

    Have you confirmed that?


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Friday, March 20, 2015 7:47 AM
    Moderator
  • Hi,

    Your understanding is correct. It doesn't appears to be shown the variable and its value in the log. But I can see that value is set now.

    Friday, March 20, 2015 9:50 AM