locked
Kali Linux - Not Available In Any Locations RRS feed

  • Question

  • I'm trying to create a Kali Linux VM in Azure. When I do, I get a message, "The selected image is not valid for the specified location. Select a different location." I get this message for every location on the list, and I am unable to create the VM, please help?
    Wednesday, September 5, 2018 4:27 PM

All replies

  • I tried reproducing the scenario and was able to create it East US 2. Can you please share the screenshot where you are getting the error?

    Wednesday, September 5, 2018 5:55 PM
    Owner
  • The Kali image appears to be available in all regions. 

    You can check this by running the following PowerShell Command: 

    Get-AzureRmVMImageOffer -Location EastUS -PublisherName kali-linux

    Just change the location to check if it is available. The output will look like so: 

    PS C:\Users\mimckitt> Get-AzureRmVMImageOffer -Location EastUS -PublisherName kali-linux

    Offer      PublisherName Location Id
    -----      ------------- -------- --
    kali-linux kali-linux    eastus   /Subscriptions/XXXXXXX-XXXX-XXXX-XXXX-XXXXXXXXXXXX/Providers/Microsoft.Compute/Lo...

    What is likely the issue is that is not available for your subcription. 

    What subscription tier do you have? Free Trial, Pay-As-You-Go, Etc? 

    Are you the subscription admin? 

    Do you have a credit card tied to your account? This image will require you to have a card on file. 

    Wednesday, September 5, 2018 6:04 PM
  • I have a pay-as-you-go subscription, and I am the admin. I have tried every location on my account and I get the same message. I have a CC on file as well. I'm unable to post pics yet, otherwise I'd have posted screenshots.
    Wednesday, September 5, 2018 6:12 PM
  • So I am assuming you are getting the error on this page correct? 

    Can you try running the PowerShell commands I provided above to see if you get any other error messages? 

    Wednesday, September 5, 2018 6:16 PM
  • No error when running the PS commands; however, when I click create I'm still getting the same message.
    Thursday, September 6, 2018 3:17 PM
  • found a location where it works.
    Thursday, September 6, 2018 3:26 PM
  • Interesting. What location worked for you? 
    Thursday, September 6, 2018 6:08 PM
  • East Japan, but during creation the connection stopped to Azure, I had to reload and start again and now it's not working again.
    Thursday, September 6, 2018 6:32 PM
  • Actually got deployment to work this time under western Australia
    Thursday, September 6, 2018 7:04 PM
  • Thanks for the update. I am glad to hear at least for now you are unblocked. 

    I would suggest you open a ticket to the subscription and billing team via the portal. 

    They should be able to help clear up why it is not working in some regions since as far as I have tested it is available in almost all of them. Then from there work towards getting them enabled for all available regions in your subscription. 

    Thursday, September 6, 2018 7:50 PM