locked
Azure Datafactory Web Activity RRS feed

  • Question

  • I have developed an Function app and published the same via Azure APIM. I am trying to call the API(APIM) from Data factory Web Activity, which fails with the below.

    {

        "errorCode": "2108",
        "message": "Error calling the endpoint. Response status code: ",
        "failureType": "UserError
    }

    However when I use the Azure function URL + Function key directly in WebActivity this works fine.
    So I want to be able to call a REST endpoint internal to my organization from Azure Data Factory using Web Activity. Appreciate any directions on this.

    Thursday, February 14, 2019 5:26 PM

All replies

  • Go to ADF , use a WEB Activity

    When using a WEB activity you can NOT use any space in your string 

    Click here for more info


    Sincerely Nik -- Please kindly mark the post(s) that answered your question and/or vote for the post(s). http://sqldataside.blogspot.ca/ (SQL Tabular + PowerShell)

    Friday, February 15, 2019 6:13 AM
  • This doesn't answer my question. I have a function app published in APIM.

    I have 2 use cases below and I want help with the first one.

    1. When I trigger the Data Factory(WebActivity) with the REST end point from APIM this fails with below error. I think APIM being part my org vnet is the problem. I need to know how to get around this. 

    {

        "errorCode": "2108",
        "message": "Error calling the endpoint. Response status code: ",
        "failureType": "UserError
    }

    2. When I trigger the Data Factory(WebActivity) with the REST end point from Function App this works fine. The REST end point here is public and that is why there is no issue here.

    Friday, February 15, 2019 3:22 PM
  • let me do some investigation on this today

    Sincerely Nik -- Please kindly mark the post(s) that answered your question and/or vote for the post(s). http://sqldataside.blogspot.ca/ (SQL Tabular + PowerShell)

    Friday, February 15, 2019 5:18 PM
  • Any luck with this pls ?
    Monday, February 18, 2019 3:50 PM
  • Hi Shiva,

    Sorry for the delayed response. I found a similar issue reported here :

    https://stackoverflow.com/questions/54441426/error-calling-the-azure-function-endpoint-from-azure-data-factory

    Please have a look at the answers on the post, they might be helpful in your case as well. Let us know if it helps. Else we can gladly continue to probe into the issue further.


    MSDN

    Friday, March 1, 2019 6:31 AM