none
WCF host doesn't work on Windows server 2003 using SSL RRS feed

  • Question

  • hi, I have created a WCF simple project by this tutorial:
    
    www.codeproject.com/Articles/36705/7-simple-steps-to-enable-HTTPS-on-WCF-WsHttp-bindi
    
    (first result at google with "simple wcf project ssl")
    
    
    
    I tried it on windows 7 .NET Framework 4.0 and everything worked great. (including http:// and https://)
    
    
    Then I moved the project to a remote host with OP of Windows server 2003 and .NET Framework 3.5
    
    I created a virtual directory, which points to my Service directory, and it created Application inside the Application pool for it automaticly.
    
    using http:// everything worked great. then I checked require SSL and tried to enter with https:// , didnt worked.
    
    I didnt have makecert on the remote host, so I moved the one from Windows 7 to the Windows server 2003 and used it there.
    
    I have created a certification issued by my remote host name to my remote host name, and put it at trusted root certifications. then I used it as a certification to my Default web page in inetmgr.
    
    I have configured httpcfg with these settings:
    
    urlacl: https://1.2.3.4:443/MyService (as 1.2.3.4 is my remote host ip, -I haven't try using to use 127.0.0.1-) with a very wide access list including everyone
    
    iplisten: 1.2.3.4:443
    
    ssl : 1.2.3.4:443 with the certification's thumbprint (no spaces).
    
    I have noticed I have svchost.exe running but w3wp.exe didnt. When I tried to open it manually (with a double-click), it showed in the Event viewer that:
    
    "Error : the worker process failed to initialize the http.sys communication or the w3svc communication layer"
    
    I followed this:
    
    http://support.microsoft.com/kb/896286
    
    but everything was already fine, and yet the error still shows.
    
    at the Virtual's directory log, it shows this:
    
    "w3svc1 127.0.0.1 GET /MyService -po -127.0.0.1 Mozilla/4.0+(compatible;MSIE+6.0;+windows+NT+5.2;+SV1;+.NET+CLR+1.1.14322;+.NET+CLR+2.0.50727;+.NET+CLR+3.0.4506.2152;+.NET+CLR+3.5.30729)"
    
    3 times, with 3 diffrent errors after:
    
    403 4 5
    
    301 0 0
    
    200 0 0
    
    (remember i tried to enter with http:// and https:// few times).
    
    Also, I ran aspnet_Regiis -iru , ServiceModelReg -i , iisreset after.
    
    I tried to create a dummy.html and access it via http:// , worked. via https:// , still same thing.
    
    no idea how to keep going from here. (The error about the worker still shows on the Event viewer, only when i double-click w3wp.exe)


    Tuesday, September 3, 2013 5:45 PM

Answers

  • Hi,

    Since you have tried the http://support.microsoft.com/kb/896286, but it can not help, please try to refer to the following steps:

    1. Uninstall IIS
    2. Re-Install IIS
    3. Run the below command. If IIS is installed after .Net then we need to register the asp.net. Open the VS command prompt or go to c:\[windows/winnt]\[Microsoft.Net]\[Framwowrk]\[ v2.0.50727]\aspnet_regiis.exe –i.
    4. Create the virtual directory.
    5. Create the Application Pool.
    6. Assign the application pool to the virtual directory

    For more information, please try to refer to:
    http://letssecure.blogspot.in/2010/03/worker-process-failed-to-initialize.html .

    Best Regards,
    Amy Peng


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Wednesday, September 4, 2013 8:21 AM
    Moderator