none
Receive Location Disabled When the SAP Connection is down RRS feed

  • Question

  • Hi

    I am using BizTalk Adapter V2.0 for mySAP, my receive location is using SAP adapter and is connected to SAP.  Whenever my Receive Location misses the communication to SAP it is getting disabled.  The problem is it's still in a disabled stage even after the communication is established.  I have to manually restart the receive location.  Is there anyway that the receive location is enabled automatically once the communication is established with SAP?

    Thanks in advance

    Rao

    Wednesday, July 21, 2010 7:14 AM

Answers

  • What sounds like your issue is described here: http://kentweare.blogspot.com/2010/03/biztalk-adapter-pack-sap-binding.html. Kent suggests making the receive timeout longer than your expected SAP outage time. Does this sound like an option that would work for you?

    If not, I would consider building a scheduled task (or even a Windows service) based on the BizTalk Explorer OM to enable the receive location again.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Wednesday, July 21, 2010 1:51 PM
    Moderator
  • Trust me, there is no out of the box solution for this. 

    You could write an own service that listens to WMI events and that restarts the location - just as an example. But Microsoft itself doesn't offer a mechanism like that.

    Another option would be to use Microsoft SCOM or Helium Tools to monitor the solutions to send you an email when is goes down. But this would also result in a delay (smaller one but it's still there).

     


    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    http://biztalk.hauth.me

    Thursday, July 22, 2010 4:38 AM

All replies

  • There is no way of restarting the location automatically. If it's a scheduled downtime you can use the scheduling options on receive location level to get around this. But if you are talking about unexpected downtimes, this won't help you.

    Maybe (but I never tried) you can use a 1 minute maintenance scheduling to restart the location at least once a day?


    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    http://biztalk.hauth.me

    Wednesday, July 21, 2010 10:48 AM
  • What sounds like your issue is described here: http://kentweare.blogspot.com/2010/03/biztalk-adapter-pack-sap-binding.html. Kent suggests making the receive timeout longer than your expected SAP outage time. Does this sound like an option that would work for you?

    If not, I would consider building a scheduled task (or even a Windows service) based on the BizTalk Explorer OM to enable the receive location again.

    Thanks,


    If this answers your question, please use the "Answer" button to say so | Ben Cline
    Wednesday, July 21, 2010 1:51 PM
    Moderator
  • Hi Ben 

    The link suggests using WCF-SAP adapter, but I m using the SAP, so I don't have the option of timeout as suggested in the article.  

    The other thing is the receive location is not disabled due to the incoming messages but the issue is because of the communication failure, say network down.

    Thanks

    Regards

    Rao

     

    Thursday, July 22, 2010 2:32 AM
  • Trust me, there is no out of the box solution for this. 

    You could write an own service that listens to WMI events and that restarts the location - just as an example. But Microsoft itself doesn't offer a mechanism like that.

    Another option would be to use Microsoft SCOM or Helium Tools to monitor the solutions to send you an email when is goes down. But this would also result in a delay (smaller one but it's still there).

     


    If you like my post or consider it as a valid answer, please use the buttons to show me - Oliver

    http://biztalk.hauth.me

    Thursday, July 22, 2010 4:38 AM