none
Can't reenter credentials

    Question

  • Hi;

    Our networking folks recently blocked external web access from IE 9 since it is no longer supported.

    When requested by Visual Studio (2013 & 2015) to reenter my credentials, I get a "Page can't be displayed" error. The network guys traced it back to the fact that VS is using IE 9 to https://app.vssps.visualstudio.com to authenticate. It appears that most people in the company are going out with a user agent of "-" where as mine is reporting "IE9".

    If there a way around this? Is there a way to change the user agent in Visual Studio?

    I know from past experience that if the license cannot be verified after a period of time Visual Studio won't launch.

    Appreciate the help.

    Cheers.

    Ron...


    Thanks Ron...

    Friday, April 01, 2016 11:39 AM

All replies

  • Hi RonlnOttawa,

    According to your description, this problem occurs on your account settings for Visual Stduio 2013/2015 sign page, is it right?

    As far as I know, the default browser engine used by Visual Studio is Internet Explorer. And VS2013/VS2015 are supported IE 11. So I suggest you upgrade your IE to version 11 to check whether it resolve your problem.

    Best Regards,
    Weiwei

    Monday, April 04, 2016 3:20 AM
    Moderator
  • Have you tried to login to your account separately, using browser? Maybe clear cache and cookies. Then retry from Visual Studio.

    Monday, April 04, 2016 4:42 AM
  • Hi Weiwei.

    Thanks for your answer.

    My browser is IE11 - IE9 is not even installed on my computer according to the registry. So VS seems to be using it's own version of IE and I need to know how to change it.


    Thanks Ron...

    Monday, April 04, 2016 10:35 AM
  • Thanks for your answer Viorel.

    I have tried what you suggested and I have no problem loggin into https://app.vssps.visualstudio.com with IE 11.

    Like I mentioned above, our security group is blocking all external access if it comes from IE9 due to security holes. So I need to change the default browser used by Visual Studio from IE9 to IE11.

    IE9 is not installed on my computer, so VS must be using it's own version.


    Thanks Ron...

    Monday, April 04, 2016 10:38 AM
  • Hi RonlnOttawa,

    The Visual Studio should use the installed IE version on your computer. Could you please tell me how do you confirm it use IE 9 in your scenario?

    Please try click the "Visual Studio profile" hyper link to check whether it open the IE 11 on your computer. If yes, it means your Visual Studio should use the IE 11. If no, please tell us what will happen when you click it.

    Please try clear cache and cookies as Viorel suggested, then sign out your account and re-sign in to check whether it can sign in successful or not.

    Best Regards,
    Weiwei

    Tuesday, April 05, 2016 2:43 AM
    Moderator
  • We've resolved a portion of the problem by altering our security rules allowing IE9 access to the required URL to authenticate against the Microsoft Servers. This is not ideal as you shouldn't fix issues by weakening security protocols.

    That being said, any link I click within VS opens up IE 9 and is therefore blocked by our firewall rules.

    My desktop PC is running IE11 - The registry sows it to be using IE11.

    Network packet sniffer is saying that it is using IE9 and that's why our firewall rules are blocking access.

    BTW - This is true of VS2012, 2013 and 2015. Each version is running the most recent Updates.


    Thanks Ron...

    Friday, April 08, 2016 12:29 PM
  • Hi RonlnOttawa,

    Please check whether your IE emulation mode set as IE 9, which result to your IE 11 run as IE 9 version. You can check it with following steps.

    1. Open your IE 11.
    2. Press F12 to open the Developer Tools.
    3. Choose the Emulation tab and check the Mode as below image shows.

    More questions about how to set your IE 11, I suggest you post your problem to the Internet Explorer forum for a better help.

    https://social.technet.microsoft.com/Forums/ie/en-US/home?forum=ieitprocurrentver&filter=alltypes&sort=lastpostdesc

    Best Regards,
    Weiwei


    Monday, April 11, 2016 2:56 AM
    Moderator