locked
Creating new application id RRS feed

  • Question

  • Hi

    I am trying to create a new application id for my development.
    Even though i have given a action url and public cert, they were listed in red color in my Application configuration center's Validate tab. Does this mean there is issue in action url and public cert? I have submitted
    Go-Live request to hvappid@microsoft.com also. How do i know whether my application id is authenticated to health vault or not?


    Thanks
    Sathya

    Tuesday, September 9, 2008 1:12 PM

Answers

  • Try the troubleshooter utility shipped with our SDK. Also this post might be helpful: http://blogs.msdn.com/healthvaultfaq/archive/2007/12/12/troubleshooter-application-certificate-cannot-be-accessed.aspx

    Hope this helps.

    regards,
    Vaibhav
    Friday, September 12, 2008 7:39 PM
  • Sathya,

     

    Sometimes app manager is having trouble doing the right thing - I don't know why yet.

     

    Try deleting the certificate on the server and then importing it using computercertificates.msc (in the tools directory of the SDK). And then grant using winhttpcertcfg.exe (also in the tools directory) in the way the sample apps do.

     

    Also try running the troubleshooter through IIS on the server, put in the app ID, and see what happens.

     

    Monday, September 15, 2008 6:01 PM

All replies

  • hi Sathya -

    The Validation tab is a sanity checker intended to prepare your application for our production environment. Besides it thing it complains about it gives a reason. In case of action url it will say that our production environment requires a SSL enabled action url (for security reasons) and in case of public cert you need to give us one with the go-live request.

    However in your case i think you are just trying to develop your application in our pre production environment and in that case your application is in the environment when you see it in application configuration center and the above restrictions only apply for production environment.

    Please feel free to use our learn section or FAQs in case you need more help.

    Hope this helps.

    regards,
    Vaibhav
    Tuesday, September 9, 2008 9:53 PM
  • Hi

    I have created my own application id and able to use it successfully,
    But when i map my application to IIS am getting the below pasted error.

    Need help to overcome this issue

    Keyset does not exist

    Description: An unhandled exception occurred during the execution of the current web request. Please review the stack trace for more information about the error and where it originated in the code.

    Exception Details: System.Security.Cryptography.CryptographicException: Keyset does not exist


    Source Error:

    An unhandled exception was generated during the execution of the current web request. Information regarding the origin and location of the exception can be identified using the exception stack trace below.

    Stack Trace:

    [CryptographicException: Keyset does not exist
    ]
    System.Security.Cryptography.Utils.CreateProvHandle(CspParameters parameters, Boolean randomKeyContainer) +1520238
    System.Security.Cryptography.Utils.GetKeyPairHelper(CspAlgorithmType keyType, CspParameters parameters, Boolean randomKeyContainer, Int32 dwKeySize, SafeProvHandle& safeProvHandle, SafeKeyHandle& safeKeyHandle) +55
    System.Security.Cryptography.RSACryptoServiceProvider.GetKeyPair() +79
    System.Security.Cryptography.RSACryptoServiceProvider..ctor(Int32 dwKeySize, CspParameters parameters, Boolean useDefaultKeySize) +309
    System.Security.Cryptography.RSACryptoServiceProvider..ctor(CspParameters parameters) +9
    System.Security.Cryptography.X509Certificates.X509Certificate2.get_PrivateKey() +199
    Microsoft.Health.ApplicationConfiguration.GetSignatureCertRsaProvider(Guid applicationId, RSACryptoServiceProvider& rsaProvider, String& thumbprint) +335
    Microsoft.Health.Web.Authentication.WebApplicationCredential.SetupSignatureCertRsaProvider() +117

    Thursday, September 11, 2008 8:43 AM
  • Try the troubleshooter utility shipped with our SDK. Also this post might be helpful: http://blogs.msdn.com/healthvaultfaq/archive/2007/12/12/troubleshooter-application-certificate-cannot-be-accessed.aspx

    Hope this helps.

    regards,
    Vaibhav
    Friday, September 12, 2008 7:39 PM
  •  

    Hi,

     

    I have generated my new application id using Health vault application manager present in health vault sdk.  I clicked on “Create new certificate” button in the health vault application manger and created my new certificate. By right clicking on the certificate name and choosing the option upload certificate.  I have configured the application and generated the key by right clicking on the certificate name and choosing the option “Export the Public and Private keys (*.pfx)”. I have uploaded this key to my server using “Import pfx files” option in Health vault Application manager.  I have 5.1 IIS version in my local machine and IIS 6 version in my server machine.  I granted run under IIS permission also for the certificate in health vault application manager in server. I have also followed the instructions mentioned in the health vault faq that you have mentioned, even then am getting the same error saying  Key set does not exist”. Is the problem is because of the different IIS version or am I exporting the key in wrong way?

     

     

    Thanks

    Sathya N

    Monday, September 15, 2008 11:56 AM
  • Sathya,

     

    Sometimes app manager is having trouble doing the right thing - I don't know why yet.

     

    Try deleting the certificate on the server and then importing it using computercertificates.msc (in the tools directory of the SDK). And then grant using winhttpcertcfg.exe (also in the tools directory) in the way the sample apps do.

     

    Also try running the troubleshooter through IIS on the server, put in the app ID, and see what happens.

     

    Monday, September 15, 2008 6:01 PM
  • thanks a lot.. Thanks for everything..

    Take care..

    Bye
    Thursday, October 30, 2008 12:45 PM