locked
Paste in XS doesn't seem to pickup clipboard from other application RRS feed

  • Question

  • User350 posted

    Hi there, I seem to have a problem with XS, in that text I've copied to the clipboard in another application isn't present in the XS clipboard - only text copied in XS seems to be available.

    Is this a known problem?

    Thanks,

    James

    Thursday, April 25, 2013 9:33 PM

All replies

  • User350 posted

    Hmm... exited XS and re-loade solution, and it now works. Strange.

    Thursday, April 25, 2013 9:54 PM
  • User1044 posted

    I don't think this is a known problem, so if you can reproduce it again, let us know (and from which application you copied from, perhaps that makes a difference?)

    Friday, April 26, 2013 3:49 PM
  • User10327 posted

    XS Starter edition, Windows 7. Load up Tasky starter example. Open a .cs file. Copied two lines of source code from Xamarin docs recipe web page I was viewing in Chrome. Go back to cs file in XS and cannot paste. Like others say, clipboard appears empty to XS.
    Thanks

    Wednesday, May 1, 2013 5:16 AM
  • User1044 posted

    Hmmm, I just installed Chrome on my Windows VM and tested this out and it seems to work fine for me...

    I've submitted a bug for it anyway, though: https://bugzilla.xamarin.com/show_bug.cgi?id=12063

    Wednesday, May 1, 2013 8:26 PM
  • User1806 posted

    I fixed that on windows already

    Wednesday, May 1, 2013 8:32 PM
  • User4715 posted

    Copied 1 line from Notepad, tried to paste it to the source file in XS and got an error: The line is too long. Restarted XS and the error is gone.

    Friday, May 24, 2013 6:31 PM
  • User52521 posted

    I tried copying a block of code from the Hello Android tutorial and pasting it into the Xamarin code and nothing happens - no error message. I opened Notepad and was able to paste into it. I'm using Firefox to view the tutorial.

    Friday, May 16, 2014 2:30 PM
  • User106595 posted

    I've also just encountered this problem, perhaps it has something to do with the fact that I've had two instances of Xamarin Studio running? I also copied and pasted from one instance to the other without a hitch. When the bug occured, it didn't seem to matter where I pasted from, Firefox, charmap or notepad all didn't work.

    Thursday, April 2, 2015 11:07 AM
  • User28 posted

    This is a known issue, however the dev investigating has not been able to find reliable repro steps. If you have any further information about how to reproduce the problem, please add it to this bug: https://bugzilla.xamarin.com/show_bug.cgi?id=16519

    Thursday, April 2, 2015 4:45 PM
  • User106595 posted

    @mhutch Your link seems to be linking to another entry in Bugzilla.

    Friday, April 3, 2015 12:18 PM
  • User28 posted

    Sorry, fixed!

    Friday, April 3, 2015 4:25 PM