none
VS 2107, "traditional" (C++ only) Windows app project, would not change Character Set.

    Question

  • Hi!

    Something happened to my "traditional"Windows app project (I don't want to use ATL nor MFC with this project). It just switched to Multibyte char set, and changing the setting in Project properties (GUI) would not help.

    I also tried #define UNICODE in header file, no luck, all WinApis default to A which creates huge problem.

    I thought that maybe some global setting kicked in in my Visual Studio installation, so I opened another Windows app project, and this time it defaulted to UNICODE, and would not switch to Multibyte. Strange. 

    Would you have any idea what might happen, and where I could start looking to have this fixed?

    Thank you!

    Thursday, December 6, 2018 9:17 AM

All replies

  • Hi BeeBee89,

    Welcome to the MSDN forum.

    Refer to your description, this issue is about the C++ development and our forum is to discuss the VS IDE, I will help you move this thread to the appropriate forum for a better support, thank you for your understanding.

    Best regards,

    Sara


    MSDN Community Support Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com

    Friday, December 7, 2018 3:06 AM

  •  It just switched to Multibyte char set, and changing the setting in Project properties (GUI) would not help.

    I also tried #define UNICODE in header file, no luck, all WinApis default to A which creates huge problem.


    If you are using precompiled headers, try turning their use off ("Not Using ...") 
    in the project properties. Then do a Clean and Rebuild (not Build). See if 
    anything changes.

    Also make sure that the very first #include directive is

    #include "stdafx.h"

    - Wayne

    Friday, December 7, 2018 3:39 AM