none
BizTalk 2010 - EDI Batching Service - Delimiter specifications ignored? RRS feed

  • Question

  • Hello,

    I am having a weird issue and I can't figure out how to fix it. I have a BizTalk process generating EDI 837I files. That works fine, and all the files with single ST/SE transaction sets are generated in a folder, with the correct delimiters as specified in the agreement settings (segment terminator of "~" and "CR LF" suffix).

    I have then the batching service pick up the files, and a single file gets generated correctly. All the fields look correct, however the only issue is that the batched file is not following the delimiter specifications any longer, as the segment terminator is not set to "~" , but just "CR LF".

    What am I doing wrong? Is there a separate section for setting the delimiters for the files generated by the batching service?

    Thanks

    PS - I applied the latest Cumulative Update 6 already


    • Edited by Steven G_ Wednesday, August 14, 2013 7:43 PM
    Wednesday, August 14, 2013 7:43 PM

Answers

  • And you're not setting the EDIOverride properties I'll assume.

    If you route the batch to a different Send Port, one not specified in the Agreement, you should get an error.

    Also, make sure you've set the delimiters on the right Tab of the Agreement.

    • Marked as answer by Pengzhen Song Thursday, August 22, 2013 6:18 AM
    Thursday, August 15, 2013 5:23 PM

All replies

  • First, check that the batch send port is also listed under the Agreement.

    However, is there a reason you're taking the round trip through the file folder?

    You really can just route the individual messages to the Batching Service.

    The EDI Assembler will use the delimiters from whatever Agreement resolves, regardless of the message type.

    You might also disable the Fallback Settings in case that's getting used unintentionally.

    Wednesday, August 14, 2013 8:19 PM
  • The batch send port is already listed under the Agreement, and the Fallback Settings are disabled as well (plus they are set to different delimiters so I know it's not picking them up from there).

    The batched files, no matter what delimiters I specify in the Agreement, keep on defaulting to * as the data element separator, ":" as the component separator, and CR LF as the segment terminator. As mentioned before, all the unbatched files have the correct delimiters, but all the delimiters get changed after batching.

    In my test box, there is only 1 agreement defined, so I am not really sure where those wrong delimiters are coming from... Any more help?

    Thanks

    Thursday, August 15, 2013 4:23 PM
  • And you're not setting the EDIOverride properties I'll assume.

    If you route the batch to a different Send Port, one not specified in the Agreement, you should get an error.

    Also, make sure you've set the delimiters on the right Tab of the Agreement.

    • Marked as answer by Pengzhen Song Thursday, August 22, 2013 6:18 AM
    Thursday, August 15, 2013 5:23 PM
  • In BizTalk 2010 for weird issue problem as mentioned check this - You route the batch on same send Port and set delimiters on the right Tab.

    http://www.athenainfotech.co.uk/biztalk-consultancy-services

    Thursday, August 29, 2013 1:25 PM