locked
VS2017 v15.5.2 - Ordered Test - No available tests RRS feed

  • Question

  • I have a test class in my unit test project with multiple unit tests, which I want to run in a specified order, but none are available?!


    Jovica

    Sunday, December 24, 2017 4:16 PM

All replies

  • Hi Jovica,

    Welcome to MSDN forum.

    Yes, I have meet the same issue as yours when use VS2017 v15.5.2, I have reported this issue to the product team before.

    https://developercommunity.visualstudio.com/content/problem/172694/no-available-tests-in-orderedtest1orderedtest.html

    You could vote it and add comment. Microsoft VS product engineers will evaluate it seriously, please wait patiently till it is fixed in the next release.

    Thanks for your understanding and support.

    Regards,

    Judyzh


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Judy ZhuY Tuesday, December 26, 2017 8:43 AM
    • Unproposed as answer by Judy ZhuY Friday, January 12, 2018 7:48 AM
    Monday, December 25, 2017 5:43 AM
  • I have the same problem. Using v15.5.3
    Wednesday, January 10, 2018 10:20 AM
  • Hi D.Jonas,

    If you have similar issue, you may post another thread in this forum, we will help you solve this according to the specified error information.

    Usually, we discuss one issue in one thread and it can help us to trace and research your issue. Thank you for your understanding.

    Regards,

    Judyzh


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Thursday, January 11, 2018 9:04 AM
  • I just started using the mstest stuff, and with a brand new project the ordered test editor doesn't find the 3 tests I started with.

    This is using version 15.5.3. The test project was created from scratch (yesterday).

    Thursday, January 11, 2018 5:39 PM
  • Hi Keith,

    Welcome to MSDN forum.

    I can reproduce the issue in Visual Studio 2017 v15.5.3.

    About this issue, it has reported to the product team before, this is not a bug.

    https://developercommunity.visualstudio.com/content/problem/172512/unit-test-not-displayed-in-ordered-test.html

    In addition, we discuss one issue in one thread and it can help us to trace and research your issue. So, if you have similar issue, you may post another thread in the forum.

    Thanks for your understanding.

    Regards,

    Judyzh


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    Friday, January 12, 2018 7:43 AM
  • Hi Jovica,

    I think I found a solution, please refer to the reply I provided to Keith.

    If it helps you, please mark it as an answer.

    Thanks for your understanding and support.

    Regards,

    Judyzh


    MSDN Community Support
    Please remember to click "Mark as Answer" the responses that resolved your issue, and to click "Unmark as Answer" if not. This can be beneficial to other community members reading this thread. If you have any compliments or complaints to MSDN Support, feel free to contact MSDNFSF@microsoft.com.

    • Proposed as answer by Judy ZhuY Friday, January 12, 2018 7:48 AM
    Friday, January 12, 2018 7:48 AM