locked
How do I expand the size of the EW4 editing panel? RRS feed

  • Question

  • I use multiple monitors in order to move all the tool panels off the main page so I can maximise the editing window.

    I know there must be a simple answer but I can't find it...how do I expand the size of the main editing window in design view?

    TIA.

    Wednesday, March 2, 2011 12:30 AM

Answers

  • Put your mouse on the edges, and drag them wider.

    • Marked as answer by buddha6 Wednesday, March 2, 2011 1:34 PM
    • Unmarked as answer by buddha6 Wednesday, March 2, 2011 1:35 PM
    • Marked as answer by buddha6 Wednesday, March 2, 2011 1:40 PM
    Wednesday, March 2, 2011 1:00 AM
  • Just as Kathy said "Put your mouse on the edges, and drag them wider"You will see the pointer turn into a double headed arrow to make it bigger or smaller .

    MIKE E


    "It's like déjà vu all over again." — Yogi Berra
    • Marked as answer by buddha6 Wednesday, March 2, 2011 1:34 PM
    • Unmarked as answer by buddha6 Wednesday, March 2, 2011 1:34 PM
    • Marked as answer by buddha6 Wednesday, March 2, 2011 1:40 PM
    Wednesday, March 2, 2011 12:19 PM
  • All I can say is that it works fine for me.

    Try an experiment, just for curiosity:  Don't use dual monitors.  Close or shrink the panes beside the editing window.  Can you now expand the edting window?  Just wondering if there's a quirk in using dual monitors. 

    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:31 PM
    Wednesday, March 2, 2011 3:15 PM
  • The maximum size of the editable window area in Design view is dictated by 2 things:
    1) the screen size minus the bits used by chrome and panels

    2) The page size set.  A page set to 760px wide will result in an editable area 760px wide, no matter how much width is allocated to the design area. To change the page size, click the size in status bar at bottom right of design window.

    If you switch to code view, can you adjust the window containing the code?


    Ron Symonds
    Microsoft MVP (Expression Web)

    www.rxs-enterprises.org/fp
    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:31 PM
    Wednesday, March 2, 2011 4:06 PM
  • That's what I thought but it doesn't work. I can resize any of the panels open in my left monitor but I can't get the editing window to fill the workspace on the right. The application maximises to fill the workspace but the actual editing panel fills about 30% of the real estate.

    Turn on Auto-Hide by clicking on the little push-pins on the panels. They'll all go away and your screen will expand to almost the width of your monitor, except for the little blue tabs to unhide the panels.

    This is on a single monitor, so I don't know if it will work with multiple monitors.


    Nancy Ward
    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:31 PM
    Wednesday, March 2, 2011 4:11 PM
  • Yep, I bet Ron is right. I can select a small page size in my wide EW window and I just see a sliver of my page with a whole bunch of gray on either side. When I change to "Current Page Size" it expands to fill the window.

    I can definitely state that none of this is any issue with using a dual monitor setup. I use two monitors all the time, and EW has no problem with it. Of course, as Nancy said, there is the option to autohide panels, which is what I usually do. I prefer to keep a browser window open on the second monitor, but I do occasionally move panels around. I've never had an issue with that.

    Jim

    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:30 PM
    Wednesday, March 2, 2011 5:03 PM
  • Ah, OK. So, from that, if I understand you correctly, you can accomplish what you're after, but it's not "sticky" from session to session.

    If so, I'm not sure that there is currently a resolution. One of the thorniest issues EW users have complained about ever since the release of EW3 (when we lost customizable toolbars and VBA macros) has been the lack of customizability of the EW interface, primarily focused on the toolbars, but true as well for other aspects. There is not even close to an equivalent of the ubiquitous Workspace Manager menu in Adobe products, that lets you select from, for example, Classic, Coder Plus, Designer, etc. in Dreamweaver, and the equivalents in other Adobe apps. And there is no ability to configure a workspace to one's liking and then save it with your own choice of name.

    So, if that's what you're looking for, sorry, AFAIK there is no equivalent to that capability. Would I love to have it? Sure, me and several thousands of other EW users. Are we likely to get it? Hmm, dunno. As long as we're cursed with WPF as a basis for the application, prospects don't look good (WPF was the reason given for losing toolbar customizability, IIRC).

    Anyway, the upshot is that I don't know if there is any way to make your preferred layout sticky across sessions, so you may just have to keep setting up manually whenever you start up. Sorry.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:30 PM
    Wednesday, March 2, 2011 6:10 PM
  • The maximum size of the editable window area in Design view is dictated by 2 things:
    1) the screen size minus the bits used by chrome and panels

    2) The page size set.  A page set to 760px wide will result in an editable area 760px wide, no matter how much width is allocated to the design area. To change the page size, click the size in status bar at bottom right of design window.

    If you switch to code view, can you adjust the window containing the code?


    Ron Symonds
    Microsoft MVP (Expression Web)

    www.rxs-enterprises.org/fp

    Hi Ron:

    Thanks for the assistance.  Switching to code view has no effect.

    I now suspect that it has something to do with how EW4 interprets the desktop when using multiple monitors. See my reply to Kathy above.

    John

     

    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:30 PM
    Wednesday, March 2, 2011 4:55 PM

All replies

  • Put your mouse on the edges, and drag them wider.

    • Marked as answer by buddha6 Wednesday, March 2, 2011 1:34 PM
    • Unmarked as answer by buddha6 Wednesday, March 2, 2011 1:35 PM
    • Marked as answer by buddha6 Wednesday, March 2, 2011 1:40 PM
    Wednesday, March 2, 2011 1:00 AM
  • Just as Kathy said "Put your mouse on the edges, and drag them wider"You will see the pointer turn into a double headed arrow to make it bigger or smaller .

    MIKE E


    "It's like déjà vu all over again." — Yogi Berra
    • Marked as answer by buddha6 Wednesday, March 2, 2011 1:34 PM
    • Unmarked as answer by buddha6 Wednesday, March 2, 2011 1:34 PM
    • Marked as answer by buddha6 Wednesday, March 2, 2011 1:40 PM
    Wednesday, March 2, 2011 12:19 PM
  • Thanks guys.

    That's what I thought but it doesn't work. I can resize any of the panels open in my left monitor but I can't get the editing window to fill the workspace on the right. The application maximises to fill the workspace but the actual editing panel fills about 30% of the real estate.

    As a Dreamweaver user of long standing, I'm trying to adapt to EW4 for its .Net capabilities but this is almost a show stopper.

    I suspect there's an easy answer and I'll continue to look but for now this is an aggravation. LOL

     

    Wednesday, March 2, 2011 1:39 PM
  • All I can say is that it works fine for me.

    Try an experiment, just for curiosity:  Don't use dual monitors.  Close or shrink the panes beside the editing window.  Can you now expand the edting window?  Just wondering if there's a quirk in using dual monitors. 

    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:31 PM
    Wednesday, March 2, 2011 3:15 PM
  • The maximum size of the editable window area in Design view is dictated by 2 things:
    1) the screen size minus the bits used by chrome and panels

    2) The page size set.  A page set to 760px wide will result in an editable area 760px wide, no matter how much width is allocated to the design area. To change the page size, click the size in status bar at bottom right of design window.

    If you switch to code view, can you adjust the window containing the code?


    Ron Symonds
    Microsoft MVP (Expression Web)

    www.rxs-enterprises.org/fp
    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:31 PM
    Wednesday, March 2, 2011 4:06 PM
  • That's what I thought but it doesn't work. I can resize any of the panels open in my left monitor but I can't get the editing window to fill the workspace on the right. The application maximises to fill the workspace but the actual editing panel fills about 30% of the real estate.

    Turn on Auto-Hide by clicking on the little push-pins on the panels. They'll all go away and your screen will expand to almost the width of your monitor, except for the little blue tabs to unhide the panels.

    This is on a single monitor, so I don't know if it will work with multiple monitors.


    Nancy Ward
    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:31 PM
    Wednesday, March 2, 2011 4:11 PM
  • Ron, that's a very good point.  We may be talking about two things.  I'm assuming the editing window (the thread topic says "editing panel"), which is not constrained by the page size settings, and you assume that the OP is talking about the visual page size inside that editing window, which is constrained by page size settings.  I bet you have hit the explanation.
    Wednesday, March 2, 2011 4:13 PM
  •  

    All I can say is that it works fine for me.

    Try an experiment, just for curiosity:  Don't use dual monitors.  Close or shrink the panes beside the editing window.  Can you now expand the editing window?  Just wondering if there's a quirk in using dual monitors. 


    Hi Kathy:

    Thanks for the reply.

    If I reset the workspace layout and then close all the panels the editing window expands to fill the entire workspace and I can then open and move panels to the left monitor.

    But, if I close EW4 and reopen it the editing panel is reduced back to the small size with no ability to re-size it.

    I suspect it's a quirk in using multiple monitors that could be explored by the development folks.

    Wednesday, March 2, 2011 4:52 PM
  • The maximum size of the editable window area in Design view is dictated by 2 things:
    1) the screen size minus the bits used by chrome and panels

    2) The page size set.  A page set to 760px wide will result in an editable area 760px wide, no matter how much width is allocated to the design area. To change the page size, click the size in status bar at bottom right of design window.

    If you switch to code view, can you adjust the window containing the code?


    Ron Symonds
    Microsoft MVP (Expression Web)

    www.rxs-enterprises.org/fp

    Hi Ron:

    Thanks for the assistance.  Switching to code view has no effect.

    I now suspect that it has something to do with how EW4 interprets the desktop when using multiple monitors. See my reply to Kathy above.

    John

     

    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:30 PM
    Wednesday, March 2, 2011 4:55 PM
  • Yep, I bet Ron is right. I can select a small page size in my wide EW window and I just see a sliver of my page with a whole bunch of gray on either side. When I change to "Current Page Size" it expands to fill the window.

    I can definitely state that none of this is any issue with using a dual monitor setup. I use two monitors all the time, and EW has no problem with it. Of course, as Nancy said, there is the option to autohide panels, which is what I usually do. I prefer to keep a browser window open on the second monitor, but I do occasionally move panels around. I've never had an issue with that.

    Jim

    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:30 PM
    Wednesday, March 2, 2011 5:03 PM
  • Jim:

    Do you move the various panels off to the other monitor or simply auto-hide them.

    On my setup the problem arises if I undock the panels and move them to another monitor.  As long as I keep EW4 open the editing panel is resized to the available screen size. If I close and reopen EW4, it remembers the panel layout but I can't resize the editing window.

    If I set the panels to autohide it works as expected.

    Thanks for your help.

    John

     

    Wednesday, March 2, 2011 5:23 PM
  • Ah, OK. So, from that, if I understand you correctly, you can accomplish what you're after, but it's not "sticky" from session to session.

    If so, I'm not sure that there is currently a resolution. One of the thorniest issues EW users have complained about ever since the release of EW3 (when we lost customizable toolbars and VBA macros) has been the lack of customizability of the EW interface, primarily focused on the toolbars, but true as well for other aspects. There is not even close to an equivalent of the ubiquitous Workspace Manager menu in Adobe products, that lets you select from, for example, Classic, Coder Plus, Designer, etc. in Dreamweaver, and the equivalents in other Adobe apps. And there is no ability to configure a workspace to one's liking and then save it with your own choice of name.

    So, if that's what you're looking for, sorry, AFAIK there is no equivalent to that capability. Would I love to have it? Sure, me and several thousands of other EW users. Are we likely to get it? Hmm, dunno. As long as we're cursed with WPF as a basis for the application, prospects don't look good (WPF was the reason given for losing toolbar customizability, IIRC).

    Anyway, the upshot is that I don't know if there is any way to make your preferred layout sticky across sessions, so you may just have to keep setting up manually whenever you start up. Sorry.

    cheers,
    scott


    Please remember to "Mark as Answer" the responses that resolved your issue. It is common courtesy to recognize those who have helped you, and it also makes it easier for visitors to find the resolution later.
    • Marked as answer by buddha6 Wednesday, March 2, 2011 6:30 PM
    Wednesday, March 2, 2011 6:10 PM