none
VS2015 Win10 Localhost not routing RRS feed

  • Question

  • Hi

    I have quite an interesting problem with my windows 10 machine. When I debug an MVC application, VS2015 starts IISExpress, attaches correctly, launches internet explorer, and then it just doesn't load the website. It looks like everything is running correctly, but nothing routes to localhost. I tried normal IIS as well, but nothing.

    I am on a corporate network, going through a proxy and we have static IP's. On the proxy I have excluded localhost as well.
    I also have virtual box installed.
    I have also done a re-install of virtual box, and a repair of VS2015.

    This was working up to a week ago, then it just suddenly stopped working. Last night it was working on my home network, where I was without proxy. But now it's not working again.

    If anyone has any insights as to why this is happening, it would be greatly appreciated.

    Wednesday, November 11, 2015 7:45 AM

Answers

  • Hi everyone

    Sorry for the late reply. So after months of struggling to get the localhost issue solved, I decided to just do a format. This helped, and the strange thing is I have re-installed all the previous apps and it's working.

    I guess there must have been one app that messed something up.

    Thanks for all the help.

    Regards

    • Marked as answer by TechnoDezi Wednesday, January 13, 2016 7:52 PM
    Wednesday, January 13, 2016 7:52 PM

All replies

  • Hi TechnoDezi,

    Firstly, please make sure you have set the Project Url in the right format. See the Project Url by [Project Properties]->[Web]->[Project Url]. Then You could ch0ose another browser on Standard ToolBar to see if it could work on other browsers。

    Best Regards,
    Li Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, November 12, 2015 1:51 AM
  • Hi Li Wang

    Thanks for the reply. The project itself should be correct, nothing changed since the last time it worked.
    I am quite convinced it has something to do with windows 10 and localhost.

    When I use localhost nothing happens, but when I use the pc name it gets routed to iis express, and I get the invalid hostname error which is consistent with iis not having a binding for it. But localhost just does nothing, it's like loading a url that doesn't exist.

    Regards

    Thursday, November 12, 2015 7:06 AM
  • Hi,

    Internet Options>Security tab, Intranet or Trusted sites zone.... explicitly add http://localhost/ to the zone list. File>Properties menu to determine which IE security zone a domain is mapped to. The Internet zone no longer seems to work on Win10.

    Use the slider control on the Security zone settings tab to quickly change the security level for the zone for testing purposes..... uncheck "Display intranet sites in compatibility view" on the Compatibility View Settings menu.

    You will find the localhost loopback flag on the about:flags page in Edge.


    Regards.


    Rob^_^



    Monday, November 16, 2015 3:16 AM
  • Hi Rob

    Thanks for the reply.
    This made no difference, still getting "This page could not be displayed".
    But it's really interesting that the Internet zone no longer seems to work on Win10.
    At this point it might be quicker to just format.

    Regards
    Dezi

    Monday, November 16, 2015 5:44 AM
  • Hi Dezi,

    I was experiencing the same issue and asked around.

    ref: http://blogs.msdn.com/b/ieinternals/archive/2012/03/23/understanding-ie10-enhanced-protected-mode-network-security-addons-cookies-metro-desktop.aspx

    there are two IE settings to change.

    first remove localhost from Trusted or Intranet zone lists.

    second, Advanced tab of Internet Options, uncheck "Enable Enhanced Protected Mode" and save your changes.... you will have to close and reopen IE for the full changes to take affect.... also turning off EPM will reset your network adaptor, you will have to re-login to your network if you are using a wireless connection before testing (otherwise you will get an "Your not connected to the internet" error page.

    From the File>Properties menu, localhost sites should now map to the internet zone.

    Regards.


    Rob^_^

    Tuesday, November 17, 2015 11:33 PM
  • Good morning

    Thanks for the suggestion. No luck :-(.

    EPM is never enabled on my dev machines. I also did a full IE settings reset just in case, but this issue still feels like its happening on a network level.

    Regards
    Dezi

    Wednesday, November 18, 2015 7:20 AM
  • Hi TechnoDezi,

    Is 127.0.0.1 work for you?

    Best Regards,
    Li Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Thursday, November 19, 2015 6:29 AM
  • Hi Li

    127.0.0.1 also doesn't work.

    Regards

    Friday, November 20, 2015 8:20 AM
  • Hi TechnoDezi,

    Ping 127.0.0.1 to check whether your loopback address is blocked?

    Best Regards,
    Li Wang


    We are trying to better understand customer views on social support experience, so your participation in this interview project would be greatly appreciated if you have time. Thanks for helping make community forums a great place.
    Click HERE to participate the survey.

    Wednesday, November 25, 2015 6:11 AM
  • Hi everyone

    Sorry for the late reply. So after months of struggling to get the localhost issue solved, I decided to just do a format. This helped, and the strange thing is I have re-installed all the previous apps and it's working.

    I guess there must have been one app that messed something up.

    Thanks for all the help.

    Regards

    • Marked as answer by TechnoDezi Wednesday, January 13, 2016 7:52 PM
    Wednesday, January 13, 2016 7:52 PM