locked
Could I open asp.net Web Site Configuration Tool in VS 2017? RRS feed

  • Question

  • User426001450 posted

    Hello to all

    I built a website with VS Express 2010 long ago and by that time the asp.net Web Site Configuration Tool was the tool to use to manage users accounts. I upgraded to VS 2017 and found that this tool is not there anymore and that Identity is the way to go now. Since I’ve been happy with the old tool, I would like to keep it. I will save a lot of time since I don’t have to read about Identity and implement it. Since this is the case, I do have several questions:

    1) Could I keep my old account configuration for users and still manage them with the Web Site Configuration Panel or I won’t be able to do that with VS 2017?

    2) If your answer is positive and I could do it, may you please provide information about how to do it and how to open the asp.net Web Site Configuration Tool in VS 2017?

    Thanks to all for your help.   

    Sunday, August 30, 2020 4:59 AM

Answers

  • User426001450 posted

    yij sun

    As far as I think,you could keep using Web Site Administration Tool in Visual Studio 2017.

    You could do just like this:

    1.Determine the port # that the project uses for IISExpress. Located in Properties \ Web of the project. Example: 54442

    2.Open a command prompt and change directories: CD C:\Program Files (x86)\IIS Express

    3.Execute the following command <be sure to replace the port with your port>
    iisexpress.exe /path:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles" /vpath:"/WebAdmin" /port:54442 /clr:4.0 /ntlm

    4.Minimize the command window

    5.Open Internet Explorer (not Edge or another browser otherwise authentication will not work)

    6.Enter the following URL: (replace the port with your port and use the path to your project):

    http://localhost/ASPNetAdmin/default.aspx?applicationPhysicalPath=C:[YOUR SITE PATH HERE]\&applicationUrl=/

    7.Enter your windows username and password to login to the Web Site Administration Tool

    8. Click on the Security link and then use the wizard to setup a new user (or proceed however you like)

    More details,you could refer to below article:

    http://blog.regencysoftware.com/post/2014/06/22/asp-net-web-site-administration-tool-visual-studio-2013

    Well, I gave up on this one. If this is the only way to do it, it is pure nonsense. This is confusing, too long and after the last step a login window pops up for me to login. I try my best and can not login. I try with another user name and even though I was able to login a message was display that I have to set the Database. It has been a nightmare to follow this link and to try to do it this way. Completely a waste of time and energy! 

    So, how did I solve the problem? Easy, just open one of the last Visual Studio version that still display the ASP.NET Web Site Administration Tool icon (in my case I have Visual Studio Express 2010); open the website that you are working with and click the tool icon, it's that simple.

    Thanks to all !! 

      

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, October 7, 2020 6:32 PM

All replies

  • User1535942433 posted

    Hi vstorpedo,

    1) Could I keep my old account configuration for users and still manage them with the Web Site Configuration Panel or I won’t be able to do that with VS 2017?

    2) If your answer is positive and I could do it, may you please provide information about how to do it and how to open the asp.net Web Site Configuration Tool in VS 2017?

    As far as I think,you could keep using Web Site Administration Tool in Visual Studio 2017.

    You could do just like this:

    1.Determine the port # that the project uses for IISExpress. Located in Properties \ Web of the project. Example: 54442

    2.Open a command prompt and change directories: CD C:\Program Files (x86)\IIS Express

    3.Execute the following command <be sure to replace the port with your port>
    iisexpress.exe /path:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles" /vpath:"/WebAdmin" /port:54442 /clr:4.0 /ntlm

    4.Minimize the command window

    5.Open Internet Explorer (not Edge or another browser otherwise authentication will not work)

    6.Enter the following URL: (replace the port with your port and use the path to your project):

    http://localhost/ASPNetAdmin/default.aspx?applicationPhysicalPath=C:[YOUR SITE PATH HERE]\&applicationUrl=/

    7.Enter your windows username and password to login to the Web Site Administration Tool

    8. Click on the Security link and then use the wizard to setup a new user (or proceed however you like)

    More details,you could refer to below article:

    http://blog.regencysoftware.com/post/2014/06/22/asp-net-web-site-administration-tool-visual-studio-2013

    Best regards,

    Yijing Sun

    Monday, August 31, 2020 3:04 AM
  • User426001450 posted

    Thanks for your help but is now working.

    This is what I did

    OK, let’s assume that my port number is 12345 and that the folder that is holding all my website files is call GCandy. So, the url to enter in the browser would be:

    http://localhost:12345/WebAdmin/default.aspx?applicationPhysicalPath=C:\GCandy&applicationUrl=/AppAdmin

     After this was entered the following error was displayed:

    This page can’t be displayed

    Make sure the web address http://localhost:12345 is correct.

    • Look for the page with your search engine.
    • Refresh the page in a few minutes.

    I did follow your instruction from your last post and from this link as well but is not working: https://coderwall.com/p/k3p6dq/asp-net-web-site-administration-tool-for-visual-studio-2017

    Thanks again

    Monday, August 31, 2020 11:47 PM
  • User1535942433 posted

    Hi vstorpedo,

    As far as I think,you need to use ASP.NETWebAdminFiles in url .And you need to check wheather  your site path is right.

    More details,you could refer to below article:

    https://stackoverflow.com/questions/32194465/where-is-web-site-administration-on-visual-studio-2015

    Best regards,

    Yijing Sun

    Tuesday, September 1, 2020 8:33 AM
  • User426001450 posted

    Hello, I do have a couple questions, you said: 

    yij sun

    Hi vstorpedo,

    As far as I think,you need to use ASP.NETWebAdminFiles in url .And you need to check wheather  your site path is right.

    More details,you could refer to below article:

    https://stackoverflow.com/questions/32194465/where-is-web-site-administration-on-visual-studio-2015

    Best regards,

    Yijing Sun

    First of all I can see that you said "As far as I think", what do you mean by that? Have you done it yourself? Have you accessed the Web site configuration tool using this link that you are providing or you just 'think' as you said that it could be done this way. It is not working for me at all.

    Second: where it reads " Path=C:[YOUR SITE PATH HERE]", for this part here, please provide an example of a site path, maybe the way that I'm entering it is wrong. My site resides on local server, C directory and inside a folder call CCandy. Should I include just the folder or some files inside the folder. Please provide a sample with the information that I just gave you.

    Thanks  

    Wednesday, September 2, 2020 6:39 PM
  • User475983607 posted

    The instructions work.  Keep in mind the ASP.NET Web Site Configuration tools ended with Visual Studio 2008 and ASP.NET Membership.  It's not very useful if for modern applications.   I guess if you are maintaining an older application it could be useful but mostly likely an older application is already configured.  

    Second: where it reads " Path=C:[YOUR SITE PATH HERE]", for this part here, please provide an example of a site path, maybe the way that I'm entering it is wrong. My site resides on local server, C directory and inside a folder call CCandy. Should I include just the folder or some files inside the folder. Please provide a sample with the information that I just gave you.

    It is the physical path to the application you want to configure.  You are the only one that know the path...

    c:\inetpub\wwwroot\myapplication

    Or 

    Wednesday, September 2, 2020 7:23 PM
  • User426001450 posted

    I built the Website long ago using Visual Studio menu. I never got involve with the IIS or with its configuration. I just followed File>New>Website on Visual Studio and installation and Website creation was done automatically for this particular project.

    I’m not sure, but I think that Visual Studio is using IIS Express for this. I’m saying this because when I open IIS (inetmgr) as an administrator there is nothing there, no Website to manage or default Website to display. For this reason I think that when I paste the following on the browser address bar, it does not go anywhere and keep telling me that document cannot be found.  http://localhost:8082/asp.netwebadminfiles/default.aspx?applicationPhysicalPath=C:\inetpub\wwwroot\CCandy\&applicationUrl=/

    I’m assuming that I’m having problem here locating where the Website reside on the local server and what server is hosting the Website, IIS or IIS Express. I believe that IIS Express is built into Visual Studio if I don’t make a mistake here.

    Now everything has come to the following: How could I find where the Webpage reside and its correct path. Secondly, if I find the correct path and I repeat the steps from the link, is it going to work? How could I find the correct path?

    Thank all for your help  

    Thursday, September 3, 2020 2:57 AM
  • User475983607 posted

    If you followed the instructions, the IIS express host is running in the console window.  It seems like you are not following the instructions and making up your own path.

    Thursday, September 3, 2020 9:33 AM
  • User426001450 posted

    Sorry, but all of this is new for me and I’m not familiar with what I’m doing. The only one to blame here is Microsoft. Usually, new upgraded software allows users to run old apps without any problem or issues. Everything that we used to do in the old version should be on the new one but better and with more tools. Microsoft left many people behind and those that upgraded from Membership to Identity invested unnecessary time and money if they did it against their will. This is my case.

    I’m sure that would have been far better if Microsoft would have both options with Visual Studio. Those that want to keep using Membership could and those that want to upgrade or use the new ‘Identity’ could; this is without allowing  having both at the same time on the app or Website.

    On the other hand, you said:

    If you followed the instructions, the IIS express host is running in the console window.  It seems like you are not following the instructions and making up your own path.

    I think that I followed all the instruction as was provided on the links. Since it is not working for me, several things may be happening: Maybe these instructions don’t work when IIS Express is hosting the page. I’m saying this because when I open IIS (No the Express) as administrator and try to find if it is hosting any Website or there is any on default, I couldn’t find anything. But it is my understanding that all the instruction provided to me so far is to deal with IIS and not the Express. Please correct me if I’m wrong here.

    When I add the sample path that you provided to me and make some changes according to my site name, the browser display error and tells me that there is not files at all in that location. The following is the path that you provided and is not working: c:\inetpub\wwwroot\myapplication. (I added my application name). There is nothing there according to the browser.  

    The question that I have now is: Does this path work as well when IIS Express is hosting the page?

    Sorry and I do apologize if I’m doing something wrong, not following the instructions or making up my own path as you said. If that is the case, let’s start from the beginning again, please provide me with clear instruction of what I have to do and hopefully this time I could get it done.

    Thanks for your help

    Thursday, September 3, 2020 1:49 PM
  • User475983607 posted

    vstorpedo

    I think that I followed all the instruction as was provided on the links. Since it is not working for me, several things may be happening: Maybe these instructions don’t work when IIS Express is hosting the page. I’m saying this because when I open IIS (No the Express) as administrator and try to find if it is hosting any Website or there is any on default, I couldn’t find anything. But it is my understanding that all the instruction provided to me so far is to deal with IIS and not the Express. Please correct me if I’m wrong here.

    Your adding steps and troubleshooting items that have nothing to do with the instructions.  There are two steps.  The first steps hosts the Web Administration tools in the console window.  This step assume you have the Web Administration tool on your system and IIS Express.  All you have to do is open the command prompt then enter the following two lines of code.

    cd C:\Program Files\IIS Express\
    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm

    Results

    Copied template config file 'C:\Program Files\IIS Express\AppServer\applicationhost.config' to 'C:\Users\someuser\AppData\Local\Temp\iisexpress\applicationhost202093141337623.config'
    Updated configuration file 'C:\Users\someuser\AppData\Local\Temp\iisexpress\applicationhost202093141337623.config' with given cmd line info.
    Starting IIS Express ...
    Successfully registered URL "http://localhost:8082/" for site "Development Web Site" application "/"
    Successfully registered URL "http://localhost:8082/ASP.NETWebAdminFiles/" for site "Development Web Site" application "/ASP.NETWebAdminFiles"
    Registration completed
    IIS Express is running.
    Enter 'Q' to stop IIS Express

    Do not close the console window.  For step 2 all you have to do is open a browser and enter the URL for the admin tool you created in the first step.

    http://localhost:8082/asp.netwebadminfiles/default.aspx

    The URL above will open the application but the URL is missing the application path to configure.  You'll get an error if you use the URL above but the Web Admin tool should display in the browser window.

    You need to add two parameters to the URL; applicationPhysicalPath and applicationUrl.  The applicationURL is just "/".  All you have to do is add the physical path to your application.  Forum members have no idea what that path is... Only you know the path!

    Working example from my machine... be sure to replace any spaces in the path with %20

    http://localhost:8082/asp.netwebadminfiles/default.aspx?applicationPhysicalPath=C:\Users\someuser\Documents\Visual%20Studio%202019\Projects\NetApps\WebFormsDemo&applicationUrl=/

    You can find the path to the project using Visual Studio if you do not know where your project files are located on your hard drive.  Right click on the project in project explorer and select "Open Folder in File Explorer".  That's it.

    There's no reason to open IIS Express and all the other stuff you're doing.  Just follow the instructions and you'll be fine.

    Thursday, September 3, 2020 2:30 PM
  • User426001450 posted

    Ok, your instructions have been followed and it is not working. At the end the browser display the following errors.  

    1) First I entered the URL with the port 8082 as you instructed me to do (http://localhost:8082 ………..) and this is the message that the browser is displaying:

     This page can’t be displayed

    • Make sure the web address http://localhost:8082 is correct.
    • Look for the page with your search engine.
    • Refresh the page in a few minutes.

    Fix connection problems

    **************************************************

    2) Since the before error message only display the localhost and the port number I thought that the problem may be the port number.

    Since the cmd displayed this message: ‘Successfully registered URL "http://localhost:8080/" for site "Development Web Site" application "/";

    I thought that maybe I should try with port 8080 instead. So, I changed the URL and added port 8080 instead and I got the following message now: 

    Server Error in '/' Application.

     Access is denied.

    Description: An error occurred while accessing the resources required to serve this request. The server may not be configured for access to the requested URL.

     Error message 401.2.: Unauthorized: Logon failed due to server configuration.  Verify that you have permission to view this directory or page based on the credentials you supplied and the authentication methods enabled on the Web server.  Contact the Web server's administrator for additional assistance.

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.8.4110.0

    It may be important to note here that I have been logged on the Website as administrator in another tab on the same browser. I don’t know if this make a difference or not but since the message was related logon permission, I tried this as well.

    *************************************************

    3) Finally I tried something else. I right click my project on Visual Studio and then click on ‘properties window’ for my project and according to information there my project Website property URL is http://localhost:63170, so I tried with this new port and this is the browser message with this new port:

    Server Error in '/' Application.

    The resource cannot be found.

    Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly.

    Requested URL: /asp.netwebadminfiles/default.aspx

    Version Information: Microsoft .NET Framework Version:4.0.30319; ASP.NET Version:4.8.4110.0

    ********************************************

    Well, at this point I don’t know what to do, I followed your instructions and I tried with three different ports and it is not working at all. What do you think that I should do now?

     Thanks for your help

    Friday, September 4, 2020 5:44 AM
  • User475983607 posted

    vstorpedo

    Ok, your instructions have been followed and it is not working. At the end the browser display the following errors.

    If you followed the instructions then you should known the Web Administration host was not working before trying to open the application in your browser.  You would see an error message in the console or you would see the content I posted above. Seems odd you did not mention that part.

    First open the command prompt.  1) Click the start button and type "cmd".  2) Click on cmd.exe.

    Enter the following at the prompt.  This changes the directory (cd) to the IIS Express application folder (iisexpress.exe). 

    cd C:\Program Files\IIS Express\

    Then prompt changes to 

    C:\Program Files\IIS Express>

    Now enter the iisexpress.exe command to host Web Admin in IIS Express. https://docs.microsoft.com/en-us/iis/extensions/using-iis-express/running-iis-express-from-the-command-line

    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm

    You should see the following response in the console as explained above.

    Microsoft Windows [Version 10.0.19041.450]
    (c) 2020 Microsoft Corporation. All rights reserved.
    
    C:\WINDOWS\system32>cd C:\Program Files\IIS Express\
    
    C:\Program Files\IIS Express>iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm
    Copied template config file 'C:\Program Files\IIS Express\AppServer\applicationhost.config' to 'C:\Users\someuser\AppData\Local\Temp\iisexpress\applicationhost202094104211277.config'
    Updated configuration file 'C:\Users\someuser\AppData\Local\Temp\iisexpress\applicationhost202094104211277.config' with given cmd line info.
    Starting IIS Express ...
    Successfully registered URL "http://localhost:8082/" for site "Development Web Site" application "/"
    Successfully registered URL "http://localhost:8082/ASP.NETWebAdminFiles/" for site "Development Web Site" application "/ASP.NETWebAdminFiles"
    Registration completed
    IIS Express is running.
    Enter 'Q' to stop IIS Express

    Do NOT close the command prompt as it is hosting the Web Admin.  If you see an error then read the error and share the error here on the forum.  Otherwise, you should be able to open Web Admin in your browser at this point.

    vstorpedo

    1) First I entered the URL with the port 8082 as you instructed me to do (http://localhost:8082 ………..) and this is the message that the browser is displaying:

    The URL is configured in the following command line.  Why change the port?

    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm

    vstorpedo

    2) Since the before error message only display the localhost and the port number I thought that the problem may be the port number.

    Why?

    vstorpedo

    3) Finally I tried something else. I right click my project on Visual Studio and then click on ‘properties window’ for my project and according to information there my project Website property URL is http://localhost:63170, so I tried with this new port and this is the browser message with this new port:

    Huh?  Why?  You made this bit up and it has absolutely nothing to do with the Web Admin tool.

    I tested the above on 3 different machines without issue.  If you are still having issue then I assume you are missing IIS Express or the Web Admin tool.

    Friday, September 4, 2020 10:47 AM
  • User426001450 posted

    mgebhard

    You should see the following response in the console as explained above.

    Microsoft Windows [Version 10.0.19041.450]
    (c) 2020 Microsoft Corporation. All rights reserved.
    
    C:\WINDOWS\system32>cd C:\Program Files\IIS Express\
    
    C:\Program Files\IIS Express>iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm
    Copied template config file 'C:\Program Files\IIS Express\AppServer\applicationhost.config' to 'C:\Users\someuser\AppData\Local\Temp\iisexpress\applicationhost202094104211277.config'
    Updated configuration file 'C:\Users\someuser\AppData\Local\Temp\iisexpress\applicationhost202094104211277.config' with given cmd line info.
    Starting IIS Express ...
    Successfully registered URL "http://localhost:8082/" for site "Development Web Site" application "/"
    Successfully registered URL "http://localhost:8082/ASP.NETWebAdminFiles/" for site "Development Web Site" application "/ASP.NETWebAdminFiles"
    Registration completed
    IIS Express is running.
    Enter 'Q' to stop IIS Express

    I see the message, but is not completely the same, my message do not display the following:

    C:\Program Files\IIS Express>iisexpress.exe /path:C:\Windows\Microsoft.NET\Frame
    work\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm
    
    and 
    
    Successfully registered URL "http://localhost:8082/ASP.NETWebAdminFiles/" 
    for site "Development Web Site" application "/ASP.NETWebAdminFiles"

    What should I do now.

    Saturday, September 5, 2020 4:49 AM
  • User475983607 posted

    vstorpedo

    What should I do now.

    You did not enter the full iisexpress.exe command.  I'm not sure how to help you as it seems you are unable to follow basic instructions.

    You entered

    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles

    For some unknown reason you did not enter the command switches ; /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm

    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm

    It's just a copy and paste...

    Saturday, September 5, 2020 5:47 AM
  • User426001450 posted

    You did not enter the full iisexpress.exe command.  I'm not sure how to help you as it seems you are unable to follow basic instructions.

    You entered

    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles

    For some unknown reason you did not enter the command switches ; /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm

    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm

    It's just a copy and paste...

    No idea how that command got cut.

    I reenter the command and double check to be sure that the complete command is there now.

    Finally, I got the same information as you.

    Next, I paste the URL on the browser and a sign in window for localhost 8082 pop up asking me for UserName and Password. 

    Since I don't know what I'm doing, have not read anything about this procedure, don't know where to find information about this either, hate what Microsoft did and everything is weird and new for me, I do have a question: The UserName and Pasword to enter here are the ones for the Website user administrator, for the computer user or what? 

     

    Saturday, September 5, 2020 3:06 PM
  • User475983607 posted

    vstorpedo

    Next, I paste the URL on the browser and a sign in window for localhost 8082 pop up asking me for UserName and Password. 

    Make sure you run the command prompt as an administrator.  Right click the command prompt and run as administrator.  Otherwise maybe you are still missing a command switch.

    vstorpedo

    Since I don't know what I'm doing, have not read anything about this procedure, don't know where to find information about this either, hate what Microsoft did and everything is weird and new for me, I do have a question: The UserName and Pasword to enter here are the ones for the Website user administrator, for the computer user or what? 

    You are trying to use a tool that has not been around since VS 2008.   The documentation is here; https://docs.microsoft.com/en-us/previous-versions/aspnet/ms228053(v=vs.100)

    The admin tool does nothing special.  Most of the configuration you can just copy and paste from official documentation.  Can you you explain why you need the tool or what problem you are trying to solve?  

    Perhaps move to a modern framework.  

    Saturday, September 5, 2020 6:19 PM
  • User426001450 posted

    It was run as administrator and I was sure that the command was not cut this time. After that I compared my console response with yours and it was exactly the same. So, I believe that up to that point everything is fine.

    Since you said the following:

    Make sure you run the command prompt as an administrator.  Right click the command prompt and run as administrator.  Otherwise maybe you are still missing a command switch.

    So, what do you mean? That if run as an administrator and the command is complete with the switch, after entering the URL to the browser, the login window should not pop up? Is this what you mean?

    ...........  Can you you explain why you need the tool or what problem you are trying to solve?  

    Perhaps move to a modern framework.  

    The page is fine and running, I do not have any reason whatsoever to upgrade or move to a modern framework. I like it the way it is and the Website configuration tool was doing more than we ask for. So, why to upgrade, waste time, change code, pages, money and so on. If the car that I have takes me from point A to B and I'm happy with that, nobody should force me to change my car. Microsoft messed up.

    I cannot tell you that we will never upgrade, we may, but for sure not now if we could solve this problem.

    Saturday, September 5, 2020 7:00 PM
  • User475983607 posted

    I assume the prompt is asking for your Windows credentials.   I can't see the prompt.   If you know your Windows credentials enter them and that should get you to the admin page.

    The page is fine and running, I do not have any reason whatsoever to upgrade or move to a modern framework.

    Keep in mind, you can always go back to Visual Studio 2008 or 2010 which has the tool and supports the older frameworks.

    Saturday, September 5, 2020 10:09 PM
  • User426001450 posted

    It is weird that none of your computers show the login pop up window. If you watch the following video that talk about this problem you will see the pop up window. You don't have to watch the entire video, only the last minute at minute 6:42.

    Video link: https://www.youtube.com/watch?v=-t_bJW80NQQ

    Saturday, September 5, 2020 11:55 PM
  • User475983607 posted

    It is weird that none of your computers show the login pop up window. If you watch the following video that talk about this problem you will see the pop up window. You don't have to watch the entire video, only the last minute at minute 6:42.

    The Windows prompt means there is a configuration issue with your machine.  Enter the username and password you used to login to your machine.

    Sunday, September 6, 2020 10:43 AM
  • User426001450 posted

    I thought about that and did it before but didn't work

    Sunday, September 6, 2020 2:30 PM
  • User1535942433 posted

    Hi vstorpedo,

    Could you tell us what's your errors?

    I have create a test and it's works well.

    1.Open a command prompt and change directories: CD C:\Program Files\IIS Express

    2..Execute the following command <be sure to replace the port with your port>You could use 8080 port.
    iisexpress.exe /path:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles" /vpath:"/WebAdmin" /port:8080 /clr:4.0 /ntlm

    3.Open Internet Explorer (not Edge or another browser otherwise authentication will not work).

    4.Enter the following URL: (replace the port with your port and use the path to your project):

    http://localhost/WebAdmin/default.aspx?applicationPhysicalPath=C:[YOUR project path ]\&applicationUrl=/

    5.Successfully.

    Best regards,

    Yijing Sun

    Tuesday, September 8, 2020 8:09 AM
  • User475983607 posted

    vstorpedo

    I thought about that and did it before but didn't work

    I'm not sure why you do not know the username and password.  This might be an issue with your browser not being able to negotiate your Windows credentials.   Try Internet Explorer as IE is configured to negotiate Windows Credentials.

    If IE still does not work then for some reason the folder....

    C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles

    ...security is not allowing your credential to access the folder.  Make sure you are logging in as an admin and make sure the folder security allows the admin account Read/Write access to the folder.

    Tuesday, September 8, 2020 10:54 AM
  • User426001450 posted

    <be sure to replace the port with your port>You could use 8080 port.
    Open Internet Explorer (not Edge or another browser otherwise authentication will not work).

    Thanks for your help. I did it with port 8080 and 8082 and with the Explorer but it is not working. I'm getting the following message either way:

     

    Server Error in '/' Application.
    
    The resource cannot be found. 
      Description: HTTP 404. The resource you are looking for (or one of its dependencies) could have been removed, had its name changed, or is temporarily unavailable.  Please review the following URL and make sure that it is spelled correctly. 
    
     Requested URL: /ASPNetAdmin/default.aspx
    
    
    Version Information: Microsoft .NET Framework Version:2.0.50727.8806; ASP.NET Version:2.0.50727.8762 

    Tuesday, September 8, 2020 2:08 PM
  • User475983607 posted

    The 404 (Not Found) error means the URL does not exist.  The URL is defined in the iisexpress.exe command.

    iisexpress.exe /path:C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:8082 /clr:4.0 /ntlm

    The URL above is 

    http://localhost:8082/asp.netwebadminfiles/default.aspx

    Please review the command and make sure you are using the correct URL.

    The URL is also shown in the console output which you can copy and paste.

    Tuesday, September 8, 2020 2:16 PM
  • User1535942433 posted

    Hi vstorpedo,

    As far as I think,you must make sure these:

    1.Cmd run as administrator.

    2.Port use 8080. And you will get successfully registered.

    3.Open with Internet Explorer.The path you must follow this:

    http://localhost:8080/[vpath]/default.aspx?applicationPhysicalPath=[your project path]&applicationUrl=/

    My result:

    Best regards,

    Yijing Sun

    Wednesday, September 9, 2020 2:23 AM
  • User426001450 posted

    Hi vstorpedo,

    As far as I think,you must make sure these:

    1.Cmd run as administrator.

    2.Port use 8080. And you will get successfully registered.

    3.Open with Internet Explorer.The path you must follow this:

    http://localhost:8080/[vpath]/default.aspx?applicationPhysicalPath=[your project path]&applicationUrl=/

    My result:

    Best regards,

    Yijing Sun

    Well, it work for you but it does not for me. At the very end when I enter URL to browser, the browser display a login window, I entered my Windows credentials and computer don't allow me to move forward. I don't know what to do now. If you are not getting the login pop up window, you don't know what I talking about and how frustrating this is. Check the video link that I posted three or four post behind this one and you will see what I'm talking about. 

    Wednesday, September 9, 2020 5:55 AM
  • User1535942433 posted

    Hi vstorpedo,

    Accroding to your description,I have tried that entering username and password.

    Could you post the result of successfully register in cmd and the path you have open in Internet Explorer?

    Could you post us your applicationhost config file?It will help us to solve your problems.

    By the way,in the applicationhost config ,you could add these to allow user login.

    Just like this:

    <authorization>
    <clear />
    <add accessType="Allow" users="[your account]" />
    </authorization>

    Best regards,

    Yijing Sun

    Thursday, September 10, 2020 8:42 AM
  • User426001450 posted

    yij sun

    Hi vstorpedo,

    Accroding to your description,I have tried that entering username and password.

    Could you post the result of successfully register in cmd and the path you have open in Internet Explorer?

    Here it is:

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.
    
    C:\Windows\system32>cd C:\Program Files (x86)\IIS Express
    
    C:\Program Files (x86)\IIS Express>iisexpress.exe /path:C:\Windows\Microsoft.NET
    \Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:
    63170 /clr:4.0 /ntlm
    Copied template config file 'C:\Program Files (x86)\IIS Express\AppServer\applic
    ationhost.config' to 'C:\Users\Terminal1\AppData\Local\Temp\iisexpress\applicationho
    st20209101919452.config'
    Updated configuration file 'C:\Users\Terminal1\AppData\Local\Temp\iisexpress\applica
    tionhost20209101919452.config' with given cmd line info.
    Starting IIS Express ...
    Successfully registered URL "http://localhost:63170/" for site "Development Web
    Site" application "/"
    Successfully registered URL "http://localhost:63170/ASP.NETWebAdminFiles/" for s
    ite "Development Web Site" application "/ASP.NETWebAdminFiles"
    Registration completed
    IIS Express is running.
    Enter 'Q' to stop IIS Express

    yij sun

    Could you post us your applicationhost config file?It will help us to solve your problems.

    Here it is:

    <?xml version="1.0"?>
    
    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <handlers>
          <remove name="ChartImageHandler" />
          <add name="ChartImageHandler" preCondition="integratedMode" verb="GET,HEAD,POST"
            path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </handlers>
      </system.webServer>
      
    
    <appSettings>
        <add key="ChartImageHandler" value="storage=file;timeout=20;dir=c:\TempImageFiles\;" />
      </appSettings>
      
    
    <connectionStrings>
        <add name="MainWebConnection" connectionString="xxxx Hidden xxxxxxx"/>
        <add name="SecondMainConnection" connectionString="xxxx Hidden xxxxxxx"/>
         </connectionStrings>
      <system.web>
       
        
        
        
        
        
        
        
        
        
        
        
        
        <!--To avoid the required non-alphanumeric character" -->
       
        <httpHandlers>
    
            <add path="ChartImg.axd" verb="GET,HEAD,POST" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
            validate="false" />
       
        </httpHandlers>
       
        
        
        
        <membership>
          <providers>
            <!--THIS STRING IS ONLY TO BE USED WITH THE ASP.NET WEB SITE ADMINISTRATION TOOL FOR WEBSITE ON LOCAL SERVER.  -->
            <add connectionStringName="SecondMainConnection" name="MyProvider" minRequiredNonalphanumericCharacters="0" maxInvalidPasswordAttempts="25" passwordAttemptWindow="30" type="System.Web.Security.SqlMembershipProvider"/>
          </providers>
        </membership>
        
        
        <roleManager enabled="true" cacheRolesInCookie="true" createPersistentCookie="true">
          <providers>
            <!--THIS STRING IS ONLY TO BE USED WITH THE ASP.NET WEB SITE ADMINISTRATION TOOL FOR WEBSITE ON LOCAL SERVER.   -->
            <add connectionStringName="SecondMainConnection" name="MyRoleProvider" type="System.Web.Security.SqlRoleProvider"/>
          </providers>
        </roleManager>
        
        
        <!-- The <authentication> section enables configuration of the security authentication mode used by ASP.NET to identify an incoming user. -->
        <authentication mode="Forms">
          <forms loginUrl="MemberService/Login.aspx"/>
        </authentication>
        <authorization>
          <allow roles="Administrator"/>
        </authorization>
    
    
    
    
    
    
    
    
    
    
           
        
        
        
        <pages controlRenderingCompatibilityVersion="3.5" maintainScrollPositionOnPostBack="true"
          clientIDMode="AutoID">
          <namespaces>
            <clear />
            <add namespace="System" />
            <add namespace="System.Collections" />
            <add namespace="System.Collections.Specialized" />
            <add namespace="System.Configuration" />
            <add namespace="System.Text" />
            <add namespace="System.Text.RegularExpressions" />
            <add namespace="System.Web" />
            <add namespace="System.Web.Caching" />
            <add namespace="System.Web.SessionState" />
            <add namespace="System.Web.Security" />
            <add namespace="System.Web.Profile" />
            <add namespace="System.Web.UI" />
            <add namespace="System.Web.UI.WebControls" />
            <add namespace="System.Web.UI.WebControls.WebParts" />
            <add namespace="System.Web.UI.HtmlControls" />
            <add namespace="System.Data.SqlClient" />
            <add namespace="System.Drawing" />
            <add namespace="System.IO" />
            <add namespace="System.Data" />
            <add namespace="System.Data.Odbc" />
            <add namespace="System.Web.UI.Page" />
            <add namespace="System.Web.Configuration" />
            <add namespace="System.Collections.Generic" />
            <add namespace="System.Net.Mail" />
            <add namespace="System.Security.Cryptography" />
            <add namespace="System.Drawing.Drawing2D" />
            <add namespace="System.Drawing.Imaging" />
            <add namespace="System.Drawing.Design" />
            <add namespace="System.Net" />
            <add namespace="System.Net.Mime" />
          </namespaces>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI.DataVisualization.Charting"
              assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </controls>
        </pages>
        
    
        <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          </assemblies>
        </compilation>
       
       
    
     <customErrors mode="Off">
          <!--  defaultRedirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" >
    
    
                <error statusCode="401" redirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" />
                <error statusCode="403" redirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" />
                <error statusCode="404" redirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" />
                <error statusCode="500" redirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" />
               -->
        </customErrors>
       
        
        
        
        <caching>
          <sqlCacheDependency enabled="true" pollTime="1000" >
            <databases>
              <add name="xxx hidden Database xxxx" connectionStringName="MainWebConnection" />
            </databases>
          </sqlCacheDependency>
        </caching>
      
        
        
        
        <httpRuntime maxRequestLength="51200" executionTimeout="1800"/>
       
        
        
        
       
        <sessionState timeout="360000" mode="InProc" />
     
      
      
      </system.web>
      <system.net>
        <mailSettings>
          <smtp>
            <network host="xxx hidden xxx" userName="xxx hidden xxx" password="xxx hidden xxx"/>
          </smtp>
        </mailSettings>
      </system.net>
    </configuration>
    
    

    yij sun

    By the way,in the applicationhost config ,you could add these to allow user login.

    Just like this:

    <authorization>
    <clear />
    <add accessType="Allow" users="[your account]" />
    </authorization>

    I did it and is not working.

    And this is the error that the browser is displaying after entering the URL:

    HTTP Error 401.1 - Unauthorized
    
    You do not have permission to view this directory or page using the credentials that you supplied.
    
    
    
    Most likely causes:
    •The username supplied to IIS is invalid.
    •The password supplied to IIS was not typed correctly. 
    •Incorrect credentials were cached by the browser.
    •IIS could not verify the identity of the username and password provided.
    •The resource is configured for Anonymous authentication, but the configured anonymous account either has an invalid password or was disabled.
    •The server is configured to deny login privileges to the authenticating user or the group in which the user is a member.
    •Invalid Kerberos configuration may be the cause if all of the following are true:
    ◦Integrated authentication was used.
    ◦the application pool identity is a custom account.
    ◦the server is a member of a domain.
    
    
    
    Things you can try:
    •Verify that the username and password are correct, and are not cached by the browser.
    •Use a different username and password.
    •If you are using a custom anonymous account, verify that the password has not expired.
    •Verify that the authenticating user or the user's group, has not been denied login access to the server.
    •Verify that the account was not locked out due to numerous failed login attempts.
    •If you are using authentication and the server is a member of a domain, verify that you have configured the application pool identity using the utility SETSPN.exe, or changed the configuration so that NTLM is the favored authentication type.
    •Check the failed request tracing logs for additional information about this error. For more information, click here. 
    
    
    
    Detailed Error Information:
    
    
    
    Module
       WindowsAuthenticationModule 
    
    Notification
       AuthenticateRequest 
    
    Handler
       PageHandlerFactory-Integrated-4.0 
    
    Error Code
       0xc000006d 
    
    
    
    Requested URL
       http://localhost:63170/webadmin/default.aspx?applicationPhysicalPath=C:\CCandy&applicationUrl=/ 
    
    Physical Path
       C:\Program Files (x86)\IIS Express\AppServer\empty_wwwroot\webadmin\default.aspx 
    
    Logon Method
       Not yet determined 
    
    Logon User
       Not yet determined 
    
    Request Tracing Directory
       C:\Users\Terninal1\Documents\IISExpress\TraceLogFiles\DEVELOPMENT WEB SITE 
    
    
    
    
    More Information:
    This error occurs when either the username or password supplied to IIS is invalid, or when IIS cannot use the username and password to authenticate the user. 
    View more information »
    
    Microsoft Knowledge Base Articles:
    •907273
    •871179
    •896861
    

    Thanks

    Friday, September 11, 2020 12:34 AM
  • User1535942433 posted

    Hi vstorpedo,

    Accroding to you have post,could you tell us is  the applicationhost config file your cmd resgistered successfully applicationhost20209101919452.config?

    And accroding to your applicationhost config file,it allow Administrator:

    <authorization>
          <allow roles="Administrator"/>
        </authorization>

    Do you have delete it and replace with:

    <authorization>
    <clear />
    <add accessType="Allow" users="[your account]" />
    </authorization>

    Or:

    <authorization>
            <allow users="?"/>
    </authorization>

    Best regards,

    Yijing Sun

    Friday, September 11, 2020 6:49 AM
  • User426001450 posted

    I'm having a hard time understanding your last post, English language and your meaning are not clear. May you please edit your last post for a better understanding. Sorry for that and thanks for your help.

    Friday, September 11, 2020 8:21 AM
  • User1535942433 posted

    Hi vstorpedo,

    Microsoft Windows [Version 6.1.7601]
    Copyright (c) 2009 Microsoft Corporation.  All rights reserved.

    C:\Windows\system32>cd C:\Program Files (x86)\IIS Express

    C:\Program Files (x86)\IIS Express>iisexpress.exe /path:C:\Windows\Microsoft.NET
    \Framework\v4.0.30319\ASP.NETWebAdminFiles /vpath:"/ASP.NETWebAdminFiles" /port:
    63170 /clr:4.0 /ntlm
    Copied template config file 'C:\Program Files (x86)\IIS Express\AppServer\applic
    ationhost.config' to 'C:\Users\Terminal1\AppData\Local\Temp\iisexpress\applicationho
    st20209101919452.config'
    Updated configuration file 'C:\Users\Terminal1\AppData\Local\Temp\iisexpress\applica
    tionhost20209101919452.config' with given cmd line info.
    Starting IIS Express ...
    Successfully registered URL "http://localhost:63170/" for site "Development Web
    Site" application "/"
    Successfully registered URL "http://localhost:63170/ASP.NETWebAdminFiles/" for s
    ite "Development Web Site" application "/ASP.NETWebAdminFiles"
    Registration completed
    IIS Express is running.
    Enter 'Q' to stop IIS Express

    <?xml version="1.0"?>

    <configuration xmlns="http://schemas.microsoft.com/.NetConfiguration/v2.0">
      <system.webServer>
        <validation validateIntegratedModeConfiguration="false" />
        <handlers>
          <remove name="ChartImageHandler" />
          <add name="ChartImageHandler" preCondition="integratedMode" verb="GET,HEAD,POST"
            path="ChartImg.axd" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
        </handlers>
      </system.webServer>
      

    <appSettings>
        <add key="ChartImageHandler" value="storage=file;timeout=20;dir=c:\TempImageFiles\;" />
      </appSettings>
      

    <connectionStrings>
        <add name="MainWebConnection" connectionString="xxxx Hidden xxxxxxx"/>
        <add name="SecondMainConnection" connectionString="xxxx Hidden xxxxxxx"/>
         </connectionStrings>
      <system.web>
       
        
        
        
        
        
        
        
        
        
        
        
        
        <!--To avoid the required non-alphanumeric character" -->
       
        <httpHandlers>

            <add path="ChartImg.axd" verb="GET,HEAD,POST" type="System.Web.UI.DataVisualization.Charting.ChartHttpHandler, System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35"
            validate="false" />
       
        </httpHandlers>
       
        
        
        
        <membership>
          <providers>
            <!--THIS STRING IS ONLY TO BE USED WITH THE ASP.NET WEB SITE ADMINISTRATION TOOL FOR WEBSITE ON LOCAL SERVER.  -->
            <add connectionStringName="SecondMainConnection" name="MyProvider" minRequiredNonalphanumericCharacters="0" maxInvalidPasswordAttempts="25" passwordAttemptWindow="30" type="System.Web.Security.SqlMembershipProvider"/>
          </providers>
        </membership>
        
        
        <roleManager enabled="true" cacheRolesInCookie="true" createPersistentCookie="true">
          <providers>
            <!--THIS STRING IS ONLY TO BE USED WITH THE ASP.NET WEB SITE ADMINISTRATION TOOL FOR WEBSITE ON LOCAL SERVER.   -->
            <add connectionStringName="SecondMainConnection" name="MyRoleProvider" type="System.Web.Security.SqlRoleProvider"/>
          </providers>
        </roleManager>
        
        
        <!-- The <authentication> section enables configuration of the security authentication mode used by ASP.NET to identify an incoming user. -->
        <authentication mode="Forms">
          <forms loginUrl="MemberService/Login.aspx"/>
        </authentication>
        <authorization>
          <allow roles="Administrator"/>
        </authorization>


           
        
        
        
        <pages controlRenderingCompatibilityVersion="3.5" maintainScrollPositionOnPostBack="true"
          clientIDMode="AutoID">
          <namespaces>
            <clear />
            <add namespace="System" />
            <add namespace="System.Collections" />
            <add namespace="System.Collections.Specialized" />
            <add namespace="System.Configuration" />
            <add namespace="System.Text" />
            <add namespace="System.Text.RegularExpressions" />
            <add namespace="System.Web" />
            <add namespace="System.Web.Caching" />
            <add namespace="System.Web.SessionState" />
            <add namespace="System.Web.Security" />
            <add namespace="System.Web.Profile" />
            <add namespace="System.Web.UI" />
            <add namespace="System.Web.UI.WebControls" />
            <add namespace="System.Web.UI.WebControls.WebParts" />
            <add namespace="System.Web.UI.HtmlControls" />
            <add namespace="System.Data.SqlClient" />
            <add namespace="System.Drawing" />
            <add namespace="System.IO" />
            <add namespace="System.Data" />
            <add namespace="System.Data.Odbc" />
            <add namespace="System.Web.UI.Page" />
            <add namespace="System.Web.Configuration" />
            <add namespace="System.Collections.Generic" />
            <add namespace="System.Net.Mail" />
            <add namespace="System.Security.Cryptography" />
            <add namespace="System.Drawing.Drawing2D" />
            <add namespace="System.Drawing.Imaging" />
            <add namespace="System.Drawing.Design" />
            <add namespace="System.Net" />
            <add namespace="System.Net.Mime" />
          </namespaces>
          <controls>
            <add tagPrefix="asp" namespace="System.Web.UI.DataVisualization.Charting"
              assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />
          </controls>
        </pages>
        

        <compilation debug="true" strict="false" explicit="true" targetFramework="4.0">
          <assemblies>
            <add assembly="System.Web.DataVisualization, Version=4.0.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35"/>
          </assemblies>
        </compilation>
       
       

     <customErrors mode="Off">
          <!--  defaultRedirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" >


                <error statusCode="401" redirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" />
                <error statusCode="403" redirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" />
                <error statusCode="404" redirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" />
                <error statusCode="500" redirect="~/Classifieds/MessagePage.aspx?PanelToView=PageErrorPanel" />
               -->
        </customErrors>
       
        
        
        
        <caching>
          <sqlCacheDependency enabled="true" pollTime="1000" >
            <databases>
              <add name="xxx hidden Database xxxx" connectionStringName="MainWebConnection" />
            </databases>
          </sqlCacheDependency>
        </caching>
      
        
        
        
        <httpRuntime maxRequestLength="51200" executionTimeout="1800"/>
       
        
        
        
       
        <sessionState timeout="360000" mode="InProc" />
     
      
      
      </system.web>
      <system.net>
        <mailSettings>
          <smtp>
            <network host="xxx hidden xxx" userName="xxx hidden xxx" password="xxx hidden xxx"/>
          </smtp>
        </mailSettings>
      </system.net>
    </configuration>

    My meaning is

    1.The applicationhost config you have posted wheather is applicationhost20209101919452 config file?

    2.Do you have delete allow Administrator then add allow your count or * in your applicationhost20209101919452 config file?

    <authorization>
    <clear />
    <add accessType="Allow" users="[your account]" />
    </authorization>

    or

    <authorization>
            <allow users="?"/>
    </authorization>

    Best regards,

    Yijing Sun

    Friday, September 11, 2020 9:38 AM
  • User426001450 posted

    Sorry but I don't understand your two questions, may you please rephrase them? Here are your two questions:

    My meaning is
    
    1.The applicationhost config you have posted wheather is applicationhost20209101919452 config file?
    
    2.Do you have delete allow Administrator then add allow your count or * in your applicationhost20209101919452 config file?

    If what you mean is that if I've tried 

    <authorization>
    <clear />
    <add accessType="Allow" users="[your account]" />
    </authorization>
    
    or
    
    <authorization>
            <allow users="?"/>
    </authorization>

    Yes, I tried both and it does not work.

    Thanks
     

    Friday, September 11, 2020 10:56 AM
  • User1535942433 posted

    Hi vstorpedo,

    vstorpedo

    HTTP Error 401.1 - Unauthorized

    You do not have permission to view this directory or page using the credentials that you supplied.

    Most likely causes:
    •The username supplied to IIS is invalid.
    •The password supplied to IIS was not typed correctly. 
    •Incorrect credentials were cached by the browser.
    •IIS could not verify the identity of the username and password provided.
    •The resource is configured for Anonymous authentication, but the configured anonymous account either has an invalid password or was disabled.
    •The server is configured to deny login privileges to the authenticating user or the group in which the user is a member.
    •Invalid Kerberos configuration may be the cause if all of the following are true:
    ◦Integrated authentication was used.
    ◦the application pool identity is a custom account.
    ◦the server is a member of a domain.

    Things you can try:
    •Verify that the username and password are correct, and are not cached by the browser.
    •Use a different username and password.
    •If you are using a custom anonymous account, verify that the password has not expired.
    •Verify that the authenticating user or the user's group, has not been denied login access to the server.
    •Verify that the account was not locked out due to numerous failed login attempts.
    •If you are using authentication and the server is a member of a domain, verify that you have configured the application pool identity using the utility SETSPN.exe, or changed the configuration so that NTLM is the favored authentication type.
    •Check the failed request tracing logs for additional information about this error. For more information, click here. 

    Detailed Error Information:

    Module
       WindowsAuthenticationModule 

    Notification
       AuthenticateRequest 

    Handler
       PageHandlerFactory-Integrated-4.0 

    Error Code
       0xc000006d 

    Requested URL
       http://localhost:63170/webadmin/default.aspx?applicationPhysicalPath=C:\CCandy&applicationUrl=/ 

    Physical Path
       C:\Program Files (x86)\IIS Express\AppServer\empty_wwwroot\webadmin\default.aspx 

    Logon Method
       Not yet determined 

    Logon User
       Not yet determined 

    Request Tracing Directory
       C:\Users\Terninal1\Documents\IISExpress\TraceLogFiles\DEVELOPMENT WEB SITE 


    More Information:
    This error occurs when either the username or password supplied to IIS is invalid, or when IIS cannot use the username and password to authenticate the user. 
    View more information »

    Microsoft Knowledge Base Articles:
    •907273
    •871179
    •896861

    Do you have meet 401 issues?As far as I think,you could check the failed request tracing logs for additional information about this error.

    Or you could set authentication.

    1.Open IIS and select site that is causing 401

    2.Select Authentication property in IIS Header

    3.Select Anonymous Authentication

    4.Right click on it, select Edit and choose Application pool identity

    5.Restart site 

    You could refer to below article:

    https://stackoverflow.com/questions/11162430/401-unauthorized-on-a-directory

    Best regards,

    Yijing Sun

    Wednesday, September 16, 2020 6:48 AM
  • User426001450 posted

    yij sun

    Or you could set authentication.

    1.Open IIS and select site that is causing 401

    2.Select Authentication property in IIS Header

    3.Select Anonymous Authentication

    4.Right click on it, select Edit and choose Application pool identity

    5.Restart site 

    You could refer to below article:

    https://stackoverflow.com/questions/11162430/401-unauthorized-on-a-directory

    Best regards,

    Yijing Sun

    I only have two options for Anonymous authentication: Enable and Disabled. I do have IIS Express on my local computer and these are the only two options that I see. If there is any way around let me know.

    On the other hand I tried to configure the browser since it looks that is a security issue. I followed the instructions on the following links for the Internet Explorer: https://www.lansweeper.com/knowledgebase/enabling-or-disabling-login-prompts/ 

    I read the link and followed the instructions steps by steps but is not working either. So, at this point I'm about to give up, nothing seem to work.

    Since you do not have that problem and after you paste the URL on the browser, it take you straight to the Web Site Configuration Tool, may you please let me know what is the configuration that you have on your Internet Explorer under security. I don't know what else to do. 

    Thanks   

    Wednesday, September 23, 2020 6:52 PM
  • User1535942433 posted

    Hi vstorpedo,

    As far as I think,there's nothing with the browser.Now,we need to start from scratch.

    Could you post your cmd prompt which successfully register to us?Just like this:

    Note:You could use port:8080 replace your 63170.

    And then,if you successfully register,could you post applicationhostxxxxx.config to us?It is like  the above result I have drawed.

    Best regards,

    Yijing Sun

    Thursday, September 24, 2020 8:49 AM
  • User426001450 posted

    Hi vstorpedo,

    As far as I think,there's nothing with the browser. Now,we need to start from scratch.

    No, we don't need to start from scratch. The only problem is that at the very end when the URL is paste to browser, a login Window pops up. That's is the only problem at this time. 

    It is my understanding that this is a security issue, the IIS Express setting must be changed in order to stop this Window login from popping up. This pop up is asking for my Windows credential. I typed my credentials but for some reason it does not log me in even though I'm sure that I'm typing the correct one.

    What I'm trying to do now is to disable Window Authentication on the IIS Express. But at the same time I don't know what to do with the Anonymous Authentication. Should both be disabled? Another thing is that I'm not sure if additional code should be added to the web.conf file after I do this.  

    So far I tried by changing Window Authentication = disable and Anonymous Authentication = enabled but the pop up is still showing. I don't know if some code must be added to the web.conf file after this is done.

    I thing that it may work if I could disable the server Window Authentication, but so far I've not figure out how to do it. 

    Thanks 

    Sunday, September 27, 2020 5:23 AM
  • User1535942433 posted

    Hi vstorpedo,

    It is my understanding that this is a security issue,

    Yes,your are right. However, we need to make sure where the error  was raised.So,we need you post your cmd prompt.

    Best regards,

    Yijing Sun

    Wednesday, September 30, 2020 9:08 AM
  • User426001450 posted

    yij sun

    As far as I think,you could keep using Web Site Administration Tool in Visual Studio 2017.

    You could do just like this:

    1.Determine the port # that the project uses for IISExpress. Located in Properties \ Web of the project. Example: 54442

    2.Open a command prompt and change directories: CD C:\Program Files (x86)\IIS Express

    3.Execute the following command <be sure to replace the port with your port>
    iisexpress.exe /path:"C:\Windows\Microsoft.NET\Framework\v4.0.30319\ASP.NETWebAdminFiles" /vpath:"/WebAdmin" /port:54442 /clr:4.0 /ntlm

    4.Minimize the command window

    5.Open Internet Explorer (not Edge or another browser otherwise authentication will not work)

    6.Enter the following URL: (replace the port with your port and use the path to your project):

    http://localhost/ASPNetAdmin/default.aspx?applicationPhysicalPath=C:[YOUR SITE PATH HERE]\&applicationUrl=/

    7.Enter your windows username and password to login to the Web Site Administration Tool

    8. Click on the Security link and then use the wizard to setup a new user (or proceed however you like)

    More details,you could refer to below article:

    http://blog.regencysoftware.com/post/2014/06/22/asp-net-web-site-administration-tool-visual-studio-2013

    Well, I gave up on this one. If this is the only way to do it, it is pure nonsense. This is confusing, too long and after the last step a login window pops up for me to login. I try my best and can not login. I try with another user name and even though I was able to login a message was display that I have to set the Database. It has been a nightmare to follow this link and to try to do it this way. Completely a waste of time and energy! 

    So, how did I solve the problem? Easy, just open one of the last Visual Studio version that still display the ASP.NET Web Site Administration Tool icon (in my case I have Visual Studio Express 2010); open the website that you are working with and click the tool icon, it's that simple.

    Thanks to all !! 

      

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Wednesday, October 7, 2020 6:32 PM