locked
Report Viewer 404 error RRS feed

  • Question

  • User1305081841 posted

    I am getting:

    <fieldset>

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

    </fieldset>

     From the report viewer that is in my asp.net site. The odd piece though is it pulls up the report parameters, and control panel allows me to select the different parameters, however when I click on view report I get the 404 message down in the actual report part.

    I have a simple viewer:

      

    <rsweb:ReportViewer ID="ReportViewer1" runat="server" Font-Names="Verdana" 
            Font-Size="8pt" Height="400px" ProcessingMode="Remote" Width="800px">
            <ServerReport ReportPath="/foldername/reportname" 
                ReportServerUrl="http://servername/reportserver" />
        </rsweb:ReportViewer>

     Any thoughts on why it will sorta pull the report but then not find the "results"?

    Thanks for all the help.

    Friday, October 24, 2008 9:25 AM

Answers

  • User1305081841 posted

     I added the impersonate account to the IIS_Users group and everything works fine. Baring I stay mindful of this, everything works just fine.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, October 28, 2008 2:31 PM

All replies

  • User-1315512054 posted

    Hello,

    Check here for solution: http://blog.yourdotnetsolution.com/2008/09/report-server-report-viewer-404-file-or.html

    Regards

    Friday, October 24, 2008 10:58 AM
  • User1305081841 posted

     Thank you. After making the changes mainly the addition of the handler in the web.config file. I now get a server error 500 back.

    Thoughts?

    Thanks

    Friday, October 24, 2008 12:50 PM
  • User1305081841 posted

     Ok, I added the changes to the web config, and now have this problem.

     

    Could not load file or assembly 'Microsoft.ReportViewer.Common' or one of its dependencies. Access is denied.

    I am using identity impersonate=true

    I have added the .dll / references to the project, but still get this error. If I make the account I am using for impersonation an admin on the webserver everything works perfectly. What rights does the impersonation account need in order to not get this error?

    Thanks

     

    Monday, October 27, 2008 3:50 PM
  • User1305081841 posted

     I added the impersonate account to the IIS_Users group and everything works fine. Baring I stay mindful of this, everything works just fine.

     

    • Marked as answer by Anonymous Thursday, October 7, 2021 12:00 AM
    Tuesday, October 28, 2008 2:31 PM
  • User819109694 posted

    you have to go to iis n add the particular report

    I am getting:

    404 - File or directory not found.

    The resource you are looking for might have been removed, had its name changed, or is temporarily unavailable.

     From the report viewer that is in my asp.net site. The odd piece though is it pulls up the report parameters, and control panel allows me to select the different parameters, however when I click on view report I get the 404 message down in the actual report part.

    I have a simple viewer:

      

    <rsweb:ReportViewer ID="ReportViewer1" runat="server" Font-Names="Verdana" 
            Font-Size="8pt" Height="400px" ProcessingMode="Remote" Width="800px">
            <ServerReport ReportPath="/foldername/reportname" 
                ReportServerUrl="http://servername/reportserver" />
        </rsweb:ReportViewer>

     Any thoughts on why it will sorta pull the report but then not find the "results"?

    Thanks for all the help.

    Thursday, October 30, 2008 2:04 AM
  • User-261937410 posted

    Hi,


    Thanks for sharing the solution. it worked for me. :)

    Sunday, January 10, 2010 3:39 AM
  • User-2061207276 posted

    Worked for me!! Thanks!

    Monday, January 17, 2011 7:00 PM
  • User-223646125 posted
    1. Open IIS 7 or 7.5
    2. Select the site to modify by double clicking, revealing all options.
    3. Double click on Handler Mappings
    4. Click Add Managed Handler
    5. Request path: Reserved.ReportViewerWebControl.axd
    6. Type: Microsoft.Reporting.WebForms.HttpHandler
    7. Name: Reserved-ReportViewerWebControl-axd
    8. Click OK to complete

    or follow instructions on the following link

    http://ericphan.info/blog/2008/12/8/reservedreportviewerwebcontrolaxd-not-found.html

    Tuesday, October 9, 2012 7:49 AM
  • User-223646125 posted

    -- OR --

    Visual Studio had edited the web.config based on the IIS 6.0 model and had made an entry for the Http Handler under the <httpHandler> section. With IIS 7.0 this section is no longer read. So we need to make the proper entries for the Http Handler that handles the calls to Reserved.ReportViewerWebControl.axd

    <system.webServer>

    <handlers>

    <add name="ReportViewerWebControl" path="Reserved.ReportViewerWebControl.axd" verb="*" type="Microsoft.Reporting.WebForms.HttpHandler, Microsoft.ReportViewer.WebForms, Version=9.0.0.0, Culture=neutral, PublicKeyToken=b03f5f7f11d50a3a"/>

    </handlers>

    </system.webServer>

     

    Tuesday, October 9, 2012 8:46 AM