none
Rendering Problem While Exporting to PDF RRS feed

  • Question

  • Hello,

    I'm having problem with rendering the report while exporting to PDF in Windows 7.

    I'm not using any code for exporting, simply using the inbuilt export feature of Report Viewer.

    The PDF is fine in Windows XP, but in Windows 7 (I've tried different systems) it doesn't renders properly.


    I'm using Visual Studio 2010 and RDLC Report for my needs.

    I'm also attaching 2 files, one exported in Windows XP and another exported in Windows 7 so that you can view what's wrong.


    PDF of Report when Exported in Windows XP : http://www.mediafire.com/?tcd6n36c0snoh29

    PDF of Report when Exported in Windows 7 : http://www.mediafire.com/?85i5yzqagq45c3x

    Friday, May 25, 2012 11:11 AM

Answers

  • Hi Krishnandu,

    I cannot view your files to see the problem. Making a guess....

    In older versions of RS, we did not embed fonts. If you are getting little blocks instead of characters, it is do to the fonts being installed or not installed on the local machine.


    Brad Syputa, Microsoft Reporting Services This posting is provided "AS IS" with no warranties.

    Tuesday, May 29, 2012 8:00 PM

All replies

  • Hi Krishnandu,

    I cannot view your files to see the problem. Making a guess....

    In older versions of RS, we did not embed fonts. If you are getting little blocks instead of characters, it is do to the fonts being installed or not installed on the local machine.


    Brad Syputa, Microsoft Reporting Services This posting is provided "AS IS" with no warranties.

    Tuesday, May 29, 2012 8:00 PM
  • Thanks. Yes I'm getting blocks instead of texts.
    Tuesday, July 24, 2012 2:46 PM