locked
one or more parameters were not specified for the subreport. RRS feed

  • Question

  • This error message show at my report. But all the main report data & sub report data show complete.
    Wednesday, February 29, 2012 12:26 PM

Answers

  • This error message hints that either the report parameter has not been passed from the parent report to the child report or that the wrong format of report parameter or an unacceptable value for the report parameter has been passed from the parent to the child report (I mean the subreport when I mean the child report). Can you check the report parameters that are being passed once again?

    Cheers,
    Jason
    P.S. : Please click the 'Mark as Answer' button if a post solves your problem! :)

    Some Random Thoughts

    Follow me on Twitter

    • Proposed as answer by Suhas Kudekar Monday, March 5, 2012 3:12 PM
    • Marked as answer by Zilong Lu Tuesday, March 6, 2012 3:00 AM
    Wednesday, February 29, 2012 3:50 PM
  •  Hi Giin,

    Thanks for your post.

    This error message indicates that you havnen’t specfiy all the parameter values for your subreport, I would suggest you to open the subreport properties window,and pay attention to the Parameters section, verify whether you had feed values for each parameters of your subreport.

    Thanks,
    Bill Lu


    Bill Lu

    TechNet Community Support

    • Proposed as answer by Suhas Kudekar Monday, March 5, 2012 3:12 PM
    • Marked as answer by Zilong Lu Tuesday, March 6, 2012 3:00 AM
    Monday, March 5, 2012 10:12 AM

All replies

  • This error message hints that either the report parameter has not been passed from the parent report to the child report or that the wrong format of report parameter or an unacceptable value for the report parameter has been passed from the parent to the child report (I mean the subreport when I mean the child report). Can you check the report parameters that are being passed once again?

    Cheers,
    Jason
    P.S. : Please click the 'Mark as Answer' button if a post solves your problem! :)

    Some Random Thoughts

    Follow me on Twitter

    • Proposed as answer by Suhas Kudekar Monday, March 5, 2012 3:12 PM
    • Marked as answer by Zilong Lu Tuesday, March 6, 2012 3:00 AM
    Wednesday, February 29, 2012 3:50 PM
  •  Hi Giin,

    Thanks for your post.

    This error message indicates that you havnen’t specfiy all the parameter values for your subreport, I would suggest you to open the subreport properties window,and pay attention to the Parameters section, verify whether you had feed values for each parameters of your subreport.

    Thanks,
    Bill Lu


    Bill Lu

    TechNet Community Support

    • Proposed as answer by Suhas Kudekar Monday, March 5, 2012 3:12 PM
    • Marked as answer by Zilong Lu Tuesday, March 6, 2012 3:00 AM
    Monday, March 5, 2012 10:12 AM