none
Create Access DB via file manager in 64 bit RRS feed

  • Question

  • Hi,

     

     

    Is there anyone aware of how to get the creation of Access DBs working via file manager when the websitepanel server is running with it's App pool in 64 bit mode? With the pool in 32 bit mode, access db creation works , other areas in the portal such as the website settings won't function, so it's a trade off. Any help appreciated/.

     

    Hughesh

    Wednesday, August 4, 2010 7:38 PM

Answers

  • I think we will add a check for 64-bit system and then just hide "Create DB" button.
    Feodor Fitsner - MSFT
    Thursday, August 5, 2010 8:32 PM
    Moderator

All replies

  • Hi Hughesh,

    I'm afraid it's impossible to use MS Access API in 64-bit mode. Would it make sense if we add hiding of "Create DB" button when running in 64-bit mode?

    Regarding web site settings - do you mean it's impossible to modify web site settings when WSP Server is running in 32-bit mode on 64-bit OS?


    Feodor Fitsner - MSFT
    Wednesday, August 4, 2010 10:13 PM
    Moderator
  • It could be possible but this would need to change some things inside WSP infrastructure and service distribution. Basically WSP Server should be installed by default with two webservices pointing to the same directory but one would be x86 and second x64. This can be done manually but after this change service distribution is going wild a little because OS and Web services are divided to different WSP Servers with different IDs in Enterprise DB. Like I said this could be done but it needs bigger infrastructure changes.
    Wednesday, August 4, 2010 10:25 PM
  • :) Yes, this trick might work.
    Feodor Fitsner - MSFT
    Wednesday, August 4, 2010 10:27 PM
    Moderator
  • Thanks for the replies.

     

     

    Feodor,  When the website panel server app pool is running in 32 bit mode on a 64 bit server,  the access db creation works fine as you know,  but the Web site settings option errors.   However the option to hide the access db creation is just as good an option for us as it will prevent confusion for customers.

     

    The error generated on web site settings is as follows:

     

     

    Page URL: https://controlpanelurl/Default.aspx?pid=SpaceWebSites&mid=78&ctl=edit_item&ItemID=669&SpaceID=185
    Logged User: serveradmin
    Work on Behalf: hughesh
    Hosting Space: 185
    Stack Trace: System.Web.Services.Protocols.SoapException: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> Filename: \\?\C:\Windows\system32\inetsrv\config\administration.config
    Error: The configuration section 'system.webServer/management/authorization' cannot be read because it is missing a section declaration


    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at WebsitePanel.Providers.Web.WebServer.GetSite(String siteId)
    at WebsitePanel.EnterpriseServer.WebServerController.GetWebSite(Int32 siteItemId)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.ReadResponse(SoapClientMessage message, WebResponse response, Stream responseStream, Boolean asyncCall)
    at System.Web.Services.Protocols.SoapHttpClientProtocol.Invoke(String methodName, Object[] parameters)
    at WebsitePanel.EnterpriseServer.esWebServers.GetWebSite(Int32 siteItemId)
    at WebsitePanel.Portal.WebSitesEditSite.BindWebSite()
    Thursday, August 5, 2010 7:59 AM
  • Hi Hughesh,

    When you switch application pool to x32 mode you cannot edit site settings because of Remote Management Feature for web sites which is required x64 mode for application pool for searching x64 nodes in register.

    Trick, described by Webio, has more details at this link.

    http://forum.dotnetpanel.com/forums/p/7219/30251.aspx#30251


    • Marked as answer by Hughesh Thursday, August 5, 2010 2:11 PM
    • Unmarked as answer by Hughesh Thursday, August 5, 2010 2:12 PM
    Thursday, August 5, 2010 1:25 PM
  • I think we will add a check for 64-bit system and then just hide "Create DB" button.
    Feodor Fitsner - MSFT
    Thursday, August 5, 2010 8:32 PM
    Moderator
  • I think this is the best option really.  It's a nice feature but not wholly required.
    Friday, August 6, 2010 7:59 AM
  • If you are planning to hide Access DB button then you should remember to check not if system is x64 type but for application pool setting since Access DB can be managed on x64 ssytem when all application pools are set to 32bit compatibility mode.
    Sunday, August 8, 2010 9:52 AM
  • How can I remove create MS ACCESS database button?
    NixGurus
    Wednesday, February 9, 2011 9:07 AM
  •  

    windows has two sets of system directories (for 32bit and 64bit applications):

    64bit: c:\windows\system32

    32bit: c:\windows\syswow64

     

    if your application pool is running in 32bit mode then your application pool tries to read "c:\windows\syswow64\inetsrv\config\administration.config" instead of "c:\windows\system32\inetsrv\config\administration.config" (even though the error specifies otherwise).

     

    a simple solution is to run the following commands (this will create a hard link for .config files within the 32bit directory to the 64bit/regular directory):

    mklink /H C:\Windows\SysWOW64\inetsrv\config\administration.config C:\Windows\System32\inetsrv\config\administration.config

    mklink /H C:\Windows\SysWOW64\inetsrv\config\applicationHost.config C:\Windows\System32\inetsrv\config\applicationHost.config

    mklink /H C:\Windows\SysWOW64\inetsrv\config\redirection.config C:\Windows\System32\inetsrv\config\redirection.config

     

    Best regards,

    Avi hirsh [SPD Hosting].

     

    • Proposed as answer by spdhosting Wednesday, April 6, 2011 3:01 AM
    Wednesday, April 6, 2011 3:01 AM
  • Hello,

    this is so simple and yet so great solution. Thank you.

    Wednesday, April 6, 2011 10:41 AM
  • Hello Avi,
    do you use Web App Gallery? When I try to use your fix for this problem I'm getting:
    Web Application Gallery module is unavailable: 
    - MsDeployIsNotInstalled 
    error in WSP. I was wondering if installing WebDeploy x86 could fix this problem but x86 version cannot be installed on x64 system.
    Any ideas?
    EDIT:
    MsDeply is checked using:
    public bool IsMsDeployInstalled()
    		{
    			//
    			try
    			{
        Assembly.Load(MS_DEPLOY_ASSEMBLY_NAME);
        return true;
    			}
    			catch
    			{
        // type could not be instantiated
        return false;
    			}
    		}
    
    MS_DEPLOY_ASSEMBLY_NAME is
    // MS Deploy library
      private const string MS_DEPLOY_ASSEMBLY_NAME = "Microsoft.Web.Deployment";
    
    so I'm not sure if this time it could be so easily fixed when using WSP Server in x86 mode.
    Maybe manually adding Microsoft.Web.Deployment x86 DLL to GAC could fix it?

    Thursday, April 7, 2011 8:48 AM
  • UPDATE:

    I've made a very nasty hack which will allow to use MsDeploy:

    		public bool IsMsDeployInstalled()
    		{
    			//
          /*
    			try
    			{
            Assembly.Load(MS_DEPLOY_ASSEMBLY_NAME);
            return true;
    			}
    			catch
    			{
            // type could not be instantiated
            return false;
    			}
          */
          return true;
    		}
    
    and it looks like it is working. I was able to instal DotNetNuke

     

    Thursday, April 7, 2011 6:09 PM