none
Outlook 2010 Add-in Won't Load RRS feed

  • Question

  • Hello,

    I built an Outlook 2010 Add-in in VSTO 2013 Professional. I'm using Windows installer to create a set-up project. 

    Default location of App Folder is set to [AppDataFolder][Manufacturer]\[ProductName] and registry keys are created under both HKCU\Software\Microsoft\Office\Outlook\Addins and HKCU\Software\Wow6432Node\Microsoft\Office\Outlook\Addins. 

    I am not excluding any detected dependencies. String value of Manifest is: [TARGETDIR]Addinname.vso|vstolocal and I am explicitly referencing .vsto and .dll.manifest files from my bin/release folder.

    Still, add-in won't load on any outlook 2010 apps and appears under "Inactive Application Add-ins" section.

    Add-in installs fine on two machines that have visual studio installed on them.

    Any ideas what could be causing this? Would appreciate any help.

    Thanks!

    Tuesday, July 15, 2014 5:24 PM

Answers

All replies

  • Hi TTAZO,

    There are a few steps you can take to diagnose this kind of issue: http://blogs.msdn.com/b/haahmadi/archive/2010/05/26/my-vsto-add-in-does-not-load.aspx

    Could you check what the LoadBehavior value is for your add-in? (Located at: HKCU\Software\Microsoft\Office\Outlook\Addins\[Your add-in name]\LoadBehavior )

    - Thomas Bombach

    Tuesday, July 15, 2014 5:38 PM
  • Hello,

    It looks like you use the Windows Installer for distributing the add-in. If so, please make sure that you did all the steps described in the Deploying an Office Solution by Using Windows Installer article in MSDN.

    Did you have a chance to check out the Disabled Items list? Is your add-in listed there?

    Microsoft Office applications can disable add-ins that behave unexpectedly. If an application does not load your add-in, the application might have hard disabled or soft disabled your add-in.

    Hard disabling can occur when an add-in causes the application to close unexpectedly. It might also occur on your development computer if you stop the debugger while the Startup event handler in your add-in is executing.

    Soft disabling can occur when an add-in produces an error that does not cause the application to unexpectedly close. For example, an application might soft disable an add-in if it throws an unhandled exception while the Startup event handler is executing.

    When you re-enable a soft-disabled add-in, the application immediately attempts to load the add-in. If the problem that initially caused the application to soft disable the add-in has not been fixed, the application will soft disable the add-in again.

    See How to: Re-enable an Add-in That Has Been Disabled for more information.

    Also you may find the following articles helpful:

    Troubleshooting common VSTO issues – Part 1

    Troubleshooting common VSTO issues – Part 2

    Tuesday, July 15, 2014 5:49 PM
  • Hi Thomas,

    and thanks for the follow up.

    LoadBehavior is set to 3, but it flips to 2 when add-in fails to load.

    I set VSTO_SUPPRESSDISPLAYALERTS to 0 to get the error message. 

    Error message:

    MySql.Data.MySqlClient.MySqlException (0x80004005): Unable to connect to any of the specified MySQL hosts.

    What do you think can be causing this? I know that the connection credentials are 100% since the add-in is working on my machine. I also re-tested the credentials in MySQL Workbench. Port 3306 is also open and is not getting "firewalled".

    Thanks


    Wednesday, July 16, 2014 7:58 PM
  • > LoadBehavior is set to 3, but it flips to 2 when add-in fails to load. 

    Most probably an exception is thrown at runtime/startup.  That's why your add-in is disabled by the host application automatically.

    Where do you store the connection string? See Error only occurs after publishing: “Unable to connect to any of the specified MySQL hosts.”

    Finally, make sure that you included all the required prerequisites to the add-in installer - .net framework and any other dependencies.

    Thursday, July 17, 2014 8:19 AM
  • Thanks Eugene,

    Issue is resolved. Firewall was blocking connection to the remote MySQL Host.

    Thanks again!

    Thursday, July 17, 2014 1:38 PM