locked
SSRS Report Charts do not auto-refresh but tables do RRS feed

  • Question

  • I have a report written on a SQL 2008 R2 server which has tables and charts in the report.

    It is set to auto-refresh every minute.

    When viewed in Internet Explorer 9 via the server or in Report Builder it auto-refreshes correctly.

    However when viewed on a Windows 8 PC using either Internet Explorer 10 or Firefox the report does not refresh the charts.

    The tables and other text update as expected but the charts do not change.

    This has been reported before in a few instances by other posters on MSDN, mainly relating to reports embedded in sharepoint.

    Their solutions are not suitable in this instance.

    Any assistance would be appreciated.

    Thursday, May 1, 2014 7:16 AM

Answers

All replies

  • Hi dlsa_spinsys,

    According to your description, you have set the report to refresh automatically and when view it through Internet Explorer 10 or Firefox, the charts doesn't refresh properly although the other tables and text refresh without problems.

    As per my understanding, I think this issue can be a javascript error with resizing image in browser. In this scenario, I suggest you can use a rectangle to contain the chart.

    Besides, the issue can be also caused by setting or third party add-ons of browser, we can run it in compatibility mode, then refer to the following thread:
    http://social.technet.microsoft.com/Forums/en-US/b0508bf0-1868-4fce-a08e-c8655b4f6f51/how-to-remove-white-space-from-a-list?forum=sqlreportingservices

    Thanks,
    Katherine Xiong


    Katherine Xiong
    TechNet Community Support

    Friday, May 2, 2014 3:06 AM
  • Hi,

    I attempted the fixes suggested above and nothing resolved the issue.

    We did find that running Chrome as the browser and an add-on called "cache killer" resolved the issue on one single machine only.

    The customer was happy temporarily until that machine was decommissioned and now we cannot get any machine to work with this report.

    The issue still remains which is that the text on the report will auto-refresh correctly but the charts do not change.

    This also happens when the report auto-refreshes within Report Builder.

    Is there any further suggestions you can make?

    Thanks

     

    Monday, August 18, 2014 7:32 AM