locked
MDS 2012 Excel add-in installation error RRS feed

  • Question

  • I'm trying to install the SQL Server 2012 RTM Master Data Services excel add-in (32 bit) on Windows 7.  Windows 7 and Office 2010 (32 bit) are all on the latest builds/service packs.  However I'm getting an error during installation "These prerequisites are not installed:  Microsoft .NET Framework 4.0 Extended 32-bit version of Microsoft Excel 2007 or 2010.  All prerequisites can be installed from: http://go.microsoft.com/fwlink/?LinkId=219530.  I checked the control panel and I seem to have .NET Framework 4.0 Extended  installed with the version 4.0.30319.  I repaired and also removed and re-installed .NET Framework 4.0 and was unable to resolve the issue.

    Tuesday, May 15, 2012 10:07 PM

Answers

  • I found that I was missing the following Security Updates for .NET Framework 4 (KB2572078, KB2518870, KB2416472, KB2487367 and KB2539636)

    and some updates (KB982671 and KB2468871)

    • Marked as answer by topsparky88 Wednesday, May 16, 2012 5:30 PM
    Wednesday, May 16, 2012 5:30 PM

All replies

  • give this a try (as referenced here)

    1. Uninstall .NET Framework 4.0 (Client Profile, Extended, and Multiple-targeting pack)
    2. Turn off .NET 35 in OS feature (Turn Windows Features On or Off)
    3. Re-enable .NET 35 in OS feature;
    4. Install Excel Add-in
    5. Reinstall .NET 4.0
    Wednesday, May 16, 2012 2:43 PM
  • Appreciate the response.  I gave it a try and got a similar error message.

    Wednesday, May 16, 2012 3:25 PM
  • I found that I was missing the following Security Updates for .NET Framework 4 (KB2572078, KB2518870, KB2416472, KB2487367 and KB2539636)

    and some updates (KB982671 and KB2468871)

    • Marked as answer by topsparky88 Wednesday, May 16, 2012 5:30 PM
    Wednesday, May 16, 2012 5:30 PM
  • Hi may u please help me how to install these security update?
    Wednesday, October 9, 2013 7:34 AM
  • Hi

    In my case I only had to run the install from command line as administrator. Here is more info.

    Take care

    Emil

    Monday, July 28, 2014 10:28 AM