none
EDGE Browser not working with Microsoft RemoteApp and ignores X-UA-Compatible IE=9 RRS feed

  • Question

  • I know that IE 11 did not work with Microsoft RemoteApp server but IE 11 would read the X-UA-Compatible IE=9 and then render correctly.

    EDGE seems to ignore the X-UA-Compatible IE=9 and does not work at all with Microsoft RemoteApp.
    Since Windows 10 is using EDGE as the default, we are having to go into the control panel and changing the default browser to IE.

    Any fix besides changing the default browser to IE in the control panel?

    Friday, July 31, 2015 1:35 PM

All replies

  • Hi,

    for Intranet support of legacy (requiring IE emulation of a lower IE version) you should be using Enterprise Mode lists.

    Stay up-to-date with Enterprise Mode for IE11 (and Win7,8 or X)

    True, MS Edge ignores x-ua meta, headers and does not use the MSCVL (Microsoft Compatibility view lists) or IE's Compatibility View list, but uses the Enterprise Mode lists to prompt the user to switch to IE for Intranet sites on the Enterprise Mode list. MS Edge also ignores showModalDialog (if that's what you mean?)

    Most commonly, your web pages may be using userAgent sniffing (or an older version of a framework (jquery, dojo, extjs which does eg. jquery.browser). OR you are using a web document with no doctype declaration, but which still uses legacy features like css expressions, vml, or IE conditional comments.

    If possible please include a link to your website or a mashup with your questions for us to investigate.

    Regards.


    Rob^_^

    Saturday, August 1, 2015 12:56 AM
  • I downloaded the "Enterprise Mode Site List Manager". 
    http://www.microsoft.com/en-us/download/details.aspx?id=42501

    Saved the URL in IE8 Enterprise Mode to sites.xml.
    Placed the sites.xml on our web server.

    Then I used group policy to add the EnterpriseMode to the registry
    https://technet.microsoft.com/en-us/library/dn640699.aspx

    None of this seems to work with EDGE browser.

    Monday, August 3, 2015 1:38 PM
  • Hi,

    It(MS Edge) should prompt to open in IE11.

    Test with IE11 first. Use the Emulation tab or Console tab of its Dev Tool to confirm that it is reading the Enterprise Mode site list.


    Rob^_^

    Tuesday, August 4, 2015 7:52 AM