locked
MDS- Staging tables update RRS feed

  • Question

  • I'm a SQL developer learning MDS.I loaded some entities via staging tables and via  Excel add-in.

    I'm trying to update members in an entity in MDS via the staging table. I can successfully add new members, but any attribute updates to existing members  aren't populated to the entity view. The import process runs successfully with no errors. I've tried ImportType =0 and 2, neither works. When I set to 1, as expected I get an error. I also tried to update the code value using the NewCode column and that also does not get updated.  I've set up staging data with an SSIS package, and also with direct T-SQL INSERT INTO statement.  I am using almost the same T-SQL INSERT statement for a test entity which I created to load a  new member , and then to modify attributes for the new member in a second batch.  Do you have any ideas why the updates would be ignored, or suggestions for things I can try?


    Vibha

    Wednesday, December 23, 2015 7:57 PM

Answers

  • I got this issue resolved. Batch_ID was given incorrectly, which didn't allow the update and each time when I processed the SSIS Package new batch was inserted instead of updating.

    Vibha

    Monday, January 4, 2016 4:13 PM

All replies

  • have used conversion while tranfering data in mssql ?

    https://www.mssqltips.com/sqlservertip/1393/import-excel-unicode-data-with-sql-server-integration-services/

    What are doing in ssis ?share code..


    Please click Mark As Answer if my post helped.

    Friday, December 25, 2015 12:56 PM
    Answerer
  •  loading data Sql tables to MDS staging tables.

    Vibha

    Tuesday, December 29, 2015 4:30 PM
  • I got this issue resolved. Batch_ID was given incorrectly, which didn't allow the update and each time when I processed the SSIS Package new batch was inserted instead of updating.

    Vibha

    Monday, January 4, 2016 4:13 PM
  • Hi Vibhaa,

    Glad to hear that your issue had been solved, please mark your reply as answer, it will help for others who have similar issue.

    Thank you for your sharing.

    Regards,


    Charlie Liao
    TechNet Community Support

    Monday, January 11, 2016 2:27 AM
  • I'm having the same issue...when you mean Batch_ID was given incorrectly is in the stored procedure when transferring data from staging into the MDS prod tables? I have an SSIS package that runs the stored procedures and it's adding another batch even when using ImportType 2. Can you please advise. Thanks!
    Monday, October 30, 2017 2:49 PM