none
VS 2012 - Outlook Form Region error RRS feed

  • Question

  • In the last couple weeks a Outlook 2010 form region developed a couple years ago using VS 2010 stopped working suddenly.  I am using VS 2012 now and tried creating a blank form region and tried running the project only to receive the same error from Outlook - I can not trap the error in VS 2012.  The error reads "The form region "Outlookaddin1.FormRegion1" cannot be opened.  An add-in returned an invalid value while loading the form region storage." 

    Has some security patch been released to cause this issue?


    • Edited by Bob Pig Wednesday, November 26, 2014 3:56 AM
    Wednesday, November 26, 2014 3:54 AM

All replies

  • Hello Bob,

    The page describes exactly the same issue. It seems you need to clear the forms cache.

    You may find the following links helpful:

    How Outlook 2007 uses the forms cache and how to troubleshoot forms cache problems

    Understanding the Forms Cache

    How the Outlook forms cache works

    Wednesday, November 26, 2014 5:15 AM
  • Thank you for taking the time to reply Eugene.

    I have tried all the suggestions, but still have the same error.

    Thursday, November 27, 2014 12:01 AM
  • Hello Bob,

    > I am using VS 2012 now and tried creating a blank form region Could you please be more specific? How did you create a form region? Do you use a legacy form (.OFS) designed in Outlook or a user control created in Visual Studio?

    See Creating Outlook Form Regions for more information.

    Thursday, November 27, 2014 11:46 AM
  • Hello Eugene,

    I am creating a Outlook 2010 add-in using VS 2012, I then add a Outlook form region and associate it to an appointment item.  Add a random control and then press F5 to run the project, the add-in appears in the Outlook start up screen, but opening it from a calendar results in the error mentioned.

    Thanks for your help.

    Tuesday, December 2, 2014 11:26 PM
  • I don't get such message on my PC. Do you have any other add-ins installed for Outlook?
    Wednesday, December 3, 2014 12:44 PM
  • Thanks for the reply.

    My whole team is now experiencing this problem except one person (he is on Outlook 2007), so it must be related to some new patch. 

    Current Add-ins loaded :

    Business Connectivity Services Add-in
    Microsoft Exchange Add-in
    Microsoft Outlook Social Connector
    Microsoft Sharepoint Server Connector
    Microsoft Sharepoint Workspace Proxy for Outlook Add-in
    OneNotes About Outlook Items


    • Edited by Bob Pig Thursday, December 4, 2014 11:57 PM
    Thursday, December 4, 2014 11:02 PM
  • Did you have a chance to disable all add-ins? Do you get any errors in that case?

    Could you please also specify the build numbers and bitness of your Outlook?

    Friday, December 5, 2014 12:38 PM
  • Please excuse the late reply Eugene, I was on leave.

    I have tried disabling all the add-ins except for the Microsoft  Exchange add-in and still receive the same error.

    Outlook build version details = Version 14.07.7128.5000 (32-bit)

    Tuesday, December 9, 2014 1:12 AM