locked
The attachable property 'BottomAppBar' was not found in type 'Page'

    Question

  • Hi,

    Still working on my first app - and seems we are going to be on this for a long time still.

    Especially after this Error showed up;

    "The attachable property 'BottomAppBar' was not found in type 'Page'"

    I can't remember I have done anything lately - except playing around with my "Grid" setup - but all builds correctly - just now with this error ?

    What is going on? Anyone?


    Regards, Kato.

    Thursday, June 19, 2014 7:47 PM

Answers

  • I did find a solution with deleting a file called <appname.Windows_StoreKey> from my app.windows project.

    And my error from above is GONE!

    Next!


    Regards, Kato.

    Friday, June 20, 2014 1:58 PM

All replies

  • Does it build and run? 

    Did you try a clean then a rebuild from the Build menu?

    Thursday, June 19, 2014 9:24 PM
  • Hi Kato,

    You mean when you add the BottonAppBar to the XAML but you cannot access that one from your code?

    That's normal, you have to save the xaml before you trying to access the page from backend.

    However if your build works fine, that means your app is totally correct from syntax.

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Friday, June 20, 2014 2:19 AM
    Moderator
  • Hi - Yes it builds and runs.

    I keep thinking I have some error in my xaml that I just cant see and find. And my AppBar works great too.

    And I have started a Read around dependency properties - to see if something breaks.

    My error is pointing to this line in my xaml code. The first CommandBar.PrimaryCommands line.

    <AppBarButtonx:Uid="Refresh"Label="Refresh"Icon="Refresh"Click="AppBarButtonRefresh_Click"/>

    But see or understand no error it refers to - besides the error message;

    "The attachable property 'BottomAppBar' was not found in type 'Page'".

    Still - I have no idea why I get this error, and will be on it until it breaks!

    Any clues anyone?

     

      


    Regards, Kato.

    Friday, June 20, 2014 8:34 AM
  • And funny thing is - if I squeeze my code together and remove "whitespaces" - after rebuild, the "error" is still at the same line and column number...

    This feels like a bug now....

    Anyone?


    Regards, Kato.

    Friday, June 20, 2014 12:44 PM
  • And after a restart of Visual Studio 2013 and a reload of my project - the VS2013 crashes while loading the project.

    What a start of the weekend....


    Regards, Kato.

    Friday, June 20, 2014 12:49 PM
  • After a restar of my machine - I still get a cash when loading my project and VS restarts every time.

    Keeps thinking that my app manifest is damaged after linking app to store - and another realink after Capital letter namechange in App-Name.

    Any thoughts or way to reset a project...? Remove the Bin maybee...

    Thanks for any input on this.


    Regards, Kato.

    Friday, June 20, 2014 1:16 PM
  • I did find a solution with deleting a file called <appname.Windows_StoreKey> from my app.windows project.

    And my error from above is GONE!

    Next!


    Regards, Kato.

    Friday, June 20, 2014 1:58 PM
  • Hi Kato,

    So the problem solved?

    --James


    <THE CONTENT IS PROVIDED "AS IS" WITHOUT WARRANTY OF ANY KIND, WHETHER EXPRESS OR IMPLIED>
    Thanks
    MSDN Community Support

    Please remember to "Mark as Answer" the responses that resolved your issue. It is a common way to recognize those who have helped you, and makes it easier for other visitors to find the resolution later.

    Monday, June 23, 2014 9:49 AM
    Moderator