locked
Help! Server object error 'ASP 0177 : 8000ffff' RRS feed

  • Question

  • User-1877713439 posted

    I created a COM interop class library that I want to call from classic ASP. The class library is actually a wrapper for a .NET assembly log4net, it has a Guid and ClassInterfaceType.None. I generate a strong name for it using sn -k and I make it a signed assembly before building it

     I put it on a server running windows server 2003. It is placed in a directory where the Internet Guest Account, IUSR_machinename has full control.

     In IIS the execute permissions is set to scripts only. The ASP .NET version is 1.1.4322.

     I call regasm on it in the c:\windows\microsoft.net\framework\v1.1.4322\regasm

    The types are registered correctly, now I created a test web page that does

    Set Obj = Server.CreateObject("ClassLibrary1.Class1")

     When I hit that web page I get the error

    Server object error 'ASP 0177 : 80070002'

    Server.CreateObject Failed

     so I regasm it using /codebase flag and try again

    regasm mylib.dll /codebase

     This time when I hit the page I get the error

     

    Server object error 'ASP 0177 : 8000ffff'

    Server.CreateObject Failed

    I have been able to get it to run before, but after some time it just starts to fail. Any have any ideas?
     

    Wednesday, August 22, 2007 3:51 PM

Answers

All replies

  • User-1853252149 posted

    A quick search of the forums came up with:

    http://forums.iis.net/t/1031422.aspx

    Jeff

    • Marked as answer by Anonymous Tuesday, September 28, 2021 12:00 AM
    Thursday, August 23, 2007 9:21 AM
  • User-1362212145 posted

    Did you ever resolve this? I am having the sample problem, it worked when I first developed it, then I built the dll again and now it gives the error, its almost as if the registry is messed up?

     

    Cheers

    Garry

    Thursday, August 30, 2007 12:39 PM
  • User-1877713439 posted

    I have managed to get it working. Although some steps I did may be omitted to get it to work, here is what I did.

     1. I did a regasm /unregister on the dll but it seemed that entries still existed in the registry. So I used regedit and I removed all the entries to the GUID and progID in the registry.
     2. I rebuilt the dll using a different progID, strong name key file, and GUID.

     3. I copied it onto the machine and did regasm /codebase on it.

     4. I added the assembly and the assembly it was dependant upon, the log4net assembly, to the global assembly cache. I did it using the Microsoft .NET Framework Configuration in Administrative Tools. You can also do it using gacutil -i command.
     5. I rebooted the computer.

    I think the key steps for me to get it working was adding it to the global assembly cache then rebooting the computer. All the errors seemed to have gone away after the reboot. After I rebuilt the dll under a different progID I never went back to the old dll.
     

    Thursday, August 30, 2007 12:59 PM
  • User1504996854 posted

    Hi guys, I finally solved the problem. It is an issue more or less documented by Microsoft in the following links:

    http://www.microsoft.com/technet/security/bulletin/ms07-045.mspx
    http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=294241
    http://support.microsoft.com/kb/937143

    The problem is an automatic update from IE7, specifically 937143. Just uninstall this update and voila!.

    Good luck.

    Tuesday, September 25, 2007 10:15 AM
  • User-2112644629 posted

    Thanks, Minhau.

     Your post sent me to the right direction.  For me, it worked for me after I did only steps 1, 2, and 3.

     

    Saturday, January 26, 2008 3:54 PM
  • User1504996854 posted

    Hi, I found another workaround for this problem because uninstalling KB937143 seems not to be a good idea since it is a security patch:

    "Give the IUSR (or whoever your site is running as) read access to HKEY_USERS\S-1-5-20\Software\Microsoft\Windows\CurrentVersion\Internet Settings\Zones - this key might change depending on who your app pool is running as (default is Network Service [aka S-1-5-20])"

    Taken from : http://connect.microsoft.com/VisualStudio/feedback/Workaround.aspx?FeedbackID=294241

    It works fine.

    Thursday, February 28, 2008 10:06 AM
  • User-432247024 posted
    Hi, I did above mentioned changes and it worked for 20 days on production, this problem is intermittent, sometimes comes and crashes IIS and sometimes it comes with few users then disappears automatically. I tried to see http://connect.microsoft.com/VisualStudio/feedback/ViewFeedback.aspx?FeedbackID=294241<?xml:namespace prefix = o ns = "urn:schemas-microsoft-com:office:office" /><o:p></o:p>Where one guy saying that there is now a hotfix available (KB945701). Further I Google on web and found  <o:p></o:p>http://support.microsoft.com/kb/945701 where I’m unable to get hotfix download for windows server 2003 E.E. On this site the link is incorrect and following me to an advance search page where there is no way to get this hotfix for windows server 2003, only xp and vista downloads are available from the top link on this page. I would like if someone faced this issue and has any idea how to get this hotfix? One another problem is that the hotfix updates urlmon.dll with latest version. On this same page its written that The hotfix that is described in this article is included in security update 950759 (MS08-031). When I saw this security update it has urlmon older version after apply 950759. This is creating inconsistency. Please have a look on this too.<o:p></o:p><o:p> </o:p>http://support.microsoft.com/kb/945701 <o:p></o:p>

    File name<o:p></o:p>

    File version<o:p></o:p> File size<o:p></o:p> Date<o:p></o:p> Time<o:p></o:p> Platform<o:p></o:p>
    Urlmon.dll<o:p></o:p> 7.0.6000.20733<o:p></o:p> 1,162,752<o:p></o:p> 06-Dec-2007<o:p></o:p> 19:32<o:p></o:p> x86<o:p></o:p>
    <o:p> </o:p>The version of urlmon.dll on my server is :<o:p></o:p><o:p> </o:p>C:\Windows\system32\urlmon.dll <o:p></o:p>7.0.6000.16762<o:p></o:p><o:p> </o:p>

    Whether it is correct or not. Please verify.

    <o:p> </o:p>

     

    Tuesday, February 10, 2009 5:25 AM
  • User825046242 posted

    KB950759 replaces KB945701. 

    Monday, February 16, 2009 8:49 AM